Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox is giving me Troubleshooting Steps that don'e exist on my Firefox?

  • 4 பதிலளிப்புகள்
  • 1 இந்த பிரச்சனை உள்ளது
  • 7 views
  • Last reply by jscher2000

Ok so the question I was originally asking is why Firefox won't adjust to my computers Settings. For instance I have to Zoom to 150% to read my emails even though the minimum font size is set 20. So I went on the Help page and it kept giving direction do Refreshing the page, which I believe I've done before but the tutorial said they've changed the way it looks and where its at and unfortunately on my current, newest version, Firefox its nowhere. For starters, click on the 3 lines ie the Menu Bar on the right, good, then go down to Help, no Help listed in the Drop-Down Menu, No Troubleshooting, no More Tools? I am stuck? Ok under Share Data it says "safe-mode false" ?

All Replies (4)

You can set layout.css.devPixelsPerPx to 1.0 (default is -1) on the about:config page. Adjust its value in 0.1 or 0.05 steps (1.1 to enlarge or 0.9 to reduce) until icons or text looks right. Make sure not to use values too large or too small.

  • modifying layout.css.devPixelsPerPx affects user interface and webpages (global zoom)

Firefox has a Zoom section in Settings to set the default zoom level for webpages.

  • Settings -> General -> Language and Appearance -> Zoom

You can open the about:config page via the location/address bar. You can click the button to "Accept the Risk and Continue".

Helpful?

I think you are might be talking about a Refresh which removes all your add-ons and custom settings. Refresh Firefox - reset add-ons and settings Is that the one you're looking for? Probably you should save that for later after trying less extreme measures, but if you are at the end of your rope, it's an option.

Global zoom versus page zoom:

If your Windows 7 Text Size setting is 150%, Firefox should automatically use that as the baseline for calculating the size of everything. cor-el mentioned where you can override that behavior by changing -1 (meaning, follow the system) to a specific global zoom level.

If you can read the user interface text (for example, tabs, address bar, menus), then you don't need to change the global zoom level, it would make more sense to focus on the page zoom level. cor-el mentioned where you can set a new baseline on the Settings page if it's tiresome to adjust every individual site.

Font size settings versus zoom:

Using a minimum font size setting above 10 can distort page layouts because Firefox enlarges the text within the prescribed space rather than expanding the space, and therefore on tightly defined layouts, tops and bottoms of letters will cut off. Zoom generally works much better, but I guess not on every site.

Missing menu items:

Users with older laptops and monitors sometimes have lower resolution LCD panels that can cause some menus to run off the bottom of the screen or require scrolling -- especially if the system text size is more than 100%. If you think this could explain missing items on your main menu, try calling up the "classic" Help menu from the top menu bar by pressing Alt+H and see whether you can get to the Troubleshooting Page that way.

Helpful?

How many times do you need to sign into Firefox to do anything? So I really wish people would read the whole message before replying to it. And first off I'm a frequent computer user for 20+ years but I am in no way an expert so that first answer might as well have been in Japanese and the second answer, thank you, I honestly though I put that there is no Refresh icon anywhere that I can find, there is also no Help option so I can't get to the More Tools which, according to Mozilla's troubleshooting, is how i get to he Refresh button. And i too remember when it was on the taskbar next to the Home button/icon. oh and the font issue just started yesterday. I have my Computer settings on 20 Tahoma and 120% Zoom which shouldn't cause any issues that I'm aware of. And the problem is that Firefox completely ignores what the computer says the fonts should be and it ignores its own Settings when I tried changing those. And the fonts all over the place, in my gmail for example the headers and incoming messages are like 18 font I think but if i reply to a email the font jumps up like 30 or I guess Large if that was in my gmail settings which it is not. So I'm stumped, I've also had to add a Google Browser because Firefox won't run Closed Captions or even stream a video half the time.

Helpful?

First, please do not rely on old forum threads for menu items because as you know, the interface changed a few months ago.

sercouwis2004 said

And i too remember when it was on the taskbar next to the Home button/icon.

The Reload button? If it's not visible, check in the Customize panel to see whether it has returned to the box of available buttons. That tab also has a "Restore Defaults" button at the bottom to return your toolbars to their original "factory" layout. More info: Customize Firefox controls, buttons and toolbars.

oh and the font issue just started yesterday. I have my Computer settings on 20 Tahoma and 120% Zoom which shouldn't cause any issues that I'm aware of. And the problem is that Firefox completely ignores what the computer says the fonts should be and it ignores its own Settings when I tried changing those.

To get Firefox to honor modified system fonts, you can switch this setting:

Windows Font Substitutions

Firefox 89 changed how Firefox uses the system's font substitutions table. Previously, the substitutions were used to override requested fonts, but starting in Firefox 89, they are used if the requested font isn't available. You can try changing the following preference to revert to the old behavior and see whether this resolves the interface font issue with your Firefox:

The Moderators Want You To Know: Hidden settings edited using the about:config tool are explicitly not supported, which means that Mozilla makes no guarantees they will be supported in the future, or that Mozilla will fix them if they break. Mozilla does not test these preferences, and will not in the future. That includes security and performance testing which these preferences may affect.

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

(2) In the search box in the page, type or paste gfx.windows-font-substitutes.always and pause while the list is filtered

(3) Double-click the preference to switch the value from false to true -- you might need to do a regular exit/restart of Firefox for that to take effect, I don't have a way to test this

Did that make any difference?

More info on about:config: Configuration Editor for Firefox.

And the fonts all over the place, in my gmail for example the headers and incoming messages are like 18 font I think but if i reply to a email the font jumps up like 30 or I guess Large if that was in my gmail settings which it is not.

I suggest using zoom and not trying to manually set font sizes on websites.

Helpful?

கேள்வி எழுப்பு

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.