On Aug 14th 11 PM ET/Aug 15th 03:00 UTC, due to scheduled Firefox Account server maintenance, users may not be able to sign in or create a new subscription. This is expected to last approximately 30 minutes. Status updates can be found at https://status.vpn.mozilla.org or https://status.relay.firefox.com.

Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

about:logins is not showing my credentials

  • 11 பதிலளிப்புகள்
  • 1 இந்த பிரச்சனை உள்ளது
  • 21 views
  • Last reply by cor-el

I have many passwords saved in Firefox but after 93 update, there is nothing in about:logins. Although autofill works fine.

I have many passwords saved in Firefox but after 93 update, there is nothing in about:logins. Although autofill works fine.
Attached screenshots

All Replies (11)

Start Firefox in Troubleshoot Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration or userChrome.css is causing the problem.

  • switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Themes
  • do NOT click the "Refresh Firefox" button on the Troubleshoot Mode start window

You can check the Browser Console for login related messages when you open Lockwise (about:logins).

You can temporarily set signon.debug = true on the about:config page for troubleshooting purpose. Do not forget to reset signon.debug once you are done testing.

Firefox 80+ has a logins-backup.json file in the profile folder that can be used in case of issues with logins.json or to undo an accidental delete of a login, so you can check if you can find this file in the profile folder or in a backup and replace the current logins.json. Make sure to keep a backup copy of all involved files (logins.json and key4.db and logins-backup.json)

You can use the button on the "Help -> More Troubleshooting Information" (about:support) page to go to the current Firefox profile folder or use the about:profiles page.

Help -> More Troubleshooting Information -> Profile Folder/Directory: Windows: Open Folder; Linux: Open Directory; Mac: Show in Finder https://support.mozilla.org/en-US/kb/profiles-where-firefox-stores-user-data

If you use a Primary Password then you can prevent losing passwords by canceling the PP prompt. You need to logout beforehand by canceling a PP prompt, e.g. by clicking the eye icon in Lockwise (about:logins).

In the event that the passwords information is lost, you should record all information in a separate text file somewhere else on your hard drive, or written down. You can easily copy and paste if you need to do so. If you are concerned about someone else looking at that file, you can compress it using a password.


Password:Recovery:Restore:Export https://www.ghacks.net/2018/07/18/how-to-export-firefox-passwords-in-firefox-57/ +++++++++++++++++++++++++++++++++++++++++ http://www.nirsoft.net/utils/passwordfox.html (Win) PasswordFox v1.58 - Extract the usernames/passwords stored in Firefox Copyright (c) 2008 - 2017 Nir Sofer

Note: Some anti-virus show false positive. +++++++++++++++++++++++++++++++++++++++++ Easily export your passwords from Firefox. https://github.com/kspearrin/ff-password-exporter

Export your passwords from Firefox in a portable CSV or JSON format. It works on Windows, macOS, and Linux. +++++++++++++++++++++++++++++++++++++++++ 3 Tools to Decrypt and Recover Passwords Saved in Firefox • Raymond CC https://www.raymond.cc/blog/how-to-find-hidden-passwords-in-firefox/ +++++++++++++++++++++++++++++++++++++++++ https://www.ghacks.net/2018/07/18/how-to-export-firefox-passwords-in-firefox-57/ +++++++++++++++++++++++++++++++++++++++++ https://github.com/kspearrin/ff-password-exporter +++++++++++++++++++++++++++++++++++++++++ If you don't find a third party script or program you can trust, you can run a script in Firefox's Browser Console to spit out the list in CSV or JSON format. For example:

JSON file: https://support.mozilla.org/questions/1258644

CSV: https://support.mozilla.org/questions/1253828 (copy/paste from console)


chrome://passwordmgr/content/passwordManager.xul

chrome://passwordmgr/content/passwordManager.xhtml

I believe I have the same problem (FF 93, Windows 10). I have found that if I wait for 1-5 minutes, the page is actually populated with the passwords as expected, so it just takes forever to load. I have many passwords stored, but I did not have this problem before V93.

(a) said

I believe I have the same problem (FF 93, Windows 10). I have found that if I wait for 1-5 minutes, the page is actually populated with the passwords as expected, so it just takes forever to load. I have many passwords stored, but I did not have this problem before V93.

Exactly exactly. Same happens to me.

Start Firefox using Troubleshoot(Safe) Mode {web link}

A small dialog should appear. Click Start In Troubleshoot(Safe) Mode (not Refresh). Is the problem still there?

How many logins do you have if you open logins.json in a Firefox tab to check the file in the built-in JSON Viewer ?

You can use the button on the "Help -> More Troubleshooting Information" (about:support) page to go to the current Firefox profile folder or use the about:profiles page (Root directory).

cor-el said

How many logins do you have if you open logins.json in a Firefox tab to check the file in the built-in JSON Viewer ? You can use the button on the "Help -> More Troubleshooting Information" (about:support) page to go to the current Firefox profile folder or use the about:profiles page (Root directory).

I have 491 logins currently.

FredMcD said

Start Firefox using Troubleshoot(Safe) Mode {web link} A small dialog should appear. Click Start In Troubleshoot(Safe) Mode (not Refresh). Is the problem still there?

Yup, It is still there. I even refreshed the Firefox.

You can try to temporarily set signon.debug = true on the about:config page. Check the Browser Console for login related messages after you open about:logins.

Do not forget to reset signon.debug to false once you are done testing.

You can open the about:config page via the location/address bar. You can click the button to "Accept the Risk and Continue".