Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Fonts incorrectly displaying in all bold text on some websites

  • 5 பதிலளிப்புகள்
  • 1 இந்த பிரச்சனை உள்ளது
  • 696 views
  • Last reply by FredMcD

On some websites the fonts are all displaying in a large bold text instead of whatever font that page is meant to use. It will revert to a default font if i turn off the ability for sites to choose their own fonts, but this interferes with the functionality of a lot of sites' icons so its not a great solution. This also stops when i go into troubleshooting mode, but when i went through hardware acceleration and my extensions one by one, none of them were the cause.

images in order: my roll20 homepage with the incorrect font display, the same page with fonts disabled (note the notification icons in the upper right are broken now though), the same page in troubleshoot mode with the correct font display

On some websites the fonts are all displaying in a large bold text instead of whatever font that page is meant to use. It will revert to a default font if i turn off the ability for sites to choose their own fonts, but this interferes with the functionality of a lot of sites' icons so its not a great solution. This also stops when i go into troubleshooting mode, but when i went through hardware acceleration and my extensions one by one, none of them were the cause. images in order: my roll20 homepage with the incorrect font display, the same page with fonts disabled (note the notification icons in the upper right are broken now though), the same page in troubleshoot mode with the correct font display
Attached screenshots

தீர்வு தேர்ந்தெடுக்கப்பட்டது

[v56+] Type about:preferences#general<enter> in the address bar. Under fonts and colors, press the Advanced button. Scroll to the bottom, turn on Allow Web Sites To Choose Their Own.

Make sure you haven't enabled a High Contrast theme in the OS settings.

We have seen reports that this can be caused by a problem with fonts like Roboto or Helvetica that you have installed locally and that might be corrupted or are missing some variants. Also, make sure you allow pages to choose their own fonts and that you do not block remote (downloadable) fonts.

Read this answer in context 👍 0

All Replies (5)

I've never had this particular problem with the fonts, so I could guess you've selected a font that has only a bold vision to be your default font. Troubleshooting mode ususally removes all user settings, fonts included, that's why the font appears OK in that mode. Which is why I think you've simply chosen the wrong font. I have solved the fonts problems on my FF like this: • chosen default font is Open Sans. • installed extension: https://addons.mozilla.org/en-US/firefox/addon/enforce-browser-fonts/ When the page vision looks broken, I click the icon of the extension and it switches to fonts from the page. Such a broken view is with Google Translate. This extension works on a site by site basis.

rado84 said

I've never had this particular problem with the fonts, so I could guess you've selected a font that has only a bold vision to be your default font. Troubleshooting mode ususally removes all user settings, fonts included, that's why the font appears OK in that mode. Which is why I think you've simply chosen the wrong font. I have solved the fonts problems on my FF like this: • chosen default font is Open Sans. • installed extension: https://addons.mozilla.org/en-US/firefox/addon/enforce-browser-fonts/ When the page vision looks broken, I click the icon of the extension and it switches to fonts from the page. Such a broken view is with Google Translate. This extension works on a site by site basis.

Its not that, i haven't messed with the default fonts at all, they're all set to the ones firefox starts with. I did double check in case i had accidentally clicked something in there but its all normal. Fwiw, i'm calling this error 'bold' font but i cant tell if its showing it as, ie, actually a regular font with a bold effect turned on, or a font like Impact or similar that has that very heavy always-bold look.

தீர்வு தேர்ந்தெடுக்கப்பட்டது

[v56+] Type about:preferences#general<enter> in the address bar. Under fonts and colors, press the Advanced button. Scroll to the bottom, turn on Allow Web Sites To Choose Their Own.

Make sure you haven't enabled a High Contrast theme in the OS settings.

We have seen reports that this can be caused by a problem with fonts like Roboto or Helvetica that you have installed locally and that might be corrupted or are missing some variants. Also, make sure you allow pages to choose their own fonts and that you do not block remote (downloadable) fonts.

FredMcD said

[v56+] Type about:preferences#general<enter> in the address bar. Under fonts and colors, press the Advanced button. Scroll to the bottom, turn on Allow Web Sites To Choose Their Own. Make sure you haven't enabled a High Contrast theme in the OS settings. We have seen reports that this can be caused by a problem with fonts like Roboto or Helvetica that you have installed locally and that might be corrupted or are missing some variants. Also, make sure you allow pages to choose their own fonts and that you do not block remote (downloadable) fonts.

The 'Allow Web Sites To Choose Their Own. ' was already on by default, i mentioned in the original post that turning it OFF fixed this but then had the problem with icons. The conflicting local font file thing seems to have done it though, i uninstalled helvetica and the page looks normal now, thank you!

Glad to help. Safe Surfing.