Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox 90 : focus on the adress bar instead of the central search bar in the page

  • 10 பதிலளிப்புகள்
  • 1 இந்த பிரச்சனை உள்ளது
  • 19 views
  • Last reply by cor-el

Hi,

When i open a new tab, i want to start my research in the central search bar of the home page, not in the adress bar.

So in firefox 89, i put the parameter "browser.newtabpage.activity-stream.improvesearch.handoffToAwesomebar" to false. And it worked.

With firefox 90, it dit not work anymore.

How can i retrieve the previous behaviour ?

Thanks.

Hi, When i open a new tab, i want to start my research in the central search bar of the home page, not in the adress bar. So in firefox 89, i put the parameter "''browser.newtabpage.activity-stream.improvesearch.handoffToAwesomebar"'' to false. And it worked. With firefox 90, it dit not work anymore. How can i retrieve the previous behaviour ? Thanks.

All Replies (10)

The "browser.newtabpage.activity-stream.improvesearch.handoffToAwesomebar" pref should still work in Firefox 90.0 (works for me).

Did you make sure that the pref is still set to false ?

Yes, it is still to false :/. I did not change others parameters.

Start Firefox in Troubleshoot Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration or userChrome.css is causing the problem.

  • switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Themes
  • do NOT click the "Refresh Firefox" button on the Troubleshoot Mode start window

i follow the solution 1 of /kb/reset-preferences-fix-problems .

My firefox is completed reset and the problem is still here when i put the parameter "browser.newtabpage.activity-stream.improvesearch.handoffToAwesomebar" back to false.

The focus is still taken by the adress bar, and not the central search bar into the page. :/

cor-el மூலமாக திருத்தப்பட்டது

Do you see a Trash icon on the right side of this preference?

No, 2 icons : one double arrow and one curved arrow.

Hi, Today, i havd retried. I have even uninstalled firefox (bad idea , i lost all my saved password). I have re-installed firefox (v94), i put the option to false. Still the same, the focus is still fixed on the address bar.

fr.viewer மூலமாக திருத்தப்பட்டது

Is focus the only problem? Or we're talking about jumping bars while entering sth in the central bar?

Are you using the private mode or normal mode?

Yes, the focus is the only problem.

The firefox behavior in private or normal mode is the same. Why would the mode influence the focus behavior ? it is independent.

If you use the Time Machine or other backup then try to restore the logins.json and key4.db files from this backup.

Location used for the main profile that keeps your personal data (Root Directory on about:profiles).

  • ~/Library/Application Support/Firefox/Profiles/<profile>

In Mac OS X v10.7 and later, the "~/Library" folder in the Home directory is a hidden folder.