Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox suddenly stuck in restricted mode

  • 14 பதிலளிப்புகள்
  • 1 இந்த பிரச்சனை உள்ளது
  • 55 views
  • Last reply by ·´¯`·...¸>-)))º> ~dbben

I've used Firefox as my default browser for years. I'm now on a Win10 laptop I've been using for over a year. I have not knowingly made any recent changes to FF. I'm on FF version 88.0.1 (64 bit).

Suddenly, yesterday, I found that I was blocked from viewing many YT videos and comments. YT says I am in restricted mode. It is not due to a setting on my YT/Google account, because I'm not logged in.

Exact YT messages: "Video unavailable--This video is restricted. Please check the Google Workspace administrator and/or the network administrator restrictions." And "Restricted Mode has hidden comments for this video."

However, I have no problem viewing them in Chrome. So logically it's a FF problem.

Also, I discovered that other sites are affected. For example, if I run a "domain lookup" on the ICANN website, I get less detailed results than if I run the search on Chrome! https://lookup.icann.org/

Switching from Strict to Standard Tracking Protection didn't help. Then I did a FF refresh but that also didn't help.

Suggestions? Be aware I'm not a coder or any kind of super techhie.

All Replies (14)

hmm? i have no issues with YT and W10.

so its definetly something to do with your machine.

there is a troubleshoot mode in FF whereas it will run FF in a safe mode environment.

try it and see if it helps. if so, then this is a clue towards the solution

go to FF Menu > Help > Troubleshoot

Helpful?

As I stated in the OP, Chrome works fine. The problem is with FF.

I'm in troubleshoot mode right now. That in itself has not solved the problem.

Neither has a refresh, nor clearing the startup cache.

Time to switch to Chrome, I guess. A shame, I've been using FF for years. But I have things to do and no time to hassle with this nonsense.

Helpful?

Something that may help understand the issue at hand is that both Chrome and MSEdge browsers do not protect your privacy. In fact, they exploit your privacy by tracking where you visit, what you shop for, etc...,.

So basically, these browsers are 100% open and functional because they are designed to exploit your privacy for their profits.

On the other hand FF has implement a number of strategies to protect your privacy. So when you go visit Walmart.com and shop for blue jeans size xxx, Macy wont know that you were shopping for these when you next visit them. And then TVGuide.com wont show ads on the tv schedule for blue jeans and phony sales.

But FF is a work in progress. And its an experiment as well. And its a browser that is based on principle and not profits.

However, it is not to say the FF doesnt have its hiccups.

My suggestion, is that until we can figure out why you have this issue with some sites, use the other browsers for them. In the meantime, it doesnt hurt to implement some protection while visiting other sites with FF.

btw: have you researched this issue via:

https://www.google.com/search?client=firefox-b-1-d&q=video+is+restricted

·´¯`·...¸>-)))º> ~dbben மூலமாக திருத்தப்பட்டது

Helpful?

This happens regardless of whether I'm logged into YT or not. I cannot fix the fact those videos are restricted. The toggle is grayed out.

Also as I stated in the OP, this is not only a problem on YT. I don't have time to do every task in two different browsers, to figure out if I'm getting the same results.

How could this just suddenly happen? One day everything was fine, the next day I'm locked in restricted mode. And no one at Mozilla can help, apparently.

csskalet மூலமாக திருத்தப்பட்டது

Helpful?

csskalet said

Exact YT messages: "Video unavailable--This video is restricted. Please check the Google Workspace administrator and/or the network administrator restrictions." And "Restricted Mode has hidden comments for this video."

Are you connecting from inside a business network? Google has a help page explaining how employers, or perhaps other network operators, can make modifications that would cause that message:

Restrict YouTube content available to users - Google Workspace Admin Help

Helpful?

No, I'm at home. I live alone, no network changes here.

Also, YT and other sites work fine (no restricted mode) when I use Chrome.

Helpful?

Could you test changing your proxy setting here:

  • Windows: "3-bar" menu button (or Tools menu) > Options
  • Mac: "3-bar" menu button (or Firefox menu) > Preferences
  • Linux: "3-bar" menu button (or Edit menu) > Preferences
  • Any system: type or paste about:preferences into the address bar and press Enter/Return to load it

In the search box at the top of the page, type proxy and Firefox should filter to the "Settings" button, which you can click.

The default of "Use system proxy settings" piggybacks on your Windows/IE "LAN" setting. "Auto-detect" can lead to a flaky connection. Try "No proxy" and see whether that makes any difference. You might need to clear your cache and YouTube cookies, or test in a private window.

If you changed the setting, does that make any difference?

Helpful?

Changed it to "no proxy", and cleared all cookies and site data, and all of my history. No change.

Helpful?

Are you using Firefox's DNS over HTTPS (DoH) feature? You could try switching that on and off to see whether it is a factor. More info in this article: Firefox DNS-over-HTTPS.

Also, as an alternative to using Cloudflare as your DoH provider, there is a way to use Google, but I don't have the URL at my fingertips.

Helpful?

I tried switching off DoH, it didn't make any difference.

My Win10 settings are pointing to the OpenDNS servers.

This seems to be an exercise in futility.

Helpful?

What if you don't use OpenDNS?

Helpful?

It's possible that you may have / be using 2 different youtube accounts. and the one that firefox is logging you into youtube with may be the problem.

you see, based on all the research, the restricted mode is controlled via the youtube account.

so my suggestion is for you to log into youtube via FF and disable that parental control setting, restricted mode.

Helpful?

Once again: The restricted mode is in effect REGARDLESS of whether I'm logged into YT or not. I'm also not logged into FF.

If I do log in to YT I can't change the restricted mode, the toggle is grayed out and disabled.

I do not have multiple accounts. And I am not automatically logged in when I go to YT or Google. I rarely log into them. If I do, I log out as soon as I'm done, or I'm automatically logged out when I close the browser.

And I'll again remind you that I do not have these problems in Chrome on the same laptop. I'm using YT in Chrome right now, not logged in and with no restrictions.

Helpful?

csskalet said

If I do log in to YT I can't change the restricted mode, the toggle is grayed out and disabled.

Thanks for the additional information.

Incidentally, this isnt an issue pertaining to whether or not you are logged into "FireFox". Instead this is something to do with your "YouTube" Account. I say this, because FF doesnt have parental control features. But i know Windows does and of course we now know that YT does too.

So now we have to figure out why the setting is greyed out for you. This could be explanable as an option for parents to keep kids from changing the setting.

Perhaps, you have to use the other browsers to log into the YT account and take control of it. In otherwords, if you take a look at the setting in YouTube via the other browser, is it still greyed out? Is it enable for restricted mode?

Before trying the other browsers to examine that YT setting, be sure that you are logged out of YT via FF. Then close FF.

Helpful?

கேள்வி எழுப்பு

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.