Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Google Maps takes me somewhere else

  • 3 பதிலளிப்புகள்
  • 1 இந்த பிரச்சனை உள்ளது
  • Last reply by FredMcD

When i click on the google maps icon (google uk home page>dots in top right hand conrner>google maps icon)or type google maps into the search field then click on the google maps link I end up on the Sheffield Hallam University log in page (a bookmark from a while ago). This has started happening in the last few weeks.

If I use Edge then everything happens as expected and google maps opens.

I have tried refreshing firefox and disabling add-ons, neither works.

Using Windows 10 home V20H2, upto date firefox.

தீர்வு தேர்ந்தெடுக்கப்பட்டது

That was very good work. Well Done. Please flag your last post as Solved Problem as this can help others with similar problems.


Note: Firefox comes in three or more folders on all computers. They are;

Maintenance: (Programs Folder) <Windows Only> Firefox itself: (Programs Folder) And two folders in the profile of each user on the computer for each Firefox profile for that user.

If you remove the Firefox folder, the user profiles would not be affected.

Read this answer in context 👍 0

All Replies (3)

Hi, I know you say you've disabled add-ons, but just to be sure all your extensions were fully disabled, hold down the Shift key when you start Firefox to start in Safe Mode. More - Diagnose Firefox issues using Troubleshoot Mode.

If it's OK in Safe Mode, disable any theme or extensions you have - 3-bar menu > Add-ons > Themes/Extensions, then restart Firefox; now if it's still OK, re-enable them one by one until you find the culprit. You may need to restart Firefox after enabling some extensions.


If you've established it isn't an extension, try deleting ALL references to Google, Google Maps and Sheffield Hallam - you may need to repeat this procedure for all three sites: Open the 3-bar menu > Library > History, then click the Manage History link at the bottom of the list to open the History-library window. Search for the website you want to clear by typing its name in the Search History field in the top-right corner. Now in the search results, right-click on the site you want to remove, and select Forget About This Site. (Browsing and download history, cookies, cache, active logins, passwords, saved form data, exceptions for cookies, images and pop-ups for that site will be removed). Give it a few minutes to complete the deletion, then try the site (not from an old bookmark) again. More - Delete browsing, search and download history on Firefox.

If your question is resolved by this or another answer, please help other users by marking the best reply as Solved. Thank you!

Helpful?

Many thanks for the suggestion, but couldnt get that to woprk. Finally resolved it by copying bookmarks and passwords to edge. Then deleting Firefox, if you then reload FF problem still there, when i deleted FF and then also deleted the profile (which remained for some reason) it works. Profile was more or less in C>Users>apark>appdata>mozilla I deleted the whole mozilla file and contents, then reinstalled FF, imported bookmarks etc from Edge and all is ok again.

Helpful?

தீர்வு தேர்ந்தெடுக்கப்பட்டது

That was very good work. Well Done. Please flag your last post as Solved Problem as this can help others with similar problems.


Note: Firefox comes in three or more folders on all computers. They are;

Maintenance: (Programs Folder) <Windows Only> Firefox itself: (Programs Folder) And two folders in the profile of each user on the computer for each Firefox profile for that user.

If you remove the Firefox folder, the user profiles would not be affected.

Helpful?

கேள்வி எழுப்பு

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.