Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Links from the search do not open as we would like

  • 4 பதிலளிப்புகள்
  • 1 இந்த பிரச்சனை உள்ளது
  • 8 views
  • Last reply by mr.mozdor

Hello dear support! I would like to immediately warn you that I used Yandex translator to write the text, so there may be grammatical errors :) I've been using Firefox for a very long time and I'm happy with everything. But recently I have encountered the" problem " of opening tabs, it has always been there, but I am not comfortable using it.When you search for material intensively by links, when you open any link on the search page by clicking the left mouse button or using the right mouse button "open link in a new tab", in both cases a new tab opens, it throws there and you have to move back to the search page from the opened tab and open another link that I also need, which is inconvenient. In this regard, a question. Is there a setting in the browser so that by clicking on the right button I do not go to an open tab, but it opens itself, and I immediately open new links without going to them initially and I would decide which one to go to first. This feature is implemented in Opera, but I want to stay with Firefox.

Sincerely, Mr. Mozdor

தீர்வு தேர்ந்தெடுக்கப்பட்டது

Sorry, I think I misunderstood your question.

When you click a link with target="_blank" and Firefox is set to open it in a new tab, Firefox switches to the new tab immediately. There is a preference to open that link in the background, but you need to access it this way:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

(2) In the search box in the page, type or paste inback and pause while the list is filtered

The preference browser.tabs.loadInBackground is set to true by default. This is the one that has the checkbox on the Options page.

There is a different preference for the links that Firefox diverts from a new window to a new tab instead:

(3) Double-click the browser.tabs.loadDivertedInBackground preference to switch the value from false to true

Hopefully this what you are really looking for!

Read this answer in context 👍 1

All Replies (4)

Hold down the 'Shift' and then Right-Click > Open In New Tab.

Helpful?

Hi Mr. Mozdor, I don't think there is any way to add "Open Link [in This Tab]" to the right-click context menu. That only appears if you select a plain text link -- a URL that is not a hyperlink, like https://some.site.example/.

So we might consider the full situation.

Is there a specific site where you have this problem -- for example, Yandex search?

On the Yandex results page, each link has target="_blank" which instructs Firefox to open the link in a new window/new tab.

Many search engines let you choose whether results open in the same tab or a new window/new tab. I do not see that option in Yandex settings:

I was not logged in. Maybe you are given an option if you log in to the site when searching?? If not -- or if you prefer to search anonymously -- then I think you have three choices:

(1) Use an add-on to add a new "Open Link in This Tab" item

Unfortunately, extension commands are added to the bottom of the menu, so this is not as convenient.

(2) Use an add-on to remove the link targets in the results page

I see there are some general purpose add-ons for this (not specific to Yandex) but I don't know whether they are reliable / trustworthy.

Another method would be to use one of the "monkey" extensions (Tampermonkey, Greasemonkey, Violentmonkey, FireMonkey) to modify the page with a "user script". This is an example of a user script to clean out the target="_blank": https://greasyfork.org/ru/scripts/395686-yandex-open-results-in-same-tab

(3) Set Firefox to ignore link targets

Unfortunately, this is a global change affecting all sites and possibly breaking some sites. This setting will always open links in the same tab unless you direct them to a new tab using one of the usual methods:

  • right-click > Open Link in New Tab
  • Hold down the Ctrl key when clicking the link
  • Click the link using the middle mouse button (usually a scroll wheel)

If you want to try it:

(A) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

(B) In the search box in the page, type or paste neww and pause while the list is filtered

(C) Review/Edit the preference values as follows (double-click the current value to open an editing field, and then when you're done, press Enter or click the blue checkmark to save the change):

(i) browser.link.open_newwindow - for links in Firefox tabs

Changing this overrides the checkbox on the Options page about whether targeted links are allowed to open in a new window or are diverted to a new tab instead; there's no effect on untargeted links:

  • 3 = divert new window to a new tab (default)
  • 2 = allow link to open a new window
  • 1 = force new window into same tab <== try this one

(ii) browser.link.open_newwindow.override.external - for links in other programs

This preference governs those external links that open in Firefox. To avoid outside links replacing the last page you viewed, change this one:

  • -1 = apply the setting under (A) to external links (default)
  • 3 = open external links in a new tab in the last active window <== change to this
  • 2 = open external links in a new window
  • 1 = open external links in the last active tab replacing the current page

(iii) browser.link.open_newwindow.restriction - for links in Firefox tabs

By default, if a page sets width, height, or toolbars for a popup, Firefox will open it in a "dialog-style" window. To force those into a tab as well, you can change this preference to 0. However, let's decide that later and keep the default value here:

  • 0 = apply the setting under (A) to ALL new windows (even script windows with limited features)
  • 2 = apply the setting under (A) to normal windows, but NOT to script windows with features (default) <== keep this
  • 1 = override the setting under (A) and always use new windows

There is an arrow-like reset button at the right end of each of those rows if it has a non-default value, so you can easily change back if there are problems.

Helpful?

தீர்வு தேர்ந்தெடுக்கப்பட்டது

Sorry, I think I misunderstood your question.

When you click a link with target="_blank" and Firefox is set to open it in a new tab, Firefox switches to the new tab immediately. There is a preference to open that link in the background, but you need to access it this way:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

(2) In the search box in the page, type or paste inback and pause while the list is filtered

The preference browser.tabs.loadInBackground is set to true by default. This is the one that has the checkbox on the Options page.

There is a different preference for the links that Firefox diverts from a new window to a new tab instead:

(3) Double-click the browser.tabs.loadDivertedInBackground preference to switch the value from false to true

Hopefully this what you are really looking for!

Helpful?

Hello, jascher2000! Thank you very much for solving my question, which has been bothering me for a long time! The decision to go to about:config helped. In the preference browser. tabs. loadInBackground, for some reason I had the value false, I corrected it to true and the links began to open in the background in new tabs. Thank you again!

jscher2000 said

Sorry, I think I misunderstood your question. When you click a link with target="_blank" and Firefox is set to open it in a new tab, Firefox switches to the new tab immediately. There is a preference to open that link in the background, but you need to access it this way: (1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk. (2) In the search box in the page, type or paste inback and pause while the list is filtered The preference browser.tabs.loadInBackground is set to true by default. This is the one that has the checkbox on the Options page. There is a different preference for the links that Firefox diverts from a new window to a new tab instead: (3) Double-click the browser.tabs.loadDivertedInBackground preference to switch the value from false to true Hopefully this what you are really looking for!

Helpful?

கேள்வி எழுப்பு

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.