Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox slow to load.

  • 4 பதிலளிப்புகள்
  • 1 இந்த பிரச்சனை உள்ளது
  • 37 views
  • Last reply by FredMcD

Firefox slow to load, 20-30 seconds. Appears is opening more than one instance with a single click. When it does load it sometimes comes up with the last page I had open even tough I closed it out properly. Sometimes get error msg that must close out 2nd Firefox before can start Firefox but saying yes results in the current open window closing. This started yesterday and the latest version of Firefox was automatically installed yesterday? Window 7. Cleared cash. Disabled all add on's etc. No help. Close out Firefox and Task Mngr show no Firefox running. Start Firefox and Task mngr shows four/five Firefox running. This started yesterday and the latest version of Firefox was automatically updated yesterday. Any ideas.

All Replies (4)

More than one process is normal for the current Firefox. http://www.ghacks.net/2016/07/22/multi-process-firefox/

Multi-process Firefox is codenamed "e10s". https://wiki.mozilla.org/Firefox/multiprocess


You may have corrupt sessionstore [v56] sessionstore.jsonlz4 file(s). Delete all sessionstore* files and the sessionstore-backups folder.

Type about:support<enter> in the address bar.

Under the page logo on the left side, you will see Application Basics. Under this find Profile Folder. To its right press the button Show Folder. This will open your file browser to the current Firefox profile. Now Close Firefox.

Windows: Show Folder; Linux: Open Directory; Mac: Show in Finder

Linux: Under the page logo on the left side, you will see Application Basics. Under this find Profile Directory. To its right press the button Open Directory.

Locate the above file. Then rename or delete it. Restart Firefox.


Don't delete the files if you need to rescue any data from them, just move them out of the profile folder to some location where Firefox doesn't look for them. You can try to read out their contents using this tool: https://www.jeffersonscher.com/res/scrounger.html

Start Firefox in Safe Mode {web link}

A small dialog should appear. Click Start In Safe Mode (not Refresh). Is the problem still there?

Fred, I appreciate the tips. Sorry it took so long to reply but I have several other computer related irons in the fire. I did try everything you suggested to no avail. A little background. I'm an old (70) retired computer engineer. My memory ain't what it used to be and I have not even tried to keep up with the industry for the past few years. When all else fails I resort to doing things the way I used to, so here goes what I did. I uninstalled Firefox. Deleted all files associated with Firefox. Edited the Registry removing EVERYTHING associated with Firefox and Mozilla. Booted the computer and reinstalled Firefox's latest version. End result; Firefox still takes too long to load but once it does at least it appears to be working as advertised. Since this started immediately after the last Firefox update installed (automatically), and the initial problem still exists I have to believe that it is the result of the latest update. If so, I'm sure I'm not the only person experiencing this problem. Hopefully Mozilla will find their problem and fix it in a new release real SOON. I know I should move on to Windows 10 but I don't like it. Reminds me too much of my iPhone and Android tablet. I have those so I can stay somewhat familiar with those OSs when I have others asking questions of me. If you have any other ideas feel free to share and I do appreciate your help.

Start your Computer in safe mode with network support. Then start Firefox. Try Secure websites. Is the problem still there?

http://encyclopedia2.thefreedictionary.com/Linux+Safe+Mode Starting Any Computer In Safe Mode; Free Online Encyclopedia