Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Form auto fill has stopped working

  • 4 பதிலளிப்புகள்
  • 1 இந்த பிரச்சனை உள்ளது
  • 80 views
  • Last reply by tim128

Even though I'm in the UK I was previously able to use the form auto fill function by changing the extensions.formautofill.available preference from "detect" to "on" however I updated to Firefox 83.0 and it reverted to "detect" and I am now unable to save any changes to it becasue it has always reverted to "detect" when I restart Firefox.

Form auto fill is such a simple and useful function that really needs to be available, Chrome has had it working for years.

தீர்வு தேர்ந்தெடுக்கப்பட்டது

That should still be working.

Do you otherwise have issues with keeping settings made in Options/Preferences or elsewhere ?

You can check the about:policies#active page to see whether policies are active (63+).

You can check if you have a user.js file in the profile folder to initialize prefs each time Firefox starts. The user.js file will only be present if you or other software has created this file and normally won't be present.

You can check its content with a text editor (right-click: "Open with"; do not double-click). The user.js file is read each time Firefox is started and initializes preferences to the value specified in this file, so preferences set via user.js can only be changed temporarily for the current session.

You can delete the user.js file if you didn't create this file yourself.

You can check for problems with preferences. You can delete possible user.js and numbered prefs-##.js files and rename/remove the prefs.js file to reset all prefs to the default value including prefs set via user.js and prefs that are no longer supported in current Firefox releases.

You can use the button on the "Help -> Troubleshooting Information" (about:support) page to go to the current Firefox profile folder or use the about:profiles page.

Read this answer in context 👍 1

All Replies (4)

தீர்வு தேர்ந்தெடுக்கப்பட்டது

That should still be working.

Do you otherwise have issues with keeping settings made in Options/Preferences or elsewhere ?

You can check the about:policies#active page to see whether policies are active (63+).

You can check if you have a user.js file in the profile folder to initialize prefs each time Firefox starts. The user.js file will only be present if you or other software has created this file and normally won't be present.

You can check its content with a text editor (right-click: "Open with"; do not double-click). The user.js file is read each time Firefox is started and initializes preferences to the value specified in this file, so preferences set via user.js can only be changed temporarily for the current session.

You can delete the user.js file if you didn't create this file yourself.

You can check for problems with preferences. You can delete possible user.js and numbered prefs-##.js files and rename/remove the prefs.js file to reset all prefs to the default value including prefs set via user.js and prefs that are no longer supported in current Firefox releases.

You can use the button on the "Help -> Troubleshooting Information" (about:support) page to go to the current Firefox profile folder or use the about:profiles page.

Helpful?

Hi cor-el and thanks for the fast response. I've checked what you suggest and found the following:

1. about:profiles shows there is only 1 profile 2. there is not a user.js file in the profile folder 3. about:policies shows "The Enterprise Policies service is inactive" 4. I am unable to save changes to preferences in about:config. For example if I change extensions.formautofill.available to “on” it immediately reverts to “detect” as soon as I click on another preference.

Something must be preventing my preference changes from being saved.

Helpful?

You do press the Enter key or click the blue OK button after you have typed "on" ?

Helpful?

Hi again Cor-el. I discovered that my pref.js file was read-only for some reason so I uninstalled Firefox and reinstalled with a new profile and that solved it. I wondered if this might have happened because I had installed a beta and a nightly version of Firefox at some time in the past. Thanks for pointing me in the direction of the prefs profile.

Helpful?

கேள்வி எழுப்பு

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.