Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Remove Sponsored Link From Address Bar History

  • 6 பதிலளிப்புகள்
  • 1 இந்த பிரச்சனை உள்ளது
  • 29 views
  • Last reply by jscher2000

Is there a way to remove the sponsored link from the address bar drop down? Yesterday a link from a company that is run by terrorists showed up in the list. Shift+Del does not remove it. I understand Mozilla needs to get money somehow, but this is offensive. The link is for Ebay and it has the word sponsored next to it. Since the address bar drop down disappears when I hit any key, it is impossible to screenshot.

தீர்வு தேர்ந்தெடுக்கப்பட்டது

Maybe set these prefs to false on the about:config page helps.

  • browser.newtabpage.activity-stream.showSponsored
  • browser.newtabpage.activity-stream.showSponsoredTopSites
Read this answer in context 👍 1

All Replies (6)

This might be part of showing top sites as suggestions in the location bar drop-down list.

The location bar drop-down list can show history items, bookmarked pages, pages opened in tabs, top sites, and search suggestions. You can set what suggestions show when you enter an URL in the location/address bar bar.

  • Options/Preferences -> Privacy & Security
    Address Bar: When using the location bar, suggest:
    History
    Bookmarks
    Open tabs
    Top sites
  • Options/Preferences -> Search -> Search Suggestions

Helpful?

Unfortunately, I use the top sites list all day long, so it's not an option to remove top sites from the address bar drop down. I just want to remove the sponsored link because: 1) I can't stand being advertised at and 2) it bumps one of my top sites out of the list.

Helpful?

தீர்வு தேர்ந்தெடுக்கப்பட்டது

Maybe set these prefs to false on the about:config page helps.

  • browser.newtabpage.activity-stream.showSponsored
  • browser.newtabpage.activity-stream.showSponsoredTopSites

Helpful?

That worked! I also changed:

services.sync.prefs.sync.browser.newtabpage.activity-stream.showSponsored services.sync.prefs.sync.browser.newtabpage.activity-stream.showSponsoredTopSites

just in case. Many thanks for the assistance. My browsing experience has returned to normal.

Helpful?

You're welcome.

You can leave services.sync.prefs.sync.* prefs to their default (true) value as those specify whether or not to sync these prefs as part of syncing prefs to other devices (services.sync.prefs.sync.<pref> prefs set to false are excluded from Sync).

Helpful?

This is a test, which would explain why I haven't seen this is any of my profiles yet. According to the support article "Sponsored Top Sites," if you are in the test group, you should have a checkbox on the Options page, Home panel, in the expected location to control this feature:

Does that appear on yours?

Helpful?

கேள்வி எழுப்பு

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.