Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

This thread was closed and archived. Please ask a new question if you need help.

Gmail won't load

  • 6 பதிலளிப்புகள்
  • 2 இந்த பிரச்னைகள் உள்ளது
  • 14253 views
  • Last reply by AliceWyman

Gmail will not load in Firefox, but will in Chrome. I've cleared my history, cookies, and cache. I made sure I had the latest Firefox update, restarted my computer, checked in internet connection, everything I could think of. There is no error message; it just stops loading and the page is totally blank, as you can see on the attached image. I've run out of ideas and know-how. Anyone else had this issue and resolved it?

Attached screenshots

தீர்வு தேர்ந்தெடுக்கப்பட்டது

You can try these steps in case of issues with webpages:

You can reload webpage(s) and bypass the cache to refresh possibly outdated or corrupted files.

  • hold down the Shift key and left-click the Reload button
  • press "Ctrl + F5" or press "Ctrl + Shift + R" (Windows,Linux)
  • press "Command + Shift + R" (Mac)

Clear the Cache and remove the Cookies for websites that cause problems via the "3-bar" Firefox menu button (Options/Preferences).

"Remove the Cookies" for websites that cause problems:

  • Options/Preferences -> Privacy & Security
    Cookies and Site Data: "Manage Data"

"Clear the Cache":

  • Options/Preferences -> Privacy & Security
    Cookies and Site Data -> Clear Data -> Cached Web Content: Clear

If you use extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) that can block content (Adblock Plus, NoScript, Disconnect, Ghostery, Privacy Badger, uBlock Origin) always make sure such extensions do not block content.

  • make sure your extensions and filters are updated to the latest version

Start Firefox in Safe Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration or userChrome.css is causing the problem.

  • switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Themes
  • do NOT click the "Refresh Firefox" button on the Safe Mode start window

You can remove all data stored in Firefox for a specific domain via "Forget About This Site" in the right-click context menu of an history entry ("History -> Show All History" or "View -> Sidebar -> History").

Using "Forget About This Site" will remove all data stored in Firefox for this domain like history and cookies and passwords and exceptions and cache, so be cautious. If you have a password or other data for that domain that you do not want to lose then make sure to backup this data or make a note.

You can't recover from this 'forget' unless you have a backup of involved files.

If you revisit a 'forgotten' website then data for that website will be saved once again.

Read this answer in context 👍 1

All Replies (6)

தீர்வு தேர்ந்தெடுக்கப்பட்டது

You can try these steps in case of issues with webpages:

You can reload webpage(s) and bypass the cache to refresh possibly outdated or corrupted files.

  • hold down the Shift key and left-click the Reload button
  • press "Ctrl + F5" or press "Ctrl + Shift + R" (Windows,Linux)
  • press "Command + Shift + R" (Mac)

Clear the Cache and remove the Cookies for websites that cause problems via the "3-bar" Firefox menu button (Options/Preferences).

"Remove the Cookies" for websites that cause problems:

  • Options/Preferences -> Privacy & Security
    Cookies and Site Data: "Manage Data"

"Clear the Cache":

  • Options/Preferences -> Privacy & Security
    Cookies and Site Data -> Clear Data -> Cached Web Content: Clear

If you use extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) that can block content (Adblock Plus, NoScript, Disconnect, Ghostery, Privacy Badger, uBlock Origin) always make sure such extensions do not block content.

  • make sure your extensions and filters are updated to the latest version

Start Firefox in Safe Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration or userChrome.css is causing the problem.

  • switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Themes
  • do NOT click the "Refresh Firefox" button on the Safe Mode start window

You can remove all data stored in Firefox for a specific domain via "Forget About This Site" in the right-click context menu of an history entry ("History -> Show All History" or "View -> Sidebar -> History").

Using "Forget About This Site" will remove all data stored in Firefox for this domain like history and cookies and passwords and exceptions and cache, so be cautious. If you have a password or other data for that domain that you do not want to lose then make sure to backup this data or make a note.

You can't recover from this 'forget' unless you have a backup of involved files.

If you revisit a 'forgotten' website then data for that website will be saved once again.

Thank you! It was my ad blocker. I've had it for at least 6 months with no issues so I didn't consider it as a cause.

I began having this problem about a week ago. Sometime in October or early November of 2020. Gmail will not load in Firefox. Clearing cookies and all cache, works one time. Then it starts all over. Resting also works, just once. This is a giant PITA. I have to reset or clear the cache every time I use Firefox or Gmail won't load. It works fine on all other browsers. If I want to use Firefox for Gmail, I have to reset it or clear it every time. I will have to go back to Chrome to use my Gmail.

I just started having this exact same problem---AND I tried all the usual solutions just as you did, none of which worked for me either. I can load some Gmail accounts (2 others), but not my most important & main one. I did discover, though, that the problematic account that only opens with a big blank white page--just like yours--WILL fully load & open in a Firefox private window.

I have had the same problem. to solve it I went to about:config accepted all the warning messages. then searched for "javascript" scroll to javascript.enabled. mine listed as "true" at the far right is a toggle button to "false" now a reset button appears click it so the javascript returns to "true" . close the tab and try gmail again. thanks to https://www.whatismybrowser.com/guides/how-to-enable-javascript/firefox

jegdev said

I have had the same problem. to solve it I went to about:config accepted all the warning messages. then searched for "javascript" scroll to javascript.enabled. mine listed as "true" at the far right is a toggle button to "false" now a reset button appears click it so the javascript returns to "true" . close the tab and try gmail again. thanks to https://www.whatismybrowser.com/guides/how-to-enable-javascript/firefox

Related KB article (in case it helps others): JavaScript settings and preferences for interactive web pages

For anyone else with problems loading Gmail: The thread owner "jvelmore" replied earlier that his issue was caused by an adblocker (see above). His problem is solved so, If you need more help, please ask a new question. See Mozilla Support rules and guidelines.

I'll close this thread.