Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox not launching (crashing) after update 82.0

  • 8 பதிலளிப்புகள்
  • 2 இந்த பிரச்னைகள் உள்ளது
  • Last reply by FredMcD

We use Firefox as our company default and it has been running fine. This morning our devices started updating to version 82.0 and now it will not re-open. We get the following in event viewer:

Faulting application name: firefox.exe, version:, time stamp: 0x5f8738dd Faulting module name: ntdll.dll, version: 10.0.18362.1049, time stamp: 0xb5beef21 Exception code: 0xc0000409 Fault offset: 0x00000000000a1170 Faulting process id: 0x504 Faulting application start time: 0x01d6a79d51cff95a Faulting application path: C:\Program Files\Mozilla Firefox\firefox.exe Faulting module path: C:\WINDOWS\SYSTEM32\ntdll.dll Report Id: a6b172b9-a2b5-4bc0-a874-22a48b48aa06 Faulting package full name: Faulting package-relative application ID:

When trying to uninstall from Program and Features we get the following NSIS error (attached).

Attached screenshots

தீர்வு தேர்ந்தெடுக்கப்பட்டது

Specifically, do you have Digital Guardian running on your system? Currently we suspect it's to blame.

Read this answer in context 👍 1

All Replies (8)

In the address bar, type about:crashes<enter>. Note: If any reports do not have BP- in front of the numbers/letters, click it to submit them.

The crash report is several pages of data. We need the report numbers to see the whole report.

Using your mouse, mark the most recent 7 - 10 Submitted crash reports, and copy them. Now go to the reply box and paste them in.

Please, Do not post a screenshot ! !


For more help on crash reports, see;


Thank you for responding.

I am unable to even open Firefox so cannot get the crash reports from the address bar. I check the URL you sent and tried following the steps to get the crash reports in the AppData folder but I cannot see any.


Looks that something seriously went wrong with updating. NSIS is the installer used on the Windows platform.

Do a clean reinstall of the current Firefox release and delete the Firefox program folder before installing a fresh copy of the current Firefox release.

If possible uninstall your current Firefox version to cleanup the Windows Registry and settings in security software.

  • do NOT remove "personal data" when you uninstall the current Firefox version, because this will remove all profile folders and you lose personal data like bookmarks and passwords including personal data in profiles created by other Firefox versions

Remove the Firefox program folder before installing that newly downloaded copy of the Firefox installer.

  • (64-bit Firefox) "C:\Program Files\Mozilla Firefox\"
  • (32-bit Firefox) "C:\Program Files (x86)\Mozilla Firefox\"
  • it is important to delete the Firefox program folder to remove all the files and make sure there are no problems with files that were leftover after uninstalling

Your personal data like bookmarks is stored in the Firefox profile folder, so you won't lose personal data when you reinstall or update Firefox, but make sure NOT to remove personal data when you uninstall Firefox as that will remove all Firefox profile folders and you lose your personal data.

Reinstall Firefox


Thank you for responding.

Clean installation does not make a difference. I was able to get around the uninstall error (local domain policy) but still cannot launch version 82.0. To check if it could be another policy, I removed the device from all other domain policies.

On a side note.. I had a user running 82.0 fine but after installing Windows patch KB4577671 Firefox started crashing on launch. Cant say for certain this is root cause as one other machine has patch applied but 82.0 working. I have 1 machine in my entire domain with a working version of Firefox 82.0.

I installed an older version (80.0.1) and that works fine.

dirkvdm85 மூலமாக திருத்தப்பட்டது


do you happen to know which security software is running in your environment? (perhaps a similar issue as in


தீர்வு தேர்ந்தெடுக்கப்பட்டது

Specifically, do you have Digital Guardian running on your system? Currently we suspect it's to blame.


Apologies about the delayed response.

The root cause was identified as Digital Guardian.


That was very good work. Well Done. Please flag your last post as Solved Problem as this can help others with similar problems.


கேள்வி எழுப்பு

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.