Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Main Facebook page not loading properly, but login page works and it does work in incognito mode.

  • 17 பதிலளிப்புகள்
  • 2 இந்த பிரச்னைகள் உள்ளது
  • 68 views
  • Last reply by jscher2000

Hi, upon waking up this morning, found out my facebook is not loading properly. Did try clearing the cache and still issue persist. The login page works fine, but when logged in, its just plain blank. Did try logging in on incognito mode and it works as it should be. Can anyone help?

Attached screenshots

All Replies (17)

Also every site works fine atm. Facebook loads fine on other browsers too, only not working on firefox.

Many site issues can be caused by corrupt cookies or cache.

Warning ! ! This will log you out of sites you're logged in to. You may also lose any settings for that website.

If there is still a problem, Start Firefox in Safe Mode {web link} by holding down the <Shift> (Mac=Options) key, and then starting Firefox.

A small dialog should appear. Click Start In Safe Mode (not Refresh). Did this help?

While you are in safe mode;

Try disabling graphics hardware acceleration in Firefox. Since this feature was added to Firefox it has gradually improved but there are still a few glitches.

How to disable Hardware Acceleration {web link}

Hi FredMcD!

Thanks for the reply, although tried doing what you suggested, it didnt resolve the issue. And I think that the issue is on facebook. Have tried another account to log in and facebook loads fine. Its just my account is the one not responding properly. Will try to reach facebook with this issue.

me and another guy here https://support.mozilla.org/en-US/questions/1308890

are having the same issue.

I've created a new profile / reinstalled / tried safe mode literally everything you can think of...

Partners facebook works just fine only way im able to access my facebook is by installing an addon to make it force the old layout again

@christopherwhite597 yes it seems it affects some users like us which sucks tbh. im using other browsers temporarily while awaiting facebooks response for this issue.

This issue can be caused by corrupted cookies or blocked cookies.

If clearing cookies didn't help then it is possible that the cookies.sqlite file in the Firefox profile folder that stores the cookies got corrupted.

  • rename/remove cookies.sqlite (cookies.sqlite.old) and when present delete cookies.sqlite-shm and cookies.sqlite-wal in the Firefox profile folder with Firefox closed in case cookies.sqlite got corrupted.

You can use the button on the "Help -> Troubleshooting Information" (about:support) page to go to the current Firefox profile folder or use the about:profiles page.


You can remove all data stored in Firefox for a specific domain via "Forget About This Site" in the right-click context menu of an history entry ("History -> Show All History" or "View -> Sidebar -> History").

Using "Forget About This Site" will remove all data stored in Firefox for this domain like history and cookies and passwords and exceptions and cache, so be cautious. If you have a password or other data for that domain that you do not want to lose then make sure to backup this data or make a note.

You can't recover from this 'forget' unless you have a backup of involved files.

If you revisit a 'forgotten' website then data for that website will be saved once again.

You can remove all data stored in Firefox for a specific domain via "Forget About This Site" in the right-click context menu of an history entry ("History -> Show All History" or "View -> Sidebar -> History").

Using "Forget About This Site" will remove all data stored in Firefox for this domain like history and cookies and passwords and exceptions and cache, so be cautious. If you have a password or other data for that domain that you do not want to lose then make sure to backup this data or make a note.

You can't recover from this 'forget' unless you have a backup of involved files.

If you revisit a 'forgotten' website then data for that website will be saved once again.

christopherwhite597 said

me and another guy here https://support.mozilla.org/en-US/questions/1308890 are having the same issue. I've created a new profile / reinstalled / tried safe mode literally everything you can think of... Partners facebook works just fine only way im able to access my facebook is by installing an addon to make it force the old layout again

So far installing the addon is the fix.

did everything the mods suggested, deleted the cookie.sql file, forgetting the site on history, even reinstalled it, yet it still persists.

Thanks for this suggestion and I like fb classic better :D

You can check for issues with location storage (indexedDB).

Bottom line, way too much to do when there are other browsers available. I've only used Firefox. Yesterday, all was well, today Facebook login works, but won't load program. Chrome, Edge both do. I'm not going to spend a lot of time and doing things I am not skilled to do to try and fix this. It shouldn't have happened. You're a major browser. Personally, very disappointed as a life time Firefox user. But it is what it is. Thanks, Steve

verserkis said

christopherwhite597 said

... Partners facebook works just fine only way im able to access my facebook is by installing an addon to make it force the old layout again

So far installing the addon is the fix.

Which add-on was it?

Hi Steve Applegate, probably half a two dozen people have posted about this. I haven't noticed a problem with Facebook in my Firefox on Windows, but there must be some common factor that is causing the problem among those who suffer from it. You should receive notifications of updates to this thread and hopefully one of them will be a simple solution.

jscher2000 மூலமாக திருத்தப்பட்டது

This could be a problem with corrupted local storage and possibly running this command in the Web Console to clear storage as posted in bug 1569296 might fix it.

  • localStorage.clear()

(please do not comment in bug reports
https://bugzilla.mozilla.org/page.cgi?id=etiquette.html
)

Hi cor-el,

Tried the localStorage.clear() and Im not sure if it does the trick since I havent checked back first if my FB still got the issue but got the facebook working again on the new layout. Thank you so much! Though I think Id stick to that classic add on since FB runs faster on the classic layout.

Suddenly my facebook is now working again today :)

Apparently, this is intentional by Mozilla. There are all kinds of extensions and other functionality in Private Mode (>86.0) that have been cut off at the knees by Mozilla and no longer function. For example, popular Password Managers like Bitwarden, no longer work in Private mode. This is insane.

I'm sick of major issues like this appearing in Firefox upgrades, like this morning a whole lot of shit just stops working following a "silent' background upgrade sometime last night to 86. I'm getting to the point I'm ready to punt FF altogether. I'm all for Privacy, but I'm also a fan of USEABILITY, and there has to be a balance. It seems Mozilla may have forgotten that, and I've been a support from the beginning. It's out of hand.

Shane மூலமாக திருத்தப்பட்டது

Shane said

There are all kinds of extensions and other functionality in Private Mode (>86.0) that have been cut off at the knees by Mozilla and no longer function. For example, popular Password Managers like Bitwarden, no longer work in Private mode.

Hmm, I don't see anything on the Bitwarden page about it not running in private windows: https://addons.mozilla.org/firefox/addon/bitwarden-password-manager/

Could you double-check that you've given it permission to run in private windows. More info in this article: Extensions in Private Browsing.