Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Error when downloading some files: "Could not be saved because the source file could not be read"

  • 15 பதிலளிப்புகள்
  • 1 இந்த பிரச்சனை உள்ளது
  • Last reply by Martino

Hi everyone; today I got this error: "Could not be saved because the source file could not be read" when I tried to save a zip archive and it happens also with some video files, not with pdfs, photos, excels and docxs. I can download those files from edge with no problem. The problem seems to be associated with my wifi connection because if I try with android hotspot it works. Also my other pc connected to the same wifi and running firefox with windows 10 does not have that problem. I tried rebooting firefox, uninstalling and reinstalling it, installed nightly, did a windows recovery to yesterday, but the problem persist. This morning, before I noticed the problem I used dns jumper to change my dns from google one to opendns but changing again or setting default values doesn't solve.

All Replies (15)

What security software do you have ?

It is possible that (anti-virus) security software is causing the problem. Try to disable security software temporarily to see if that makes a difference.

Thank you @FredMcD. Unfortunately those methods didn't solve my problem. I was searching for the file compreg.dat but I can't find it.

@cor-el I have windows defender. I partially disabled it (turned off firewall and all app monitor/web monitor switches) but it's always the same. I also made a reset of the network configuration from windows options. None of those methods have worked

This is a generic readerror that is shown because other more specific messages do not apply.

You can check the read/write permissions for the temp folder and for the default download location as set in Options/Preferences.

cor-el மூலமாக திருத்தப்பட்டது

@cor-el can you tell me the location of the temp folder? thank you for your answer

edit. I changed the permissions of the temp folder in C:\Users\me\AppData\Local\Temp from square to none, but when I open again the properties the cell is squared. Also it didn't solve. The download location is set to default. I haven't changed it since few hours ago I reinstalled firefox

Martino மூலமாக திருத்தப்பட்டது

I noticed that not all the times I get the error with the same video file, but 100% of the times i get it with a large zip file on my gdrive. I can download them from the same firefox on the same pc with a different wifi but I can also with a different pc with firefox and my home wifi. And edge is not giving any problem at all, it works with all wifis. This is confusing

Start Firefox in Safe Mode {web link}

A small dialog should appear. Click Start In Safe Mode (not Refresh). Is the problem still there?

Start your Computer in safe mode with network support. Then start Firefox. Try Secure websites. Is the problem still there? Starting Any Computer In Safe Mode; Free Online Encyclopedia

@FredMcD starting firefox in safe mode did not work but starting my pc in safe mode yes! What can I do to make it work in normal mode?

That means something on your system is the problem. As a test, disable your protection programs.

I turned off all the switches I could find in Defender menu, disabled all protections inside Spyware Blaster, Malwarebytes is set to not open automatically but I had no success. So I tried to downgrade to win 10 1909 and the problem is still there. Now it's downloading again 2004 version.

I also noticed that the connection is a bit unstable only with firefox

Thank you. In the meantime I tried again via android hotspot and I can confirm that the download had no errors. My pc is linked to a wifi adapter Asus N 14

Martino மூலமாக திருத்தப்பட்டது

Now the problem has started to happen also on edge. When I try to open a large pdf Edge says "Unable to open the file". Firefox says "Secure connection failed". If I open edge right after the pc booted it opens the pdf normally but if I try after some time it can't open it anymore

I think I'm going to wipe the hdd and reinstall windows since I can't find the source of the problem. Anyone got some ideas of what can it be?