Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox Not Displaying Characters Correctly

  • 7 பதிலளிப்புகள்
  • 1 இந்த பிரச்சனை உள்ளது
  • 33 views
  • Last reply by cor-el

Hello, Firefox folks! I am running Firefox 78.0.1 on Ubuntu 20.04 LTS. Recently, Firefox has stopped displaying text correctly. I have attached 2 images of examples of this occurring. I refreshed Firefox some time ago and the problem went away but has since returned.

I would appreciate any insights that you all can provide.

Thank you! -Mark

Attached screenshots

All Replies (7)

Hoping to get some help with this. The problem persists. See the attached screenshot from today.

Helpful?

From the hex code in the little boxes you can see that these characters are in the basic ASCII range and this indicates a problem with the font that is used to display these specific glyphs.

You can right-click and select "Inspect Element" to open the builtin Inspector with this element selected.

You can check in the Rules tab in the right panel in the Inspector what font-family is used for selected text.
You can check in the Font tab in the right panel in the Inspector what font is actually used because Firefox might be using a different font than specified by the website.

Helpful?

Thank you for the reply. I apologize for the delayed response - for a time the bug stopped occurring. However, it has returned. I have inspected the fonts that don't display correctly using the element inspector. It appears that the various italics are not displaying. I have observed examples of "Twemoji Mozilla" and "DejaVu Sans" displaying incorrectly when they are italic. I would like for Firefox to display italic characters without my needing to go into the developer tools each time. I would appreciate any suggested fixes.

Thank you, -Mark

mswalth மூலமாக திருத்தப்பட்டது

Helpful?

Attached is a screenshot of Twemoji Italics displaying incorrectly.

Helpful?

There should be no need to use the Twemoji to display Italics. The regular DejaVu font shouldn't have a problem.

The screenshot seems to show part of the list from "All fonts on page".

What font is shown as the font used for Italic text at the top of the Font tab ?

Helpful?

Thank you for your response. The first and second screenshots show a case of firefox failing to display Twemoji italics and Twemoji non-italics. The problem seems to include more cases than I'd previously thought. The last screenshot shows the same problem occurring with DejaVu Sans italic.

Thank you for your time, -Mark

Helpful?

Hmm. I have no idea why Firefox insists in using the Twemoji font for displaying italic text instead of the default sans-serif font.

You can create a new profile as a quick test to see if your current profile is causing the problem.

See "Creating a profile":

If the new profile works then you can transfer files from a previously used profile to the new profile, but be cautious not to copy corrupted files to avoid carrying over problems.

Helpful?

கேள்வி எழுப்பு

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.