Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Typing the web site name in search bar without a suffix no longer works

  • 4 பதிலளிப்புகள்
  • 1 இந்த பிரச்சனை உள்ளது
  • 4 views
  • Last reply by cor-el

Hi, when I type the body of a URL in the search bar without the .com suffix (i.e. "gmail"), Firefox no longer guesses my intent and takes me to the site.

Now weird things happen, either it doesn't go anywhere just spins, or takes me to my default search engine, or takes me to my ISP's search page.

Seems like that feature used to work.

Thanks

தீர்வு தேர்ந்தெடுக்கப்பட்டது

Hi McMike, quite a long time ago Firefox switched to sending a single word like gmail to search first instead of doing a DNS lookup first. There used to be a preference to revert to the old behavior and that was removed recently. If this seems like a change to you, maybe you were using that preference.

Here's one workaround:

If your word should be placed between www. and .com you can type the word and then instead of pressing Enter, press Ctrl+Enter to apply that "fixup."

Read this answer in context 👍 0

All Replies (4)

தீர்வு தேர்ந்தெடுக்கப்பட்டது

Hi McMike, quite a long time ago Firefox switched to sending a single word like gmail to search first instead of doing a DNS lookup first. There used to be a preference to revert to the old behavior and that was removed recently. If this seems like a change to you, maybe you were using that preference.

Here's one workaround:

If your word should be placed between www. and .com you can type the word and then instead of pressing Enter, press Ctrl+Enter to apply that "fixup."

Helpful?

Is keyword.enabled still set to true on the about:config page ?

There is also this hidden pref that defaults to false when not defined:

  • browser.fixup.dns_first_for_single_words

  • bug 1636583 - Allow forcing a visit by appending a slash to uri-like search strings

cor-el மூலமாக திருத்தப்பட்டது

Helpful?

cor-el said

Is keyword.enabled still set to true on the about:config page ? There is also this hidden pref that defaults to false when not defined:
  • browser.fixup.dns_first_for_single_words

  • bug 1636583 - Allow forcing a visit by appending a slash to uri-like search strings


Keyword.enabled is set to true. There is no browser.fixup.dns in my config. Thanks

Thanks

Helpful?

If you set keyword.enabled to false then Firefox shouldn't do a search, but will try to resolve via a DNS lookup.

The Boolean browser.fixup.dns_first_for_single_words pref doesn't exist by default, so if you want to force a lookup then you need to create this as a Boolean pref and set the value to true.
In Firefox 79 this pref will be present on the about:config page.

  • bug 1643259 - Unhide browser.fixup.dns_first_for_single_words [79]

Helpful?

கேள்வி எழுப்பு

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.