Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Surface Pro Keyboard

  • 6 பதிலளிப்புகள்
  • 2 இந்த பிரச்னைகள் உள்ளது
  • 134 views
  • Last reply by Arsa Pratama

Surface Pro keyboard not opening when target is tapped. Only happens in FF. Not switching from tablet mode properly. Checked all normal settings? Anyone else?

தீர்வு தேர்ந்தெடுக்கப்பட்டது

Hello laura hannah,

If restarting and re-attaching doesn't fix the problem,

try reinstalling the driver for your Surface Cover.

Select the search box in the taskbar,

enter device manager, and select

Device Manager in the results.
Expand Keyboards.
Right-click Surface Type Cover Filter Device


And another way:

What version of Firefox is it? There have been a lot of fixes this year.

Could you check and/or experiment with these settings -- I guess you'll need to attach your keyboard cover or use a bluetooth keyboard:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful.

(2) In the search box above the list, type or paste osk and pause while the list is filtered

(3) Try variations on these preferences:

  • ui.osk.enabled -- this obviously needs to be set to true
  • ui.osk.detect_physical_keyboard -- defaults to true, which I think disables the on-screen keyboard if a keyboard is detected -- Firefox might not notice if the physical keyboard is detached/disabled after it does its initial hardware detection
  • ui.osk.require_win10 -- defaults to true, which I think disables the on-screen keyboard on Windows 8.1 and earlier but in theory should not affect you since you run Windows 10.

Thank you!

Read this answer in context 👍 0

All Replies (6)

Hello,

You may have seen a post or received a notification regarding support for Firefox with a link to another site. This is a scam and is not an official site to receive support from Mozilla. Please do not click on the link and do not interact by calling any phone numbers or email addresses listed. You are currently posting on the official Mozilla website and will receive assistance here.

Helpful?

தீர்வு தேர்ந்தெடுக்கப்பட்டது

Hello laura hannah,

If restarting and re-attaching doesn't fix the problem,

try reinstalling the driver for your Surface Cover.

Select the search box in the taskbar,

enter device manager, and select

Device Manager in the results.
Expand Keyboards.
Right-click Surface Type Cover Filter Device


And another way:

What version of Firefox is it? There have been a lot of fixes this year.

Could you check and/or experiment with these settings -- I guess you'll need to attach your keyboard cover or use a bluetooth keyboard:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful.

(2) In the search box above the list, type or paste osk and pause while the list is filtered

(3) Try variations on these preferences:

  • ui.osk.enabled -- this obviously needs to be set to true
  • ui.osk.detect_physical_keyboard -- defaults to true, which I think disables the on-screen keyboard if a keyboard is detected -- Firefox might not notice if the physical keyboard is detached/disabled after it does its initial hardware detection
  • ui.osk.require_win10 -- defaults to true, which I think disables the on-screen keyboard on Windows 8.1 and earlier but in theory should not affect you since you run Windows 10.

Thank you!

Helpful?

E-mail was on time, just as you said. "james1081" with links that were OK I think.. but the phone number for support as [scam ph# removed] has 200 different look-ups. Keyboard problem fixed, not sure which one did it but am happy. Thanks to all.

Andrew மூலமாக திருத்தப்பட்டது

Helpful?

I had the same problem with my Surface Pro, only I was using an off-brand Bluetooth keyboard (Logitech Craft, to be exact). I'm just sharing my solution for anyone else who's facing a similar problem with a keyboard that doesn't involve a system driver. What fixed it for me was installing Logitech options and logging in to my account. Then the program automatically lead me to an "optimize the keyboard for these aps" page, which included Firefox. I selected to optimize, and after that the onscreen keyboard started working with my Surface pen.

In order to trigger the keyboard, I do have to hold the pen in the search bar for a second (not a tap or double tap), so if you run into a similar problem that might be the solution too.

Helpful?

The problem is not the cover/keyboard, that works correctly. It is the onscreen keyboard.

Helpful?

Help on to broseng

Helpful?

கேள்வி எழுப்பு

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.