Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Disable the new address bar features in Firefox 77

  • 26 பதிலளிப்புகள்
  • 15 இந்த பிரச்னைகள் உள்ளது
  • 753 views
  • Last reply by jscher2000

Hi,

I had applied the settings to disable the new urlbar features, but as of version 77 these no longer work.

I absolutely hate this change; it does nothing useful, it interferes with viewing the page, and it very much feels to me like change for the sake of change.

If someone can pass this on to whoever makes these unilateral decisions :

Don't make changes to the user interface that are not optional. How do they not understand that changing the UI for hundreds of millions of people is not a good idea?

So my question is, how do I disable the new urlbar "features" and return to a plain static one?

All Replies (6)

Tnx, have a nice day.

reneuitijsselstein மூலமாக திருத்தப்பட்டது

Helpful?

Hi reneuitijsselstein, if you decide to try again, feel free to start a new question in case there are unique circumstances that caused these steps not to work for you: https://support.mozilla.org/en-US/questions/1289351#answer-1318441

Helpful?

jscher2000 said

Hi reneuitijsselstein, if you decide to try again, feel free to start a new question in case there are unique circumstances that caused these steps not to work for you: https://support.mozilla.org/en-US/questions/1289351#answer-1318441

Sorry for the comment. I was in a bad mood, but now all is ok. Home office is making us crazy.

Tnx again for your solution, of course it worked.

Helpful?

reneuitijsselstein said

Home office is making us crazy.

I know the feeling!!!

Helpful?

jscher2000 said

The bold font is kind of extra. To emulate the older bolding, someone said to try a weight of 600 (standard bolding is 700):
.urlbarView-title > strong,
.urlbarView-url > strong {
  font-weight: 600 !important;
}


Where do I place this in userChrome.css? My userChrome look like this now, with no result

/*** BEGIN Firefox 77 (June 2, 2020) Override URL bar enlargement ***/

 /* Compute new position, width, and padding */
 #urlbar[breakout][breakout-extend] {
   top: 5px !important;
   left: 0px !important;
   width: 100% !important;
   padding: 0px !important;
 }
 /* for alternate Density settings */
 [uidensity="compact"] #urlbar[breakout][breakout-extend] {
   top: 3px !important;
 }
 [uidensity="touch"] #urlbar[breakout][breakout-extend] {
   top: 4px !important;
 }
 /* Prevent shift of URL bar contents */
 #urlbar[breakout][breakout-extend] > #urlbar-input-container {
   height: var(--urlbar-height) !important;
   padding: 0 !important;
 }
 /* Do not animate */
 #urlbar[breakout][breakout-extend] > #urlbar-background {
   animation: none !important;;
 }
 /* Remove shadows */
 #urlbar[breakout][breakout-extend] > #urlbar-background {
   box-shadow: none !important;
 }
 /* Bold in urlbar */
 .urlbarView-title > strong,
 .urlbarView-url > strong {
 font-weight: 600 !important;

}

/*** END Firefox 77 (June 2, 2020) Override URL bar enlargement ***/

Thank you for your answer.

Helpful?

reneuitijsselstein said

Where do I place this in userChrome.css? My userChrome look like this now, with no result

That should work. Were the other rules working, but the new ones don't? If you use a font-weight of 400 you should get regular (non-bolded) text if 600 doesn't work well for you.

Helpful?

  1. 1
  2. 2
கேள்வி எழுப்பு

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.