Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Certificate not working

  • 1 பதிலளி
  • 1 இந்த பிரச்சனை உள்ளது
  • 35 views
  • Last reply by cor-el

I am trying to access a website I use for work and needed to add a certificate in the keychain (I'm on a Mac). It works fine on Chrome but since I switched to Firefox (for another website that is buggy on Chrome) I can't access it. My company doesn't support Mac so no help there. Here's my error message:

An error occurred during a connection to remotegw2-dhhs.ne.gov. SSL peer was unable to negotiate an acceptable set of security parameters.

Error code: SSL_ERROR_HANDSHAKE_FAILURE_ALERT

I tried to import the certificate from my keychain but it's not visible there as an acceptable file. I have no idea what to do. Not just a liddlelost, but reallylost. Thanks!

I am trying to access a website I use for work and needed to add a certificate in the keychain (I'm on a Mac). It works fine on Chrome but since I switched to Firefox (for another website that is buggy on Chrome) I can't access it. My company doesn't support Mac so no help there. Here's my error message: An error occurred during a connection to remotegw2-dhhs.ne.gov. SSL peer was unable to negotiate an acceptable set of security parameters. Error code: SSL_ERROR_HANDSHAKE_FAILURE_ALERT I tried to import the certificate from my keychain but it's not visible there as an acceptable file. I have no idea what to do. Not just a liddlelost, but reallylost. Thanks!

All Replies (1)

Do you still have the original certificate that you added to the Mac Keychain, so you can possibly import this certificate in the Firefox Certificate Manager ?

Some certificates can also be imported by setting security.enterprise_roots.enabled = true on the about:config page, so you can give that a try.

You can open the about:config page via the location/address bar. You can accept the warning and click "I accept the risk!" to continue.