Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox 76.0.1 not playing embedded Twitter videos

  • 23 பதிலளிப்புகள்
  • 1 இந்த பிரச்சனை உள்ளது
  • Last reply by varices

On the entertainment media site Buzzfeed, clicking on a post of an embedded Twitter video gives me a blank white image. No error message like "Unable to play the file". I did a clear history, cache & cookies and refreshed Firefox. I ran the apt update for Ubunto. It had been operating smoothly in the past. If I go to Twitter, it plays. It just goes blank when I click on the video embedded in the post.

Thank you for any assistance.

Attached screenshots

தீர்வு தேர்ந்தெடுக்கப்பட்டது

cor-el That didn't work. Same results.

Now it doesn't go blank. It has the media cannot be played message.

I'm trying allow twitter for this session and checking the box to Delete cookies and site data when Firefox is closed.

We'll see if that shakes it up.


Read this answer in context 👍 0

All Replies (20)

Make sure you are not blocking content.

Start Firefox in Safe Mode {web link}

A small dialog should appear. Click Start In Safe Mode (not Refresh). Is the problem still there?

I ended up entering the following commands in the Terminal and it took.

48 sudo dconf reset -f /

49 sudo apt update

50 sudo reboot

It restored my desktop to original state. I think I may have fouled up by sticking my nose into Gnome tweaks.

Thanks for the tip FredMcD. I definitely need to learn my way around navigating Safe Mode.


varices மூலமாக திருத்தப்பட்டது

Ended up getting buggy again. I'll be looking into the Safe Mode options tomorrow. Over this day.

Cheers, varices

I went into Safe Mode and the problem still existed. The embedded Twitter video just goes blank when I click it. It also happened on another comedy site I visit.

I ran across this older thread

I have Cross Site Tracking Cookies blocked, could that be it? Would unblocking that pose any significant threat?

Edit - On the blocked list is

varices மூலமாக திருத்தப்பட்டது

Blocking cookies can cause issues when the wrong ones are blocked.

Firefox shows a blueish highlighted shield icon at the left end of the location/address bar in case Tracking Protection is blocking content. You can click shield icon for more detail and possibly disable the protection. You can check in the Web Console what content is blocked.

If you use extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) that can block content (Adblock Plus, NoScript, Disconnect, Ghostery, Privacy Badger, uBlock Origin) always make sure such extensions do not block content.

I tried about:preferences > privacy and protection > manage data and deleted all Twitter cookies and site data. Worked for a few tests then it went back to the problem.

Then I went to about:config and made sure media.autoplay.enabled was not set to false. Nope.

cor-el, I'll give your suggestions a go next.

Thank all, varices

Toggled enhanced tracking protection on site. Nope.

I have no additional enhanced tracking protection add-ons. The only extensions default, OpenH264 Video Codec and Widevine Content Decryption Module. All are updated. I also just ran the debug to see if that did anything.

Next I tried Safe Mode, it worked. Went back and restarted with add-ons enabled and it appears to have worked.

I'll send another update tomorrow to see if it is stable now. Last time when I rebooted Ubuntu it worked for awhile and then kicked back to the problem.

Thanks, varices

It could be the work of one of your add-ons, or it could be Hardware Acceleration. How to disable Hardware Acceleration {web link}

Type about:addons<enter> in the address bar to open your Add-ons Manager. Hot key; <Control> (Mac=<Command>) <Shift> A)

In the Add-ons Manager, on the left, select Extensions. Disable a few add-ons, then Restart Firefox.

Some added toolbar and anti-virus add-ons are known to cause Firefox issues. Disable All Of them.

If the problem continues, disable some more (restarting FF). Continue until the problem is gone. After, you know what group is causing the issue. Re-enable the last group ONE AT A TIME (restarting FF) until the problem returns.

Once you think you found the problem, disable that and re-enable all the others, then restart again. Let us know who the suspect is, detective.

The peculiar behavior returned.

I toggle the hardware acceleration. Nope. There was no disable all add-ons option under Extensions (I have no additional tracking protection or anti-virus). I hit reset all add-ons just to take a shot. Nope.

Toggled in and of safe mode, restarting Firefox with each attempt.

On the two sites in visit where, I've had this happen, it's only embedded Twitter videos. Not embedded videos from TikTok, not Instagram.

I went to Preferences and under Cookies allowed the exception for Twitter to use cookies and site data. Toggled Safe Mode again, restarting Firefox with each change. Nope.

So annoying. I know it's just entertainment, but I want it in one-click like everybody else. varices


I saw this old thread (4 years). Would the drivers have anything to do with it?

Clicking the tools icon opens the settings window, but their is no heading for hardware. I was able to find the locate my info via terminal. Is this worth pursuing?

I searched but don't seem to be asking the right questions. 

Thanks, varices

This has done the trick (for now).

Went to Safe Mode. Under manage permissions, allowed for Twitter exceptions on cookies. Set Performance to Use hardware acceleration when available. Restarted Firefox with add-ons enabled.

The embedded Twitter videos are working at this time.

Is this an ok workaround? Will I need to manage my cache more closely?

Note: Twice now, the player ability has reverted back to where the embedded video was not playing. Once again, I will follow up.

Thanks everyone, varices

varices மூலமாக திருத்தப்பட்டது

The problem returned. I cleared the cache and videos began to work again.

I think I'll try manually clearing as needed or set Firefox to Automatically clear the cache, then restart Firefox as needed.

Any ideas causes this? Will these workaround affect performance much?

Thanks, varices

Location of the cache/cache2 folder; Windows: *C:\Users\<user>\AppData\Local\Mozilla\Firefox\Profiles\<profile>\ Mac: ~/Library/Caches/Firefox/Profiles/ Linux: ~/.cache/mozilla/firefox/

Close Firefox. Open your file browser to the above, and remove the folder.


I just saw this thread that had additional details. I'm stuck on opening file browser now. Do I need an extension for that?

I'm probably asking the wrong questions in my search.

That solution sounds like it refines the clearing of the cache. Cool.

Thanks, varices

The file browser is a system program that lets you navigate your hard drive.

I think this is over my head. I guess I was able to open the folder using in the terminal using $ sudo gedit.

It opened a new window that stated: "/home/owner/.cache/mozilla/firefox" is a directory. Please check that you typed the location correctly and try again.

Do I then delete the handful of documents in the Firefox tab?

I really want to learn this since I've only switched to Ubuntu and Firefox in Feb. I've tried to tackle each issue and I try to work through each speed bump, so I really appreciate all the help.

Thanks, varices

Can anyone help with my last question? I've searched twice now but, once again, I think I'm asking the wrong questions.


You can reload web page(s) and bypass the cache to refresh possibly outdated or corrupted files.

  • hold down the Shift key and left-click the Reload button
  • press "Ctrl + F5" or press "Ctrl + Shift + R" (Windows,Linux)
  • press "Command + Shift + R" (Mac)
  1. 1
  2. 2