Search Support

Beware of phishing attacks: Mozilla will never ask you to call a number or visit a non-Mozilla website. Please ignore such requests.

Learn More

Comments/reader comments below articles in one site do not load in Firefox.

  • 2 பதிலளிப்புகள்
  • 1 இந்த பிரச்சனை உள்ளது
  • 6 views
  • Last reply by Geneva1

Many articles in the following site (and other related sites in black bar at the top) have a Discussion section with reader comments and replies. One example article here: https://vitals.lifehacker.com/why-too-much-positive-thinking-can-be-counterproductive-1843287897

The Discussion section should appear directly below the "More from Lifehacker" bullet points below the article (before the sponsored links). This section opens normally in the Edge browser on my Windows 10 laptop and also in the Chrome browser on my Android phone. It does not open in Firefox. It used to work normally but stopped working a few months ago. I use other sites with discussion/reader comments sections and they work in Firefox. I tried disabling the site trackers but that didn't help.

It is tedious to have to switch browsers for this site only as I would prefer to use Firefox.

தீர்வு தேர்ந்தெடுக்கப்பட்டது

Eve, thanks for the suggestion but for some reason the problem has corrected itself without any changes by me. I had previously tried turning off enhanced tracking (the shield on the URL bar) which didn't help. But when I now try accessing the same site using Firefox the comments section opens normally, so the problem has been resolved.

Thanks again.

Read this answer in context 👍 0

All Replies (2)

It's due to strict tracking protection, since you're denying cross-site cookies it can't load the comments section. Try turning off strict tracking protection (or enhanced tracking through the shield to the left of the url bar) and reloading the page and see if it loads properly that time

Helpful?

தீர்வு தேர்ந்தெடுக்கப்பட்டது

Eve, thanks for the suggestion but for some reason the problem has corrected itself without any changes by me. I had previously tried turning off enhanced tracking (the shield on the URL bar) which didn't help. But when I now try accessing the same site using Firefox the comments section opens normally, so the problem has been resolved.

Thanks again.

Helpful?

கேள்வி எழுப்பு

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.