Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

How to eliminate website suggestions from address bar.

  • 11 பதிலளிப்புகள்
  • 2 இந்த பிரச்னைகள் உள்ளது
  • 958 views
  • Last reply by jscher2000

The latest update of Firefox includes an incredibly annoying "feature". Clicking in the address bar brings up a drop-down list of sites: youtube, facebook, reddit, wikipedia, twitter. This is distracting and I don't like Firefox shilling for these other sites. How do I get rid of these?

தீர்வு தேர்ந்தெடுக்கப்பட்டது

Hello Mike,

This is a temporary fix (so I'm told), but I am optimistically hoping
that they will come to their senses …..

Would you do this please :

Type in the address bar about:config and press Enter. (ignore the warning)

Type in the search bar and look for the preference :

browser.urlbar.openViewOnFocus

and set its value to false

Do the same with these preferences :

browser.urlbar.update1

browser.urlbar.update1.interventions

browser.urlbar.update1.searchTips

Then close and restart Firefox.

(if it's only the Top Sites suggestions that you want to get rid of :
setting the value of first preference to "false" will do that)

Read this answer in context 👍 1

All Replies (11)

தீர்வு தேர்ந்தெடுக்கப்பட்டது

Hello Mike,

This is a temporary fix (so I'm told), but I am optimistically hoping
that they will come to their senses …..

Would you do this please :

Type in the address bar about:config and press Enter. (ignore the warning)

Type in the search bar and look for the preference :

browser.urlbar.openViewOnFocus

and set its value to false

Do the same with these preferences :

browser.urlbar.update1

browser.urlbar.update1.interventions

browser.urlbar.update1.searchTips

Then close and restart Firefox.

(if it's only the Top Sites suggestions that you want to get rid of :
setting the value of first preference to "false" will do that)

Helpful?

Hi McCoy, Thanks! Setting just the first preference you list to false did the trick. When you say this is a temporary fix, do you mean they will make it possible to eliminate this annoying thing in options or that if will revert at some point and I will have to do this again? Mike

Helpful?

Mike said

Hi McCoy, Thanks! Setting just the first preference you list to false did the trick.

My pleasure - I'm glad that helped you to get rid of that nuisance !

Would you be so kind as to mark my first post as Chosen Solution ? It's the "Solved the problem " button to the right of my first post.

Thank you in advance !

When you say this is a temporary fix, do you mean they will make it possible to eliminate this annoying thing in options or that if will revert at some point and I will have to do this again?

In all honesty : I was told that this was a temporary fix, and I have no idea what to expect. I can only hope that we'll be able to disable it for good, cause I don't want this "new feature" either !

Helpful?

Sorry, mate. You suggestion is worthless on v76.0.1. The bloody address bar sites still appear. Must have been an "enhancement" by some script kiddie showing off.

Helpful?

RealGomer said

Sorry, mate. You suggestion is worthless on v76.0.1. The bloody address bar sites still appear. Must have been an "enhancement" by some script kiddie showing off.

Assuming that you're talking to me (I'm not a man btw) :   I said that this was a temporary fix ....

If you want to, you could submit feedback and let them know how you feel about this, using this link :

https://qsurvey.mozilla.com/s3/FirefoxInput/

Helpful?

Hi RealGomer, your screenshot shows the Top Sites list. If you do not want that list to open immediately when the cursor enters the address bar, the setting to prevent that is the first one listed in McCoy's solution:

McCoy said

Type in the address bar about:config and press Enter. (ignore the warning)

Type in the search bar and look for the preference :

browser.urlbar.openViewOnFocus

and set its value to false

That works for me on Firefox 76.0.1.

If you aren't familiar with about:config, you can double-click a boolean preference to switch its value between true and false.

After that, if you want to drop the list, you'll need to press the down arrow key in an empty address bar.

Helpful?

McCoy said

RealGomer said

Sorry, mate. You suggestion is worthless on v76.0.1. The bloody address bar sites still appear. Must have been an "enhancement" by some script kiddie showing off.

Assuming that you're talking to me (I'm not a man btw) :   I said that this was a temporary fix ....

If you want to, you could submit feedback and let them know how you feel about this, using this link :

https://qsurvey.mozilla.com/s3/FirefoxInput/

Sorry, mate, or if you prefer, Sheila.

It was quite a temporary fix. The bugger didn't last past the next time I used the address bar. Still think it was an enhancement by some script kiddie coder wanting to show off.

Helpful?

RealGomer said

It was quite a temporary fix. The bugger didn't last past the next time I used the address bar. Still think it was an enhancement by some script kiddie coder wanting to show off.

The people who answer questions here are (for the main part) volunteers, users just like you, who are trying to help other users in their spare time (like me).

I suggested to submit feedback using this link :

https://qsurvey.mozilla.com/s3/FirefoxInput/

There is nothing we can do about it;   we are not Mozilla developers .....

Helpful?

I have just encountered this problem after accepting an update to Firefox Mozilla to version 78.0.1 (64-bit). I tried the solution you have given, but alas it's not worked. The change to "false" was accepted on all four items, but still those website suggestions show up. Are there any other possible solutions? Thank you in advance for your help.

Helpful?

Found it. Open about:config and then search for browser.urlbar.suggest.topsites. Change it to false.

Have a nice day!

deliozzz மூலமாக திருத்தப்பட்டது

Helpful?

deliozzz said

Penny said

I have just encountered this problem after accepting an update to Firefox Mozilla to version 78.0.1 (64-bit). I tried the solution you have given, but alas it's not worked. The change to "false" was accepted on all four items, but still those website suggestions show up. Are there any other possible solutions? Thank you in advance for your help.

Found it. Open about:config and then search for browser.urlbar.suggest.topsites. Change it to false.

Have a nice day!

Yes, Firefox 78 created that new preference and this corresponding checkbox on the Options/Preferences page:

That replaces the earlier "browser.urlbar.openViewOnFocus" preference.

Helpful?

கேள்வி எழுப்பு

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.