Search Support

Firefox still keeps asking for master password after applying fixes

  • 12 பதிலளிப்புகள்
  • 1 இந்த பிரச்சனை உள்ளது
  • 6 views
  • Last reply by kaiser1111

I have applied the suggested fix for stopping the master password from popping up every time I go to a new site but it keeps happening. I open firefox with google search. I start to enter a search but the master password box pops up and I find I am typing my search query in the M P box. If I cancel it it just pops up again. This is before I even get to any site. When there it will come up again when following a link in that site and so on. This is very annoying and I am considering dumping firefox because of it. Please don't tell me to do the M password replacement procedure IT DOES NOT WORK. I have also tried editing the registry but that failed also. Robert.

All Replies (12)

Hello kaiser1111,

Would you please disable your extensions (providing you
still have any) and see if that will make a difference ?

I'm asking because of your post in this (8-yo) thread :

https://support.mozilla.org/en-US/questions/866291

Helpful?

Hi, that was quick. The only ext I have is "IObit Surfing Protection & Ads Removal (disabled)" which as you can see is disabled. This has only started in the last 2 or 3 months. I have tried every solution I can find. But still happens. What if I go back to an earlier version?

kaiser1111 மூலமாக திருத்தப்பட்டது

Helpful?

I of course don't know what you have already tried, but going back to an earlier version : please, don't.

Would you take a look at these two threads and see if maybe something there might help solve your problem :

https://www.reddit.com/r/firefox/comments/a6ziqb/firefox_master_password_window_popping_up/

And :

https://superuser.com/questions/1233346/using-master-password-without-prompt-popup-in-firefox

If neither are any good, then I'm sure that somebody else will come to your rescue ....

(edit : typo)

McCoy மூலமாக திருத்தப்பட்டது

Helpful?

Sorry, neither of these helped. Security is set at default '0'. I don't have sync turned on. All these are unchanged since this trouble started. Thanks for trying :)

Helpful?

kaiser1111 said

I have applied the suggested fix for stopping the master password from popping up

Am I right assuming that you are referring to this article (?) :

https://support.mozilla.org/en-US/kb/firefox-keeps-asking-me-master-password

Helpful?

Sorry for the late reply this one had gone into my junk folder. Yes that is correct tried that maybe 8 or 9 times with the same result, worked at first then back to the same problem. I have just noticed the password pop up doesn’t seem to happen until after I have gone to one of my sites where I expect the password request to happen. This is after starting my PC. After accessing that site and closing it, the next time I opened Firefox the password request came up immediately without any further input. (It came up twice when I opened this link.) I have tried this a few times and it seems to be a pattern. I will keep this in mind each time I do a start to see if it is always true. I shut down my PC instead of sleeping it as it has a habit of restarting randomly of its own. (Something else that seems unfixable it was doing it on Win 7 as well!)

Robert.

Helpful?

Hi there all you FF geniuses, just to let you know I am still having the same problem and no one else has had any suggestions. I have been trying all the “fixes” again but nothing helps. I have discovered that the fix of removing and reinstalling the Master Password does fix the problem until I go to a site where the MP would normally appear. The next time I open Firefox the MP request pops up 5 or 6 times or until I enter the PW, even if it is not required. Then the next link I open it starts all over again. I find it strange that there seems to be no fix for this problem as I understand I am not the only one suffering this. If it's not fixed soon I will have to go to a different browser. It's just too annoying to have to put the MP in every few minutes. I have also tried not having a MP for a couple of weeks but as soon as I use it again the same problem.

Regards

Robert.

Helpful?

What fixes did you apply?

You will have to disable the Password Manager temporarily if you do not want to use it for entering a username and password on web pages.

  • Options/Preferences -> Privacy & Security: Logins and Passwords: "Ask to save logins and passwords for websites"

I'm not sure if the timeout for asking the master password when you cancel a prompt is always working properly.

Helpful?

As you can see from previous correspondence I have done all fixers that I can find to solve this problem. I have used the config editor before I'm not sure what for but that was long before this problem started. What do you suggest I modify the time out too? It is on 900000 now. I don't see timing as a problem. The MPW pop up will activate at random times, sometimes immediately I open FF, other times after I go to a different web site. It may pop up once or twice or many times until I enter the MPW. Then when I go to another site it will start over again. Thanks for your help.

Helpful?

kaiser1111 said

The next time I open Firefox the MP request pops up 5 or 6 times or until I enter the PW, even if it is not required. Then the next link I open it starts all over again. ... It's just too annoying to have to put the MP in every few minutes.

kaiser1111 said

The MPW pop up will activate at random times, sometimes immediately I open FF, other times after I go to a different web site. It may pop up once or twice or many times until I enter the MPW. Then when I go to another site it will start over again.

Hi Robert, normally you only need to enter the Master Password once per session, and your saved logins are unlocked unless/until you call up and cancel a Master Password dialog, for example, by trying to view a password on the Logins and Passwords page. So something unusual is going on if even after you unlock your logins you have to do it over and over within the same session.

Or are you closing Firefox between links? If you are closing Firefox and starting a new session, then it would make more sense for the prompt to display again when you load a website for which you have a saved login.

This was something cor-el mentioned in an earlier reply:

I realize it's not an appealing workaround, but if you very rarely use a saved login, you can disable Lockwise by unchecking the box on the Options page.

  • Windows: "3-bar" menu button (or Tools menu) > Options
  • Mac: "3-bar" menu button (or Firefox menu) > Preferences
  • Linux: "3-bar" menu button (or Edit menu) > Preferences
  • Any system: type or paste about:preferences into the address bar and press Enter/Return to load it

In the search box at the top of the page, type login and Firefox should filter to the "Logins and Passwords" section. Then you can uncheck the box for "Ask to save logins and passwords for websites".

You'll need to check it once again to re-enable Lockwise.

Helpful?

Note that you can open the about:preferences page in a pinned tab for easy access.

Helpful?

Thank you for your reply. Sorry, reading my latest post I think I gave the wrong impression . The MPW prompt does not reappear after I enter it for that session. It does reappear if I just cancel it several times as it pops up. For example I go to a link, (that does not require the MPW), from my email, sometimes the MPW pops up immediately, sometimes after a few seconds, sometimes after a few minutes sometimes never. I read a few very long articles and suddenly the MPW will appear, I cancel it. It may not happen again or it may come up again later. The only way I can be sure it won't reappear is to enter my PW even though it's not required. The trouble is I never know when it will happen. I may be writing something and the MPW pops up and then I am typing into the MPW box (I look at the keyboard not the screen when typing) so I may have put quite a bit into the MPW box before I realise what is happening! The only way I can stop this at the moment is to go to a site that requests the MPW, enter it and then continue as normal. Not very scientific! I'm not sure just when this started but it may have been around the time (January-Feb) I moved to win 10 from Win 7. I beleive it was after but not immediately, maybe a couple of weeks or so later. Regards Robert.

Helpful?

கேள்வி எழுப்பு

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.