Where did you install Firefox from? Help Mozilla uncover 3rd party websites that offer problematic Firefox installation by taking part in our campaign. There will be swag, and you'll be featured in our blog if you manage to report at least 10 valid reports!

Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox doesn't restore my session even though the box is checked in Options

  • 5 பதிலளிப்புகள்
  • 1 இந்த பிரச்சனை உள்ளது
  • 24 views
  • Last reply by broccoli.salad.soup

Also, when I click on the Layers icon in the upper right corner, there is no option to restore the previous session.

Also, when I click on the Layers icon in the upper right corner, there is no option to restore the previous session.

தீர்வு தேர்ந்தெடுக்கப்பட்டது

Does your Firefox record tab and window history normally during regular use? For example, if you open a new window using Ctrl+n, then close the window, can you re-open it using Ctrl+Shift+n or the menu item here:

  • "3-bar" menu button > Library > History > Recently closed windows
  • Library toolbar button > History > Recently closed windows
  • (menu bar) History > Recently closed windows

Please also make sure Firefox doesn't delete browsing history at shutdown. You can check that here:

  • Windows: "3-bar" menu button (or Tools menu) > Options
  • Mac: "3-bar" menu button (or Firefox menu) > Preferences
  • Linux: "3-bar" menu button (or Edit menu) > Preferences
  • Any system: type or paste about:preferences into the address bar and press Enter/Return to load it

In the left column, click Privacy & Security

On the right side, scroll down to the History section. Usually it says:

Firefox will: Remember history

If it says

Firefox will: Use custom settings for history

make sure this box is not checked:

[_] Clear history when Firefox closes

If it says

Firefox will: Never remember history

that setting is not compatible with restoring your session.

Was everything okay there?

Read this answer in context 👍 0

All Replies (5)

தீர்வு தேர்ந்தெடுக்கப்பட்டது

Does your Firefox record tab and window history normally during regular use? For example, if you open a new window using Ctrl+n, then close the window, can you re-open it using Ctrl+Shift+n or the menu item here:

  • "3-bar" menu button > Library > History > Recently closed windows
  • Library toolbar button > History > Recently closed windows
  • (menu bar) History > Recently closed windows

Please also make sure Firefox doesn't delete browsing history at shutdown. You can check that here:

  • Windows: "3-bar" menu button (or Tools menu) > Options
  • Mac: "3-bar" menu button (or Firefox menu) > Preferences
  • Linux: "3-bar" menu button (or Edit menu) > Preferences
  • Any system: type or paste about:preferences into the address bar and press Enter/Return to load it

In the left column, click Privacy & Security

On the right side, scroll down to the History section. Usually it says:

Firefox will: Remember history

If it says

Firefox will: Use custom settings for history

make sure this box is not checked:

[_] Clear history when Firefox closes

If it says

Firefox will: Never remember history

that setting is not compatible with restoring your session.

Was everything okay there?

Ctrl+Shift+n works; also, Ctrl+Shift+T after closing a tab. History section says: Remember history

Just discovered that when I open Firefox again, and get one tab on my home page, if I click on recently closed WINDOWS, I see a icon that will open my last session as a new window.

broccoli.salad.soup மூலமாக திருத்தப்பட்டது

Nevermind. Problem was that a second Firefox window was opened, probably as I was just beginning to use it--I just installed it--and I didn't notice. So I was using, and then closing that second window, and that's why when I opened Firefox again, I got the blank window. When I discovered the old, original window--I have 20 windows open; that's normal--and closed it, when I opened Firefox again, there were all the tabs. I think I'll go have a beer.

Glad you sorted it out. I always close Firefox using the menu to avoid having the wrong windows in a "closed" status:

  • "3-bar" menu button > Exit
  • (menu bar) File > Exit
  • (keyboard) Alt+F then x