Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

How can I clear history "vlinks" when Firefox exits?

  • 14 பதிலளிப்புகள்
  • 1 இந்த பிரச்சனை உள்ளது
  • 6 views
  • Last reply by cor-el

None of the options in "clearing history" reset 'visited' links to 'not visited'. Therefore, even days later, any links I've visited are still marked as 'visited'.

Attached screenshots

All Replies (14)

You could set layout.css.visited_links_enabled to false in about:config. I don't know if that's the cleanest option though. Also, visited links would never turn purple, not even during the current browser session.

Hello Dick,

Would you please make sure that you're not in permanent Private Browsing mode :

3-bar menu (or "Tools") => Options => Privacy & Security => under "History":

Firefox will : choose "Use custom settings for history"

Uncheck  : "Always use private browsing mode"

'Hope that does the trick !

Note that you use a pre Quantum Firefox 56 version. Any specific reason why you do not use the current Firefox release (74) ?

Can you clear history in Firefox during the session ?


If you use Sync then best is to disconnect Sync temporarily during troubleshooting.

You can check for problems with the places.sqlite and favicons.sqlite files in the Firefox profile folder.

  • use "Verify Integrity" button on the "Help -> Troubleshooting Information" (about:support) page

If errors are reported with "Verify Integrity", close and restart Firefox and retry.

If "Verify Integrity" cannot repair places.sqlite, rename/remove all places.sqlite and favicons.sqlite files in the Firefox profile folder. Firefox will rebuild places.sqlite and restore the bookmarks from a recent JSON backup in the bookmarkbackups folder.

  • keep a backup copy of places.sqlite in case a new places.sqlite database has to be created

See also:

You can use the button on the "Help -> Troubleshooting Information" (about:support) page to go to the current Firefox profile folder or use the about:profiles page.

Unlambder said

You could set layout.css.visited_links_enabled to false in about:config. I don't know if that's the cleanest option though. Also, visited links would never turn purple, not even during the current browser session.

My pages specifically set 'link=blue vlink=purple'

DICKGUERTIN மூலமாக திருத்தப்பட்டது

McCoy said

Hello Dick, Would you please make sure that you're not in permanent Private Browsing mode : 3-bar menu (or "Tools") => Options => Privacy & Security => under "History": Firefox will : choose "Use custom settings for history" Uncheck  : "Always use private browsing mode" 'Hope that does the trick !

I'm using 56.0.2, which doesn't have these options. Currection: I have the options set the way you suggest:

Firefox will : choose "Use custom settings for history" Uncheck  : "Always use private browsing mode"

DICKGUERTIN மூலமாக திருத்தப்பட்டது

DICKGUERTIN said

I'm using 56.0.2, which doesn't have these options.

I should have paid better attention - didn't notice that you're on Mac, so "Options" should be "Preferences" .....

My apologies.

But that option should definately be there !

McCoy மூலமாக திருத்தப்பட்டது

DICKGUERTIN மூலமாக திருத்தப்பட்டது

DICKGUERTIN said cor-el said

Note that you use a pre Quantum Firefox 56 version. Any specific reason why you do not use the current Firefox release (74) ? Can you clear history in Firefox during the session ?

If you use Sync then best is to disconnect Sync temporarily during troubleshooting.

You can check for problems with the places.sqlite and favicons.sqlite files in the Firefox profile folder.

  • use "Verify Integrity" button on the "Help -> Troubleshooting Information" (about:support) page

If errors are reported with "Verify Integrity", close and restart Firefox and retry.

If "Verify Integrity" cannot repair places.sqlite, rename/remove all places.sqlite and favicons.sqlite files in the Firefox profile folder. Firefox will rebuild places.sqlite and restore the bookmarks from a recent JSON backup in the bookmarkbackups folder.

  • keep a backup copy of places.sqlite in case a new places.sqlite database has to be created

See also:

You can use the button on the "Help -> Troubleshooting Information" (about:support) page to go to the current Firefox profile folder or use the about:profiles page.

cor-el, I've found that 'Newer Isn't Always Better', so I stuck with 56.0.2 because 'It worked for me'. Today I discovered that if I choose 'Everything' from the History menu, vlinks get reset. BUT,I literally loose just about everything. I wish there was an option to clear-the-history for links/vlinks. DickGuertin

DICKGUERTIN மூலமாக திருத்தப்பட்டது

Clearing the "Browsing & Download history" via "Clear history when Firefox closes" should be sufficient.

You should still find "Always use Private Browsing mode" via "Options/Preferences -> Privacy".

To see all History and Cookie settings, choose:

  • Preferences -> Privacy
    Firefox will: "Use custom settings for history"

McCoy said

I should have paid better attention - didn't notice that you're on Mac, so "Options" should be "Preferences" .....

My apologies.

But that option should definately be there !

To all who have responded, I've found that Safari has the capability to 'Clear History' which includes vlinks. That's what I'm after on Firefox.

I ran into this problem immediately after installing a new Linux OS. Turned out (after several frustratingly ineffective attempts) to be a simple fix in my case. On clicking the History > Clear recent history (Ctrl+Shift+Del) links, I finally noticed that the default setting for "Time range to clear" (at the top of the pop-up pane) was defaulting to "Last hour." When I set it to "Everything" and hit the "OK" button--whaddya know--everything in my history was cleared.

You can alternatively use "Forget About This Site" to clear history for specific websites, but this includes more than visit history. As long as there is a visit count greater than zero (i.e. history is present for this link), you will see a visit CSS style applied.