Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox is slow to start, freezes for a few seconds with every new tab, and will not play YouTube videos.

  • 4 பதிலளிப்புகள்
  • 1 இந்த பிரச்சனை உள்ளது
  • 1552 views
  • Last reply by cor-el

For several days now I've been having issues with Firefox. It is very slow to start up, freezes for 10 seconds when a new tab opens, takes another 10 seconds to begin loading the new tab after unfreezing, and will not play YouTube videos (tries loading but always gives "error has occurred" message). I have tried reinstalling Firefox twice and it has not changed anything. I've also turned off advanced performance settings. Can someone help?

For several days now I've been having issues with Firefox. It is very slow to start up, freezes for 10 seconds when a new tab opens, takes another 10 seconds to begin loading the new tab after unfreezing, and will not play YouTube videos (tries loading but always gives "error has occurred" message). I have tried reinstalling Firefox twice and it has not changed anything. I've also turned off advanced performance settings. Can someone help?

தீர்வு தேர்ந்தெடுக்கப்பட்டது

Start Firefox in Safe Mode {web link}

A small dialog should appear. Click Start In Safe Mode (not Refresh). Is the problem still there?

Read this answer in context 👍 1

All Replies (4)

தீர்வு தேர்ந்தெடுக்கப்பட்டது

Start Firefox in Safe Mode {web link}

A small dialog should appear. Click Start In Safe Mode (not Refresh). Is the problem still there?

Thanks, that seems to have fixed the issues!

It could be the work of one of your add-ons, or it could be Hardware Acceleration. How to disable Hardware Acceleration {web link}

Type about:addons<enter> in the address bar to open your Add-ons Manager. Hot key; <Control> (Mac=<Command>) <Shift> A)

In the Add-ons Manager, on the left, select Extensions. Disable a few add-ons, then Restart Firefox.

Some added toolbar and anti-virus add-ons are known to cause Firefox issues. Disable All Of them.

If the problem continues, disable some more (restarting FF). Continue until the problem is gone. After, you know what group is causing the issue. Re-enable the last group ONE AT A TIME (restarting FF) until the problem returns.

Once you think you found the problem, disable that and re-enable all the others, then restart again. Let us know who the suspect is, detective.

Do you have any content blocking extensions ?

If you use extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) that can block content (Adblock Plus, NoScript, Disconnect, Ghostery, Privacy Badger, uBlock Origin) always make sure such extensions do not block content.

Firefox shows an highlighted shield icon at the left end of the location/address bar in case Tracking Protection is blocking content.

  • click the shield icon for more details and possibly disable the protection

You can check in the Web Console what content is blocked.


You can remove all data stored in Firefox for a specific domain via "Forget About This Site" in the right-click context menu of an history entry ("History -> Show All History" or "View -> Sidebar -> History").

Using "Forget About This Site" will remove all data stored in Firefox for this domain like history and cookies and passwords and exceptions and cache, so be cautious. If you have a password or other data for that domain that you do not want to lose then make sure to backup this data or make a note.

You can't recover from this 'forget' unless you have a backup of involved files.

If you revisit a 'forgotten' website then data for that website will be saved once again.