Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Links from emails not working.

  • 20 பதிலளிப்புகள்
  • 2 இந்த பிரச்னைகள் உள்ளது
  • Last reply by OzSteveC

Starting about 02/11/2020, links in emails take me to a blank page and FireFox stops working. Must close FireFox.

I have neither added nor updated any add-ons.

I disabled all add-ons with no change.

Under Performance, I unchecked " Use recommended performance settings" and 'Use hardware acceleration when available". No change.

The only way a link works is if I have (basic) FireFox already running.

I have reversed the above changes and await HELP.

All Replies (20)

In Windows 8.1 temporarily set a different web browser as the "default browser". Then launch Firefox a few times; then in Windows set Firefox as the "default browser". See if that fixes the issue.

This suggestion made no sense to me but considering how flakey Firefox has become since Quantum I tried it.

Made Chrome the default and launched Firefox 5 times, alternating between going to a website or just launching and closing.

On the 6th launch, I made Firefox the default, closed it and then tried a link.

Issue not fixed!

Thank you anyway.

AIVAS said

Starting about 02/11/2020, links in emails take me to a blank page and FireFox stops working. Must close FireFox.

This seems to have occurred with the 73 update. When Chrome is set to be the default browser, the email links work properly.

i have been unable to find a reliable copy of FF 72 to roll back.



Does anyone actually check these so called "updates"?

I'll start looking for FF 72. Post if you find one.



I've just downloaded and installed FF 72.02 and its email links work fine. The fault appears to have come with FF73.0.

Disconnect your modem after downgrading and before you run FF, and turn off auto update, otherwise it auto updates which you can't cancel. Chrome is looking very good now.

I have also lost my old bookmarks and profile, good thing I backed them up before I downgraded.

EDIT: I have been able to recover my old bookmarks and history by resetting old profiles. Is there a way I can roll back to 72.02 and still keep my history and bookmarks?



OzSteveC மூலமாக திருத்தப்பட்டது

Same here. Rolled back. Lost everything.

It upgraded back to FF 73 but everything is missing. On the bright side (NOT!), FF 73 may (?) be processing links properly.

Since FF is unusable without major reconstruction, my time would be better spent constructing Chrome.

Does anyone know the path to my settings?

OK. It looks like I restored everything (my profile) from a month old backup.

It also looks, as previously stated, that all of this (lots of time lost that, being a senior citizen, I do not have to spare) has "fixed" least until the next "update".

Where do I send the bill?

This might help someone else with the problem, if someone loses their bookmarks and browsing data after trying to downgrade then upgrading again due to the default auto upgrade. In FF73, in the url filed type "about:profiles" (no quotation marks though). DO NOT DELETE ANYTHING.

In FF73, go through each profile in turn and select "launch in new browser". With any luck, one of those will work in FF73 and you can recover all your data.

Then go to Chrome where you can import all your settings, history and bookmarks directly from within Chrome. Under "Bookmarks and Settings" you can import everything directly from Firefox.

Goodbye Firefox and hullo Chrome. Most of the standard addons have a Chrome version.


Steve Click

OzSteveC மூலமாக திருத்தப்பட்டது

Very well said!

I notice we have not heard from Mozilla about any of this.

An update,

We may have been too quick to jump down Mozilla's throat. I normally use WLM 2012, which of course is not supported by MS anymore and is not supposed to work on Win 10, or at least not very well. However, it works fine for me, even on the latest Win 10. I use it because it is much better than Win 10 Mail and I refuse to bow to the MS Office subscription model. I have tried other email clients and keep coming back to WLM.

One thing I meant to test but have not had the time was to test using Win 10 Mail.

Guess what, it works on Win 10 Mail, so perhaps not an FF problem after all.

What email clients are you using, try a different one? I'll play with WLM2012 security settings to see if that makes a difference.



OzSteveC மூலமாக திருத்தப்பட்டது

A further update,

Links work fine in Emclient, so it appears it is an email client/firefox communication problem.

I doubt we'll ever get a fix, I'm not sure if Mozilla developers read this forum.



I am still on Windows 8.1 (64-bit) due to certain software that will not work on Windows 10. That said, I use Office 2003, with Outlook, for no better reason than it works and I don't need anymore.

My wife, who is somewhat computer literate (while not in my league) opted to go to Windows 10 a year or so ago. After her SSD crashed last month and our son rebuilt it (he's better than me and can see the small parts) he talked her into Office 365, with Outlook.

We both use FiOS.

So far, after the downgrade/upgrade/restore this AM, FF appears to be behaving. My wife seems to be unaffected.

"I'm not sure if Mozilla developers read this forum."

I doubt it. Too busy screwing-up the next "upgrade" (sic).

BTW, I'm David.

Did anyone who gets blank tabs in Firefox 73.0 install today's patch with fixes for that and other issues:

Article: Update Firefox to the latest release

jscher2000 said

Did anyone who gets blank tabs in Firefox 73.0 install today's patch with fixes for that and other issues:

Wonder of wonders, the update has fixed the blank page problem.

No mention of the problem fix in release notes for 73.0.1 though.

I did put a comment in "Firefox Makes Me Sad" section on the Mozilla page yesterday, someone must have read that or this forum.

FF is usually pretty good, although I don't understand s/w mentality of, "let's upgrade because we can", or "I have to justify my salary!"

I'm a great believer in "if it ain't broke, don't fix it"!



OzSteveC மூலமாக திருத்தப்பட்டது

Hi Steve, in the week since its release, there were over a dozen threads here and on Reddit about unusual inoperable blank tabs among Windows users that had Firefox 73 set to run in backwards compatibility mode (presumably at the behest of the Windows compatibility wizard). Some Windows 7 users also were affected.

A bug was filed Feb. 12th, and the patches were developed and went into testing in the Nightly version within 48 hours. Beta testing followed and the efficacy of the patches was confirmed on Saturday, and approved for a 73.0.1 release. The new version was built on the Monday holiday.

As emergency responses go, that's quite good.

I think the forum volunteers making the rounds of threads that could be affected didn't catch this one because of the subject line.

Anyway, that messy episode is now history. On to the next challenge.

After several non-computer things yesterday, it occurred to me just before we turned in to check the logs. Apparently the "fix" occurred while I was rolling back/recovering/upgrading. Implying that it might have been the "fix" rather than what I did. Then I checked my wife's computer (although she rarely gets anything with links) but she already had the "fix". My laptop is still running FF 72 and I am hesitant to "upgrade". That applies to all future "upgrades".


AIVAS said

My laptop is still running FF 72 and I am hesitant to "upgrade". That applies to all future "upgrades". David

Understandable, I am a great believer in "if it aint' broke, don't fix it". I have turned off auto upgrade for FF.

I am running the updated FF (73.0.1) and no longer get the blank screen when clicking links. Having said that, you always need to be careful when clicking links and always check the link looks legit by hovering over the link button and reviewing it at the bottom of your email client.



Another user reported this morning that the message popup is completely blank now and I see that, too. In order to fix it, I had to liberalize my cookie settings for the site. Since you both did a major settings overhaul, perhaps that modified the problem setting in the process.

Normally I use the option "Delete cookies and site data when Firefox is closed", which is on the Privacy & Security tab of the Options page:


In order to get the Outlook message to load in the popup window, I granted cookie permission to using the Exceptions dialog:

(0) Click the Manage Permissions button

(1) Paste in the "Address of website" box

(2) Click the Allow button to add it to the list

(3) Click the Save Changes button at the lower right

You may not need that at this point, but I'll leave it here for possible future reference.

This was fixed in a bug fix release a few days later.