Search Support

Beware of phishing attacks: Mozilla will never ask you to call a number or visit a non-Mozilla website. Please ignore such requests.

Learn More

mouse wheel scroll stops working for no apparent reason in all tabs and only way to correct it is to close firefox and reopen

  • 27 பதிலளிப்புகள்
  • 2 இந்த பிரச்னைகள் உள்ளது
  • 39 views
  • Last reply by FredMcD

Version 68.4.1esr (64-bit) Linux

All Replies (20)

How long is it before the problem begins?

Helpful?

It varies, an hour ago I had to close firefox because of it then restarted and when I opened the 3rd tab after about 3 minutes it did it but really no set period, just random. If I hold down the middle button and scroll it will scroll

Helpful?

Did you try to reboot the computer (always the first to try with weird issues) ?

Helpful?

yeah this has been going on for a very long time now, had several new kernels in that time. I even uninstalled it I was that pissed with it and used vivaldi and opera but I prefer firefox and this is the only issue I have with it

Helpful?

There shouldn't be a problem with using the mouse wheel on Linux.

Did you check the mouse settings in your Linux distribution to make sure your mouse is setup properly ?

Did you try another mouse ?

Helpful?

settings seem ok, standard and unchanged since day 1 I have bought a new mouse but still the same

Helpful?

Helpful?

working as it should under xev the problem is only with firefox, the mouse works perfectly everywhere else

Helpful?

Did you check mousewheel prefs like mousewheel.default.action on the about:config page in Firefox ?

Action:

0: Nothing happens
1: Scrolling contents
2: Go back or go forward, in your history
3: Zoom in or out (reflowing zoom)
4: Treat vertical wheel as horizontal scroll
5: Zoom in or out (pinch zoom)

cor-el மூலமாக திருத்தப்பட்டது

Helpful?

It is possible that some of the status keys have the wrong state and Firefox sees them as still being pressed.

Try to press all the status keys (Shift, Ctrl, Alt) a few times to see if that helps to recover from this. If it doesn't help then close and restart Firefox or reboot the computer.

Helpful?

there doesn't seem to be a file with that in it

while I was looking for that setting it happened again so I went to mouse settings under input devices (as you suggested earlier) checked the "change pointer settings over icon", applied it and the mouse now scrolls seems any change to any input settings will bring scroll back to life

Helpful?

Sorry, I forgot to add that you can inspect prefs on the about:config page.

You can open the about:config page via the location/address bar. You can accept the warning and click "I accept the risk!" to continue.

Helpful?

Start Firefox in Safe Mode {web link}

A small dialog should appear. Click Start In Safe Mode (not Refresh). Is the problem still there?

Helpful?

started in safe mode, will advise

Helpful?

I left firefox in safe mode for several hours and there were no issues with the mouse but I was having difficulty uploading so exited.

I've been running in normal mode for quite some time now and had no issues with the mouse scroll yet. weird

Helpful?

Maybe you visit a web page that disables pointer-events.

Did you ever try to click on the web page or in the user interface (location/address bar) or move to another tab to see if that has effect?

Helpful?

Not sure what you mean, when it happens it affects all open tabs.

It's just happened again now, it's been a much longer time though since it was in safe mode.

Helpful?

I just went into mouse settings and checked "reverse scroll direction" and applied it and that re enabled scroll...however it is not in reverse, it's still normal.

Helpful?

Is this with all websites/pages, some, a few?

Helpful?

  1. 1
  2. 2
கேள்வி எழுப்பு

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.