Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

After 72.0.2 update pages load slower - every link I click hangs for 1-2 seconds before loading. Even with only 1 process.

  • 5 பதிலளிப்புகள்
  • 1 இந்த பிரச்சனை உள்ளது
  • 9 views
  • Last reply by Piterk

After 72.0.2 I started to notice performance problems with my firefox. Symptoms are similiar to my multiprocess problems I had after it was added. I managed to avoid it for some time by limiting processes number to 1 (which was 4 in reality)

Long story short: when you open new tab firefox has to create new process which is somewhat correlated to your PC performance (however it hangs up even on 4800MHz i5 with nvme pci-e 3.0 x4 ssd so....). When this process is already created and you enter different website it is smooth - firefox does not have to create another process until you open NEW TAB or it reaches its limit (from 1 to 8 processes/tabs) - set via settings. If limit was set to more than 1 I had problems with hanging up for few seconds until I reached limit - so if it was set to 4 I opened 1 tab and 3 links I clicked (with new tabs) slowed firefox down for me, but 4th, 5th etc. were fine. So I set it to 1 permanently and problem disappeared - every tab opened as fast as before.

But now problem seems to have returned. I still have 1 in my settings but symptoms are pretty much the same (but there are only 4 processes). However browser is not hanging up - it seems like connection is. It does nothing - "waiting for xxxxxx" in lower left corner and then after 1-2s page actually starts to load. It is present on every website I visit, no matter how many tabs or windows I open.

So my question is - what did you break in this firefox version? Previously it was youtube, now it is all sites...

தீர்வு தேர்ந்தெடுக்கப்பட்டது

Nice suggestion. I tried disabling all add-ons and found faulty one: https://addons.mozilla.org/pl/firefox/addon/youtube-ratings-preview/

It slows down firefox. Maybe it is google fault somehow because searching via google has something to do with youtube servers now and this addon slows this search down? Or mozilla changed something small in 72.0.2 and this add-on is no longer fully compatible?

However I still experience small lags when opening new websites - 1 second delay before page starts to load. Maybe it is different issue?

Read this answer in context 👍 0

All Replies (5)

Problem is most visible when you select some text, rightclick, and then select search in google. This can display white page which is not loading for 4 seconds!

தீர்வு தேர்ந்தெடுக்கப்பட்டது

Nice suggestion. I tried disabling all add-ons and found faulty one: https://addons.mozilla.org/pl/firefox/addon/youtube-ratings-preview/

It slows down firefox. Maybe it is google fault somehow because searching via google has something to do with youtube servers now and this addon slows this search down? Or mozilla changed something small in 72.0.2 and this add-on is no longer fully compatible?

However I still experience small lags when opening new websites - 1 second delay before page starts to load. Maybe it is different issue?

Piterk மூலமாக திருத்தப்பட்டது

Piterk said

I tried disabling all add-ons and found faulty one:

I suggest you contact its support.

However I still experience small lags when opening new websites - 1 second delay

If it's a website you have not been to before, the browser needs to get a lot of data before displaying it.

Nah it's not that. It also happens with already visited sites. IT did not happed before and it is not always present. Problem is hard to track so I will close this question for now.