X
Tap here to go to the mobile version of the site.

ஆதரவு மன்றம்

Video not autoplaying in Firefox but is in other browsers

  • 7 replies
  • 1 இந்த பிரச்சனை உள்ளது
  • Last reply by McCoy
பதிவிடப்பட்டது

My website (https://thegidgroup.com/) has a video on the homepage of a cell with a flag in. The video is set to auto play as the website loads. For some reason this works in every other browser and on every mobile I have tried exceot for Firefox. I have tried the usual things (uncheck hardware acceleration, Firefox up to date, extensions causing the issue and making sure autoplay is allowed) but nothing makes any difference. Does anone have any final ideas before I give up on Firefox as a bad job? I have attached screenshots of the website in Firefox and how it (should\does) look in Chrome. Thanks.

My website (https://thegidgroup.com/) has a video on the homepage of a cell with a flag in. The video is set to auto play as the website loads. For some reason this works in every other browser and on every mobile I have tried exceot for Firefox. I have tried the usual things (uncheck hardware acceleration, Firefox up to date, extensions causing the issue and making sure autoplay is allowed) but nothing makes any difference. Does anone have any final ideas before I give up on Firefox as a bad job? I have attached screenshots of the website in Firefox and how it (should\does) look in Chrome. Thanks.
Attached screenshots
மேற்கோள்

Additional System Details

நிறுவப்பட்ட நிரல்கள்

  • Shockwave Flash 32.0 r0

பயன்பாடு

  • User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:72.0) Gecko/20100101 Firefox/72.0

கூடுதல் தகவல்

RobertJ
  • Top 10 Contributor
144 தீர்வுகள் 1466 பதில்கள்
பதிவிடப்பட்டது

Hi littleangel_38,

Try starting Firefox in it's Safe Mode to see if the problem persists.

Safe Mode will temporarily prevent your extensions from starting, uses the default theme, turns off hardware acceleration, resets toolbar and button customizations and ignores other customizations. When you leave Safe Mode and start Firefox normally, your extensions, themes and settings will return to the state they were in before you entered Safe Mode.

With Firefox open: select Menu select Help select Restart With Add-ons Disabled on the dialog select Restart on the next dialog select Start In Safe Mode (Do Not select Refresh)

With Firefox closed: press and hold the Shift key launch Firefox on the dialog select Start In Safe Mode (Do Not select Refresh) ______________________________________________________

To quit Safe Mode: select Menu select Help select Restart With Add-ons Enabled

Or, Exit Firefox. ______________________________________________________

If the problem was not present in Safe Mode, it could be the work of one of your extensions, or it could be Hardware Acceleration. How to disable Hardware Acceleration.

Go to 3-bar Menu -> Add-ons (Or type about:addons in the address bar and press Enter) to open your Add-ons Manager. In the Add-ons Manager, on the left, select Extensions. Some toolbar and anti-virus extensions are known to cause Firefox issues. Disable All Of Them. Disable a few extensions, then restart Firefox.

If the problem continues, re-enable those and disable some more extensions and restart Firefox. Continue until the problem is gone. After, you know what group is causing the issue, re-enable the last group ONE AT A TIME, restarting Firefox each time until the problem returns.

Once you think you found the problem, disable that extension and make sure all the others are enabled, then restart again.

Hi littleangel_38, Try starting Firefox in it's [https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode#firefox:win10:fx72 Safe Mode] to see if the problem persists. Safe Mode will temporarily prevent your extensions from starting, uses the default theme, turns off hardware acceleration, resets toolbar and button customizations and ignores other customizations. When you leave Safe Mode and start Firefox normally, your extensions, themes and settings will return to the state they were in before you entered Safe Mode. With Firefox open: select Menu select Help select Restart With Add-ons Disabled on the dialog select Restart on the next dialog select Start In Safe Mode (Do Not select Refresh) With Firefox closed: press and hold the Shift key launch Firefox on the dialog select Start In Safe Mode (Do Not select Refresh) ______________________________________________________ To quit Safe Mode: select Menu select Help select Restart With Add-ons Enabled Or, Exit Firefox. ______________________________________________________ If the problem was not present in Safe Mode, it could be the work of one of your extensions, or it could be Hardware Acceleration. [https://support.mozilla.org/en-US/kb/forum-response-disable-hardware-acceleration How to disable Hardware Acceleration]. Go to 3-bar Menu -> Add-ons (Or type about:addons in the address bar and press Enter) to open your Add-ons Manager. In the Add-ons Manager, on the left, select Extensions. Some toolbar and anti-virus extensions are known to cause Firefox issues. Disable All Of Them. Disable a few extensions, then restart Firefox. If the problem continues, re-enable those and disable some more extensions and restart Firefox. Continue until the problem is gone. After, you know what group is causing the issue, re-enable the last group ONE AT A TIME, restarting Firefox each time until the problem returns. Once you think you found the problem, disable that extension and make sure all the others are enabled, then restart again.
இது உங்களுக்கு பயனுள்ளதாக இருந்ததா?
மேற்கோள்
McCoy
  • Top 10 Contributor
592 தீர்வுகள் 5677 பதில்கள்
பதிவிடப்பட்டது

FWIW : It doesn't work for me either (neither in Firefox nor in Edge).

What's weird : I get the text (shown in your screenshot) on the other site of the image, and no "Go" button.

'Done "everything in the book" to no avail; no error message in the browser console.

Even tried different URL's.

FWIW : It doesn't work for me either (neither in Firefox nor in Edge). What's weird : I get the text (shown in your screenshot) on the other site of the image, and no "Go" button. 'Done "everything in the book" to no avail; no error message in the browser console. Even tried different URL's.
இது உங்களுக்கு பயனுள்ளதாக இருந்ததா?
மேற்கோள்
cor-el
  • Top 10 Contributor
  • Moderator
17785 தீர்வுகள் 160874 பதில்கள்
பதிவிடப்பட்டது

The video works for me with Firefox 72.0.2. I get the block auto-play icon on the location bar and I get the video if I allow audio and video. Tracking Protection isn't blocking the video.

There are three sources available for playing the video if I check this in the Inspector.

The video works for me with Firefox 72.0.2. I get the block auto-play icon on the location bar and I get the video if I allow audio and video. Tracking Protection isn't blocking the video. There are three sources available for playing the video if I check this in the Inspector.
இது உங்களுக்கு பயனுள்ளதாக இருந்ததா?
மேற்கோள்
cor-el
  • Top 10 Contributor
  • Moderator
17785 தீர்வுகள் 160874 பதில்கள்
பதிவிடப்பட்டது

I see a different page that on your screenshot: different text and no Go button.

I see a different page that on your screenshot: different text and no Go button.

cor-el மூலமாக திருத்தப்பட்டது

இது உங்களுக்கு பயனுள்ளதாக இருந்ததா?
மேற்கோள்
McCoy
  • Top 10 Contributor
592 தீர்வுகள் 5677 பதில்கள்
பதிவிடப்பட்டது

cor-el said

I see a different page than on your screenshot: different text and no Go button.


McCoy said

What's weird : I get the text (shown in your screenshot) on the other site of the image, and no "Go" button.

I too have allowed audio and video, but there is no video in Firefox.

Just now I tried again in Edge : it's now displayed as shown in the OPs screenshot, including "Go" button, but clicking on it does not start the video.

''cor-el [[#answer-1283539|said]]'' <blockquote> I see a different page than on your screenshot: different text and no Go button. </blockquote> ''McCoy [[#answer-1283498|said]]'' <blockquote> What's weird : I get the text (shown in your screenshot) on the other site of the image, and no "Go" button. </blockquote> I too have allowed audio and video, but there is no video in Firefox. Just now I tried again in Edge : it's now displayed as shown in the OPs screenshot, including "Go" button, but clicking on it does not start the video.
இது உங்களுக்கு பயனுள்ளதாக இருந்ததா?
மேற்கோள்
McCoy
  • Top 10 Contributor
592 தீர்வுகள் 5677 பதில்கள்
பதிவிடப்பட்டது

Screenshot on the left : Firefox - screenshot on the right : Edge

Screenshot on the left : Firefox - screenshot on the right : Edge
இது உங்களுக்கு பயனுள்ளதாக இருந்ததா?
மேற்கோள்
McCoy
  • Top 10 Contributor
592 தீர்வுகள் 5677 பதில்கள்
பதிவிடப்பட்டது

littleangel_38 said

For some reason this works in every other browser and on every mobile I have tried except for Firefox.

It does not work in Edge (at least not for me): the page comes up and the "Go" button shows (partially), but when I click on it, the page changes and shows the exact same page as in Firefox (different text and no "Go" button).

''littleangel_38 [[#question-1277989|said]]'' <blockquote> For some reason this works in every other browser and on every mobile I have tried except for Firefox. </blockquote> It does not work in Edge (at least not for me): the page comes up and the "Go" button shows (partially), but when I click on it, the page changes and shows the exact same page as in Firefox (different text and no "Go" button).
இது உங்களுக்கு பயனுள்ளதாக இருந்ததா?
மேற்கோள்
கேள்வி எழுப்பு

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.