X
Tap here to go to the mobile version of the site.

ஆதரவு மன்றம்

Firefox won't block Pop-Ups from Blogger (with "Block pop-up windows" option selected)

  • 2 replies
  • 1 இந்த பிரச்சனை உள்ளது
  • Last reply by José
பதிவிடப்பட்டது

Hi, Firefox won't block Pop-Ups from Blogger (Google Blogs) even with "Block pop-up windows" option selected, and no exceptions list. Please advice to get all pop-ups to open in same window or another tab, but not in another separated floating window. Thank you very much for your help!

Hi, Firefox won't block Pop-Ups from Blogger (Google Blogs) even with "Block pop-up windows" option selected, and no exceptions list. Please advice to get all pop-ups to open in same window or another tab, but not in another separated floating window. Thank you very much for your help!
Attached screenshots

தீர்வு தேர்ந்தெடுக்கப்பட்டது

Hi José, there is a setting you can change (under "B" below).

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

(2) In the search box above the list, type or paste neww and pause while the list is filtered

(3) Review/Adjust the preferences as follows:

(A) browser.link.open_newwindow - for links in Firefox tabs

This is the one that has a checkbox on the Preferences page:

  • 3 = divert new window to a new tab (default)
  • 2 = allow link to open a new window
  • 1 = force new window into same tab

(B) browser.link.open_newwindow.restriction - for links in Firefox tabs

By default, if a page sets width, height, or toolbars for a popup, Firefox will let it be a separate window. To force those into a tab as well, you can change this preference to 0:

  • 0 = apply the setting under (A) to ALL new windows (even script windows with features) <= you might want to try this
  • 2 = apply the setting under (A) to normal windows, but NOT to script windows with features (default)
  • 1 = override the setting under (A) and always use new windows

(C) browser.link.open_newwindow.override.external - for links in other programs

  • -1 = apply the setting under (A) to external links (default)
  • 3 = open external links in a new tab in the last active window
  • 2 = open external links in a new window
  • 1 = open external links in the last active tab replacing the current page

To return to normal if things go haywire, right-click each "modified" preference and choose Reset.

I have a test page here: https://www.jeffersonscher.com/res/popit.html

Any improvement?

Read this answer in context 1
மேற்கோள்

Additional System Details

நிறுவப்பட்ட நிரல்கள்

  • Shockwave Flash 32.0 r0

பயன்பாடு

  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.13; rv:70.0) Gecko/20100101 Firefox/70.0

கூடுதல் தகவல்

jscher2000
  • Top 10 Contributor
8793 தீர்வுகள் 71930 பதில்கள்
பதிவிடப்பட்டது

தீர்வு தேர்ந்தெடுக்கப்பட்டது

Hi José, there is a setting you can change (under "B" below).

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

(2) In the search box above the list, type or paste neww and pause while the list is filtered

(3) Review/Adjust the preferences as follows:

(A) browser.link.open_newwindow - for links in Firefox tabs

This is the one that has a checkbox on the Preferences page:

  • 3 = divert new window to a new tab (default)
  • 2 = allow link to open a new window
  • 1 = force new window into same tab

(B) browser.link.open_newwindow.restriction - for links in Firefox tabs

By default, if a page sets width, height, or toolbars for a popup, Firefox will let it be a separate window. To force those into a tab as well, you can change this preference to 0:

  • 0 = apply the setting under (A) to ALL new windows (even script windows with features) <= you might want to try this
  • 2 = apply the setting under (A) to normal windows, but NOT to script windows with features (default)
  • 1 = override the setting under (A) and always use new windows

(C) browser.link.open_newwindow.override.external - for links in other programs

  • -1 = apply the setting under (A) to external links (default)
  • 3 = open external links in a new tab in the last active window
  • 2 = open external links in a new window
  • 1 = open external links in the last active tab replacing the current page

To return to normal if things go haywire, right-click each "modified" preference and choose Reset.

I have a test page here: https://www.jeffersonscher.com/res/popit.html

Any improvement?

Hi José, there is a setting you can change (under "B" below). (1) In a new tab, type or paste '''about:config''' in the address bar and press Enter/Return. Click the button accepting the risk. (2) In the search box above the list, type or paste '''neww''' and pause while the list is filtered (3) Review/Adjust the preferences as follows: (A) '''browser.link.open_newwindow''' - ''for links in Firefox tabs'' This is the one that has a checkbox on the Preferences page: * '''3 = divert new window to a new tab (default)''' * 2 = allow link to open a new window * 1 = force new window into same tab (B) '''browser.link.open_newwindow.restriction''' - ''for links in Firefox tabs'' By default, if a page sets width, height, or toolbars for a popup, Firefox will let it be a separate window. To force those into a tab as well, you can change this preference to 0: * 0 = '''apply the setting under (A) to ALL new windows (even script windows with features) ''<= you might want to try this''''' * 2 = apply the setting under (A) to normal windows, but NOT to script windows with features (default) * 1 = override the setting under (A) and always use new windows (C) '''browser.link.open_newwindow.override.external''' - ''for links in other programs'' * -1 = apply the setting under (A) to external links (default) * 3 = open external links in a new tab in the last active window * 2 = open external links in a new window * 1 = open external links in the last active tab replacing the current page To return to normal if things go haywire, right-click each "modified" preference and choose Reset. I have a test page here: https://www.jeffersonscher.com/res/popit.html Any improvement?
இது உங்களுக்கு பயனுள்ளதாக இருந்ததா? 1
மேற்கோள்
பதிவிடப்பட்டது

கேள்வியின் உரிமையாளர்

Perfect!

browser.link.open_newwindow.restriction was set to 2....I changed it to "0" as per your guide, and it worked!

Thank you very much, jscher2000!

In addition, this is an excellent guide if I want to make other changes in the future: bookmarked and read-listed.

Cheers!

Perfect! '''browser.link.open_newwindow.restriction''' was set to 2....I changed it to "0" as per your guide, and it worked! Thank you very much, jscher2000! In addition, this is an excellent guide if I want to make other changes in the future: bookmarked and read-listed. Cheers!
இது உங்களுக்கு பயனுள்ளதாக இருந்ததா? 0
மேற்கோள்
கேள்வி எழுப்பு

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.