X
Tap here to go to the mobile version of the site.

ஆதரவு மன்றம்

How to stop Firefox from flashing white screen while page is loading?

  • 3 replies
  • 1 இந்த பிரச்சனை உள்ளது
  • Last reply by john76
பதிவிடப்பட்டது

Hi, I use the dark reader add on which saves my eyes from the burning white pages of the internet. Unfortunately, firefox flashes white before loading new pages. How can this be stopped?

To reproduce, enable the dark reader add on. Go to duckduckgo in a new tab, do a search for anything and you'll see the screen flash white before loading results.

I was using this solution which was working perfectly, but it doesn't work anymore (after a recent refresh of firefox):

userChrome.css


@-moz-document url(chrome://browser/content/browser.xul) {

  #main-window,
  browser[type="content-primary"],
  browser[type="content"],
  tabbrowser#content,
  #content,
  browser[type="content"] > html
  {
     background: #323234 !important;
  }

}


userContent.css


@charset "utf-8"; /* CSS Document */

@-moz-document url("about:newtab") { body { background-color: #011326 !important;} }

@-moz-document url(chrome://browser/content/browser.xul) { browser[type="content-primary"] {background: #011326 !important} }


Any ideas?

Hi, I use the dark reader add on which saves my eyes from the burning white pages of the internet. Unfortunately, firefox flashes white before loading new pages. How can this be stopped? To reproduce, enable the dark reader add on. Go to duckduckgo in a new tab, do a search for anything and you'll see the screen flash white before loading results. I was using this solution which was working perfectly, but it doesn't work anymore (after a recent refresh of firefox): userChrome.css -------------------------------------- @-moz-document url(chrome://browser/content/browser.xul) { #main-window, browser[type="content-primary"], browser[type="content"], tabbrowser#content, #content, browser[type="content"] > html { background: #323234 !important; } } userContent.css -------------------------------------- @charset "utf-8"; /* CSS Document */ @-moz-document url("about:newtab") { body { background-color: #011326 !important;} } @-moz-document url(chrome://browser/content/browser.xul) { browser[type="content-primary"] {background: #011326 !important} } Any ideas?

தீர்வு தேர்ந்தெடுக்கப்பட்டது

You also need to change browser.xul to browser.xhtml in Firefox 69 and later.

@-moz-document url(chrome://browser/content/browser.xul) {} => @-moz-document url(chrome://browser/content/browser.xhtml) {}

Read this answer in context 1
மேற்கோள்

Additional System Details

பயன்பாடு

  • User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:69.0) Gecko/20100101 Firefox/69.0

கூடுதல் தகவல்

cor-el
  • Top 10 Contributor
  • Moderator
17466 தீர்வுகள் 157836 பதில்கள்
பதிவிடப்பட்டது

In Firefox 69 and later you need to set this pref to true on the about:config page to enable userChrome.css and userContent.css.

  • toolkit.legacyUserProfileCustomizations.stylesheets = true

This pref is false by default in Firefox 69 and later, but is created with a true value true in Firefox 68 when it detects the chrome folder with either of these two files to make the transfer to Firefox 69 easier. If you create a new profile in Firefox 69 and later then you need to toggle the pref manually yourself to make userChrome.css and userContent.css work again.

You can open the about:config page via the location/address bar. You can accept the warning and click "I accept the risk!" to continue.

In Firefox 69 and later you need to set this pref to true on the about:config page to enable userChrome.css and userContent.css. *toolkit.legacyUserProfileCustomizations.stylesheets = true This pref is false by default in Firefox 69 and later, but is created with a true value true in Firefox 68 when it detects the chrome folder with either of these two files to make the transfer to Firefox 69 easier. If you create a new profile in Firefox 69 and later then you need to toggle the pref manually yourself to make userChrome.css and userContent.css work again. You can open the <b>about:config</b> page via the location/address bar. You can accept the warning and click "I accept the risk!" to continue. *https://support.mozilla.org/en-US/kb/about-config-editor-firefox
இது உங்களுக்கு பயனுள்ளதாக இருந்ததா?
மேற்கோள்
cor-el
  • Top 10 Contributor
  • Moderator
17466 தீர்வுகள் 157836 பதில்கள்
பதிவிடப்பட்டது

தீர்வு தேர்ந்தெடுக்கப்பட்டது

You also need to change browser.xul to browser.xhtml in Firefox 69 and later.

@-moz-document url(chrome://browser/content/browser.xul) {} => @-moz-document url(chrome://browser/content/browser.xhtml) {}

You also need to change browser.xul to browser.xhtml in Firefox 69 and later. @-moz-document url(chrome://browser/content/browser.xul) {} => @-moz-document url(chrome://browser/content/browser.xhtml) {}
இது உங்களுக்கு பயனுள்ளதாக இருந்ததா? 1
மேற்கோள்
பதிவிடப்பட்டது

கேள்வியின் உரிமையாளர்

Thanks cor-el! That did it! My eyes are at peace again :)

Thanks cor-el! That did it! My eyes are at peace again :)
இது உங்களுக்கு பயனுள்ளதாக இருந்ததா?
மேற்கோள்
கேள்வி எழுப்பு

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.