X
Tap here to go to the mobile version of the site.

ஆதரவு மன்றம்

Firefox freezes every few seconds. I've tried refreshing/reinstalling firefox, running in safe mode, disabling hardware accelartion and unchecking accessability

  • 8 replies
  • 1 இந்த பிரச்சனை உள்ளது
  • Last reply by Luis Pais
பதிவிடப்பட்டது

Nothing works, firefox just hangs every few seconds, I even disabled session restore, set browser.sessionstore.max_tabs_undo and browser.sessionstore.max_window_undo to 0. It keeps freezing every few seconds.

I'm running firefox on linux.

Nothing works, firefox just hangs every few seconds, I even disabled session restore, set browser.sessionstore.max_tabs_undo and browser.sessionstore.max_window_undo to 0. It keeps freezing every few seconds. I'm running firefox on linux.

தீர்வு தேர்ந்தெடுக்கப்பட்டது

My problem has been fixed!

My system is running on Arch and I just followed Arch's recommendation to fix this: https://wiki.archlinux.org/index.php/.../Unresponsiveness_in_Chromium_and_Firefox. However, I didn't need to disable vsync.

Thank you everyone !

Read this answer in context 0
மேற்கோள்

Additional System Details

நிறுவப்பட்ட நிரல்கள்

None

பயன்பாடு

  • User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:69.0) Gecko/20100101 Firefox/69.0

கூடுதல் தகவல்

jscher2000
  • Top 10 Contributor
8695 தீர்வுகள் 71066 பதில்கள்
பதிவிடப்பட்டது

Hi Luis, I don't know much about Linux.

Are you using the build from your distro's repository or directly from Mozilla's site?

Do you have a system-level performance monitoring widget that would show whether Firefox is maxing out CPU or disk, or is making heavy network usage?

Note: Disabling session restore would help reduce disk access, but since the file is only updated every 15 seconds at the most, that isn't frequent enough to account for this problem. Also, you can extend that time by modifying browser.sessionstore.interval with a new value in about:config (60000 milliseconds for 60 seconds, for example).

Hi Luis, I don't know much about Linux. Are you using the build from your distro's repository or directly from Mozilla's site? Do you have a system-level performance monitoring widget that would show whether Firefox is maxing out CPU or disk, or is making heavy network usage? Note: Disabling session restore would help reduce disk access, but since the file is only updated every 15 seconds at the most, that isn't frequent enough to account for this problem. Also, you can extend that time by modifying ''browser.sessionstore.interval'' with a new value in about:config (60000 milliseconds for 60 seconds, for example).
இது உங்களுக்கு பயனுள்ளதாக இருந்ததா?
மேற்கோள்
jscher2000
  • Top 10 Contributor
8695 தீர்வுகள் 71066 பதில்கள்
பதிவிடப்பட்டது

By the way, if you can use built-in pages, check out the possible automatic connections in this article: How to stop Firefox from making automatic connections.

By the way, if you can use built-in pages, check out the possible automatic connections in this article: [[How to stop Firefox from making automatic connections]].
இது உங்களுக்கு பயனுள்ளதாக இருந்ததா?
மேற்கோள்
cor-el
  • Top 10 Contributor
  • Moderator
17474 தீர்வுகள் 157940 பதில்கள்
பதிவிடப்பட்டது

You can create a new profile to test if your current profile is causing the problem.

See "Creating a profile":

If the new profile works then you can transfer files from a previously used profile to the new profile, but be cautious not to copy corrupted files to avoid carrying over problems.

You can create a new profile to test if your current profile is causing the problem. See "Creating a profile": *https://support.mozilla.org/en-US/kb/profile-manager-create-and-remove-firefox-profiles *http://kb.mozillazine.org/Standard_diagnostic_-_Firefox#Profile_issues If the new profile works then you can transfer files from a previously used profile to the new profile, but be cautious not to copy corrupted files to avoid carrying over problems. *https://support.mozilla.org/en-US/kb/recovering-important-data-from-an-old-profile
இது உங்களுக்கு பயனுள்ளதாக இருந்ததா?
மேற்கோள்
பதிவிடப்பட்டது

கேள்வியின் உரிமையாளர்

cor-el said

You can create a new profile to test if your current profile is causing the problem.

I forgot to add that to my question. I already tried that but Firefox keeps freezing in the new account.

''cor-el [[#answer-1254197|said]]'' <blockquote> You can create a new profile to test if your current profile is causing the problem. </blockquote> I forgot to add that to my question. I already tried that but Firefox keeps freezing in the new account.
இது உங்களுக்கு பயனுள்ளதாக இருந்ததா?
மேற்கோள்
பதிவிடப்பட்டது

கேள்வியின் உரிமையாளர்

jscher2000 said

Hi Luis, I don't know much about Linux. Are you using the build from your distro's repository or directly from Mozilla's site?

Thank you for replying, I'm using my distros build.

jscher2000 said

Do you have a system-level performance monitoring widget that would show whether Firefox is maxing out CPU or disk, or is making heavy network usage?

I do, I'll report to you soon.

jscher2000 said'

'
Note: Disabling session restore would help reduce disk access, but since the file is only updated every 15 seconds at the most, that isn't frequent enough to account for this problem. Also, you can extend that time by modifying browser.sessionstore.interval with a new value in about:config (60000 milliseconds for 60 seconds, for example).

I'm also going to try that to see if the interval between freezes increases.

Thank you.

''jscher2000 [[#answer-1254167|said]]'' <blockquote> Hi Luis, I don't know much about Linux. Are you using the build from your distro's repository or directly from Mozilla's site? </blockquote> Thank you for replying, I'm using my distros build. ''jscher2000 [[#answer-1254167|said]]'' <blockquote> Do you have a system-level performance monitoring widget that would show whether Firefox is maxing out CPU or disk, or is making heavy network usage? </blockquote> I do, I'll report to you soon. ''jscher2000 [[#answer-1254167|said]]' '<blockquote> Note: Disabling session restore would help reduce disk access, but since the file is only updated every 15 seconds at the most, that isn't frequent enough to account for this problem. Also, you can extend that time by modifying ''browser.sessionstore.interval'' with a new value in about:config (60000 milliseconds for 60 seconds, for example). </blockquote> I'm also going to try that to see if the interval between freezes increases. Thank you.

Luis Pais மூலமாக திருத்தப்பட்டது

இது உங்களுக்கு பயனுள்ளதாக இருந்ததா?
மேற்கோள்
பதிவிடப்பட்டது

கேள்வியின் உரிமையாளர்

jscher2000 said

By the way, if you can use built-in pages, check out the possible automatic connections in this article: How to stop Firefox from making automatic connections.

By built in pages, do you mean Firefox's empty homepage ? If so, no, those kind of pages also freeze.

''jscher2000 [[#answer-1254168|said]]'' <blockquote> By the way, if you can use built-in pages, check out the possible automatic connections in this article: [[How to stop Firefox from making automatic connections]]. </blockquote> By built in pages, do you mean Firefox's empty homepage ? If so, no, those kind of pages also freeze.
இது உங்களுக்கு பயனுள்ளதாக இருந்ததா?
மேற்கோள்
பதிவிடப்பட்டது

கேள்வியின் உரிமையாளர்

I'm sorry it took me so long to reply, this week has been quite heavy on me. Anyways:

jscher2000 said

Do you have a system-level performance monitoring widget that would show whether Firefox is maxing out CPU or disk, or is making heavy network usage?

I just checked and firefox is not reporting any heavy network/CPU/disk usage.

jscher2000 said

Note: Disabling session restore would help reduce disk access, but since the file is only updated every 15 seconds at the most, that isn't frequent enough to account for this problem. Also, you can extend that time by modifying browser.sessionstore.interval with a new value in about:config (60000 milliseconds for 60 seconds, for example).

I changed the value to 60000 and there was no notable differences with the freezes.


But something unexpectedly weird happened, when I have my system monitor open, firefox doesn't freeze anymore. I think it has to do with my bios setting messing up my CPU. I'm going to explore this further.

I'm sorry it took me so long to reply, this week has been quite heavy on me. Anyways: ''jscher2000 [[#answer-1254167|said]]'' <blockquote> Do you have a system-level performance monitoring widget that would show whether Firefox is maxing out CPU or disk, or is making heavy network usage? </blockquote> I just checked and firefox is not reporting any heavy network/CPU/disk usage. ''jscher2000 [[#answer-1254167|said]]'' <blockquote> Note: Disabling session restore would help reduce disk access, but since the file is only updated every 15 seconds at the most, that isn't frequent enough to account for this problem. Also, you can extend that time by modifying ''browser.sessionstore.interval'' with a new value in about:config (60000 milliseconds for 60 seconds, for example). </blockquote> I changed the value to 60000 and there was no notable differences with the freezes. But something unexpectedly weird happened, when I have my system monitor open, firefox doesn't freeze anymore. I think it has to do with my bios setting messing up my CPU. I'm going to explore this further.
இது உங்களுக்கு பயனுள்ளதாக இருந்ததா?
மேற்கோள்
பதிவிடப்பட்டது

தீர்வு தேர்ந்தெடுக்கப்பட்டது

My problem has been fixed!

My system is running on Arch and I just followed Arch's recommendation to fix this: https://wiki.archlinux.org/index.php/.../Unresponsiveness_in_Chromium_and_Firefox. However, I didn't need to disable vsync.

Thank you everyone !

My problem has been fixed! My system is running on Arch and I just followed Arch's recommendation to fix this: [https://wiki.archlinux.org/index.php/Intel_graphics#Corruption/Unresponsiveness_in_Chromium_and_Firefox]. However, I didn't need to disable vsync. Thank you everyone !

Luis Pais மூலமாக திருத்தப்பட்டது

இது உங்களுக்கு பயனுள்ளதாக இருந்ததா?
மேற்கோள்
கேள்வி எழுப்பு

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.