Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Newest version of Adobe Flash does not work with Firefox

  • 72 பதிலளிப்புகள்
  • 1 இந்த பிரச்சனை உள்ளது
  • Last reply by Kymber

Last week Adobe Flash stopped actuating/working with Firefox and there is no black box in the address bar or any place else that I see that asks me to activate it. I have it set as Always Activate on the Plug-Ins page but that isn't helping. I checked and have the most recent version. I had to go through several steps to activate it but it does work in Chrome. I run Win 7 and Firefox is my default browser. Please advise how I can get Flash to work again as it is hampering a lot of my activity on the web. Thank you.

All Replies (20)

The dialog box had gone away on my screen as well until I reinstalled the plug-in. If you haven't already tried that, maybe you'll have the same partial luck as I did.

So I should delete Flash and download it again? I updated it the other day to no avail.

I just got an email from Zone Master :

" We have been looking into this but so far don’t have any new info to share.

Firefox has made an update that seems to make it impossible to play Flash games even if you have Flash set to “Always Ask”

Still looking into it,

--adam "

Doing what Kymber did might be worth a try ......

McCoy மூலமாக திருத்தப்பட்டது

tek360 said

So I should delete Flash and download it again? I updated it the other day to no avail.

Adobe Flash is notorious for not always removing old Flash Plugin DLL files as part of a Flash program update. Sometimes the user needs to uninstall Flash completely and get a clean start.

First, grab the Adobe uninstaller from here:

2nd, get Flash here: Make sure that you deselect the "Optional offers".

Run the Flash uninstaller program, then reboot your PC. Then install the Plugin version of Flash. You'll then have a clean installation of Flash for Firefox.

tek360 said

So I should delete Flash and download it again? I updated it the other day to no avail.

Maybe take another look at this article I linked to in my first post :

Here's part of the email I just sent to Zone Master, in reply to their email :

"On Edge your site asks to enable Flash - on Firefox you don't ask to enable Flash .....

As Flash is installed on the user's system; this can't be a Firefox issue - the site should ask to enable Flash."

I'm adding a screenshot to prove that the games you gave links to, do load for me (and I played them) in Firefox, even though the site did not ask me to activate Flash - when I try in Edge, I am asked to activate Flash.
Weird .....

This game (you also gave a link to) loads, but does not play :

But the site says :

"Note: Mozilla Firefox does not support all games on the site "

This seems to be one of them, and I really don't know why  :(

McCoy மூலமாக திருத்தப்பட்டது

FYI I believe Adam as I was able to play on Chrome last night but I had to click the "i" in the address bar to activate Flash. I will remove and download a clean edition of Flash to see if that works.

FYI I don't play Jewelquest, I play Bejeweled. It seems they are both in the same box but one you click on the left and the other you click on the right. I like the simpler games without the intricate graphics; I'm old school, what can I say. If I could still find a place to play the original Tetris or Uno I would as that was always a favorite. I like solo play puzzles, card and word games.

tek360 said

FYI I don't play Jewelquest, I play Bejeweled.

In used the links you provided .....

But you do play Mahjong, though, don't you  ? (see my screenshot).

Not that version. I play Mah Jong Tiles and Mahjongg Alchemy on Chrome because it won't display on FF. Add to that that I can't use the MTA trip planner either. I thought it was a fluke last week but it still won't work. This is another site that requires Flash and it works in Chrome.

tek360 மூலமாக திருத்தப்பட்டது

tek360 said

The site loads just fine for me (not asked to enable/allow Fash) - see screenshot :

tek360 said

Not that version.

I used the link that you gave us though .....

Yes but if you look there is a square to play on the left and one to play the newer game on the right. The one on the left says Play Free Online. The one which you note says Play Now. It also says if you love Mahjong Tiles you'll love Microsoft Mahjong!

Didn't see your message below for Trip Planner. Yup, the site loads but I can't do any searches. It doesn't even spin. It just sits there like I haven't clicked the button. Remember, I have Win7 and you have Win10. And, at no time do any sites ask me to enable Flash. I don't seem to even have the option to do this despite how my preference is set.

tek360 மூலமாக திருத்தப்பட்டது

tek360 said

And, at no time do any sites ask me to enable Flash.

Like I've been saying : I don't get asked to enable/allow Flash either ....

I don't think that the fact that you're on Windows 7 and I'm on Windows 10, has anything to do with it.

I sure hope that someone else will be able to come to your rescue, cause I really don't know what's going on here (so sorry).

OK. I found a Flash game

Play Classic wants to load a Flash game in an iframe that stays blank because FLash isn't enabled.

If I right-click in the frame and use:

Then I get a window that allows to enable the Flash plugin.

Once Flash is enabled then the game runs normally on the page.

cor-el மூலமாக திருத்தப்பட்டது

Fine for you but these are not the same as the games I want to play and have been playing for years until last week. Old habits die hard.

I do not get a request to enable flash. Where you see a black screen I see a big, white blank.

This game is the same as I wrote above.

Right-click in the blank area: This Frame -> Show Only this Frame Allow the Flash plugin and then the game should load. You can back back to the original page (Alt + Left) and the game should load there as well.

cor-el மூலமாக திருத்தப்பட்டது

  1. 1
  2. 2
  3. 3
  4. 4