X
Tap here to go to the mobile version of the site.

ஆதரவு மன்றம்

network.http.spdy.enabled always reset to false

  • 12 replies
  • 1 இந்த பிரச்சனை உள்ளது
  • Last reply by alex_mayorga
பதிவிடப்பட்டது

Hello, I have Firefox 68.0.2 installed on W7. I discovered that since recently network.http.spdy.enabled always reset to false ... tried to solve by following different solutions described on mozilla website ... tried to solve by reinstalling completely firefox software ... tried to solve by deleting completely the Mozilla User Roaming profile ... C:\Users\XXX\AppData\Roaming\Mozilla\Firefox\Profiles\ ... ... but nothing change/fix ... network.http.spdy.enabled is always to false and network.http.spdy.enabled.http2 is always to true with the consequence that google, cloudflare, ... websites are no longer working with http/2. Is that a known issue ? Thank You in advance for your help Best Regards, Vincent

Hello, I have Firefox 68.0.2 installed on W7. I discovered that since recently network.http.spdy.enabled always reset to false ... tried to solve by following different solutions described on mozilla website ... tried to solve by reinstalling completely firefox software ... tried to solve by deleting completely the Mozilla User Roaming profile ... C:\Users\XXX\AppData\Roaming\Mozilla\Firefox\Profiles\ ... ... but nothing change/fix ... network.http.spdy.enabled is always to false and network.http.spdy.enabled.http2 is always to true with the consequence that google, cloudflare, ... websites are no longer working with http/2. Is that a known issue ? Thank You in advance for your help Best Regards, Vincent
மேற்கோள்

Additional System Details

நிறுவப்பட்ட நிரல்கள்

  • Shockwave Flash 32.0 r0

பயன்பாடு

  • User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:68.0) Gecko/20100101 Firefox/68.0

கூடுதல் தகவல்

cor-el
  • Top 10 Contributor
  • Moderator
17521 தீர்வுகள் 158427 பதில்கள்
பதிவிடப்பட்டது

You can check the about:policies#active page to see whether policies are active.

What security software do you have?

Boot the computer in Windows Safe mode with network support to see if that has effect in case security software is causing problems.

You can check the <b>about:policies#active</b> page to see whether policies are active. *https://support.mozilla.org/en-US/kb/customizing-firefox-using-group-policy What security software do you have? Boot the computer in Windows Safe mode with network support to see if that has effect in case security software is causing problems. *https://www.bleepingcomputer.com/tutorials/how-to-start-windows-in-safe-mode/ *https://www.7tutorials.com/4-ways-boot-safe-mode-windows-10
இது உங்களுக்கு பயனுள்ளதாக இருந்ததா?
மேற்கோள்
பதிவிடப்பட்டது

கேள்வியின் உரிமையாளர்

This is always giving the same issue. When starting Firefox network.http.spdy.enabled is always set to false. I can reset the value to true and http/2 is working but this is just for the time Firefox keeps open. Closing/Reopening Firefox sets the value to false again :-(

This is always giving the same issue. When starting Firefox network.http.spdy.enabled is always set to false. I can reset the value to true and http/2 is working but this is just for the time Firefox keeps open. Closing/Reopening Firefox sets the value to false again :-(
இது உங்களுக்கு பயனுள்ளதாக இருந்ததா?
மேற்கோள்
FredMcD
  • Top 10 Contributor
4254 தீர்வுகள் 59582 பதில்கள்
பதிவிடப்பட்டது

Did you try cor-el's suggestion?

https://support.mozilla.org/en-US/kb/how-to-fix-preferences-wont-save

Note: Some software, like Advanced SystemCare with Surfing Protection, can protect files in the Firefox profile folder against changes. If you have such software then check the settings or uninstall this software.

Did you try '''cor-el's''' suggestion? https://support.mozilla.org/en-US/kb/how-to-fix-preferences-wont-save '''Note:''' Some software, '''like''' Advanced SystemCare with Surfing Protection, can protect files in the Firefox profile folder against changes. If you have such software then check the settings or uninstall this software.
இது உங்களுக்கு பயனுள்ளதாக இருந்ததா?
மேற்கோள்
பதிவிடப்பட்டது

கேள்வியின் உரிமையாளர்

I dont't have the feeling such software is installed on my laptop. Concerning the provided url link given, this is indeed where I did start. Finally I found the entry user_pref("network.http.spdy.enabled", false); under file C:\Data\Firefox\browser\defaults\profile\user.js. I don't know where this is coming from but even deleting this entry followed by restarting FF do not solve the issue ... even though the parameter is now fully removed from user.js.

Strange, very strange :-(

I dont't have the feeling such software is installed on my laptop. Concerning the provided url link given, this is indeed where I did start. Finally I found the entry user_pref("network.http.spdy.enabled", false); under file C:\Data\Firefox\browser\defaults\profile\user.js. I don't know where this is coming from but even deleting this entry followed by restarting FF do not solve the issue ... even though the parameter is now fully removed from user.js. Strange, very strange :-(

Vincent Blondel மூலமாக திருத்தப்பட்டது

இது உங்களுக்கு பயனுள்ளதாக இருந்ததா?
மேற்கோள்
cor-el
  • Top 10 Contributor
  • Moderator
17521 தீர்வுகள் 158427 பதில்கள்
பதிவிடப்பட்டது

What else is in the user.js file?

The user.js file will only be present if you or other software has created this file and normally won't be present.

You can check its content with a text editor (right-click: "Open with"; do not double-click). The user.js file is read each time Firefox is started and initializes preferences to the value specified in this file, so preferences set via user.js can only be changed temporarily for the current session.

You can delete the user.js file if you didn't create this file yourself.

What else is in the user.js file? The user.js file will only be present if you or other software has created this file and normally won't be present. You can check its content with a text editor (right-click: "Open with"; do not double-click). The user.js file is read each time Firefox is started and initializes preferences to the value specified in this file, so preferences set via user.js can only be changed temporarily for the current session. You can delete the user.js file if you didn't create this file yourself.
இது உங்களுக்கு பயனுள்ளதாக இருந்ததா?
மேற்கோள்
பதிவிடப்பட்டது

கேள்வியின் உரிமையாளர்

I found something strange. I found that two user profiles are stored in C:\Users\xxx\AppData\Roaming\Mozilla\Firefox\Profiles\ and C:\Users\xxx\AppData\Local\Mozilla\Firefox\Profiles\ as well. Yesterday, again I removed all of them ... Roaming and Local. Recreating my profile, I discovered .. before .. and .. after the profile cleaning that one file is filled in with such content ...

user_pref("network.http.spdy.enabled", false); user_pref("browser.tabs.remote.autostart", false); user_pref("browser.tabs.remote.autostart.2", false); user_pref("network.http.spdy.enabled", false); user_pref("browser.tabs.remote.autostart", false); user_pref("browser.tabs.remote.autostart.2", false); user_pref("network.http.spdy.enabled", false); user_pref("browser.tabs.remote.autostart", false); user_pref("browser.tabs.remote.autostart.2", false); user_pref("network.http.spdy.enabled", false); user_pref("browser.tabs.remote.autostart", false); user_pref("browser.tabs.remote.autostart.2", false); user_pref("network.http.spdy.enabled", false); user_pref("browser.tabs.remote.autostart", false); user_pref("browser.tabs.remote.autostart.2", false); user_pref("network.http.spdy.enabled", false); user_pref("browser.tabs.remote.autostart", false); user_pref("browser.tabs.remote.autostart.2", false); user_pref("network.http.spdy.enabled", false); user_pref("browser.tabs.remote.autostart", false); user_pref("browser.tabs.remote.autostart.2", false); user_pref("network.http.spdy.enabled", false); user_pref("browser.tabs.remote.autostart", false); user_pref("browser.tabs.remote.autostart.2", false); user_pref("network.http.spdy.enabled", false); user_pref("browser.tabs.remote.autostart", false); user_pref("browser.tabs.remote.autostart.2", false); user_pref("network.http.spdy.enabled", false); user_pref("browser.tabs.remote.autostart", false); user_pref("browser.tabs.remote.autostart.2", false); user_pref("network.http.spdy.enabled", false); user_pref("browser.tabs.remote.autostart", false); user_pref("browser.tabs.remote.autostart.2", false); user_pref("network.http.spdy.enabled", false); user_pref("browser.tabs.remote.autostart", false); user_pref("browser.tabs.remote.autostart.2", false); user_pref("network.http.spdy.enabled", false); user_pref("browser.tabs.remote.autostart", false); user_pref("browser.tabs.remote.autostart.2", false); user_pref("network.http.spdy.enabled", false); user_pref("browser.tabs.remote.autostart", false); user_pref("browser.tabs.remote.autostart.2", false); user_pref("network.http.spdy.enabled", false); user_pref("browser.tabs.remote.autostart", false); user_pref("browser.tabs.remote.autostart.2", false); user_pref("network.http.spdy.enabled", false); user_pref("browser.tabs.remote.autostart", false); user_pref("browser.tabs.remote.autostart.2", false); user_pref("network.http.spdy.enabled", false); user_pref("browser.tabs.remote.autostart", false); user_pref("browser.tabs.remote.autostart.2", false); user_pref("network.http.spdy.enabled", false); user_pref("browser.tabs.remote.autostart", false); user_pref("browser.tabs.remote.autostart.2", false); user_pref("network.http.spdy.enabled", false); user_pref("browser.tabs.remote.autostart", false); user_pref("browser.tabs.remote.autostart.2", false);

does that ring a bell ?

I found something strange. I found that two user profiles are stored in C:\Users\xxx\AppData\Roaming\Mozilla\Firefox\Profiles\ and C:\Users\xxx\AppData\Local\Mozilla\Firefox\Profiles\ as well. Yesterday, again I removed all of them ... Roaming and Local. Recreating my profile, I discovered .. before .. and .. after the profile cleaning that one file is filled in with such content ... user_pref("network.http.spdy.enabled", false); user_pref("browser.tabs.remote.autostart", false); user_pref("browser.tabs.remote.autostart.2", false); user_pref("network.http.spdy.enabled", false); user_pref("browser.tabs.remote.autostart", false); user_pref("browser.tabs.remote.autostart.2", false); user_pref("network.http.spdy.enabled", false); user_pref("browser.tabs.remote.autostart", false); user_pref("browser.tabs.remote.autostart.2", false); user_pref("network.http.spdy.enabled", false); user_pref("browser.tabs.remote.autostart", false); user_pref("browser.tabs.remote.autostart.2", false); user_pref("network.http.spdy.enabled", false); user_pref("browser.tabs.remote.autostart", false); user_pref("browser.tabs.remote.autostart.2", false); user_pref("network.http.spdy.enabled", false); user_pref("browser.tabs.remote.autostart", false); user_pref("browser.tabs.remote.autostart.2", false); user_pref("network.http.spdy.enabled", false); user_pref("browser.tabs.remote.autostart", false); user_pref("browser.tabs.remote.autostart.2", false); user_pref("network.http.spdy.enabled", false); user_pref("browser.tabs.remote.autostart", false); user_pref("browser.tabs.remote.autostart.2", false); user_pref("network.http.spdy.enabled", false); user_pref("browser.tabs.remote.autostart", false); user_pref("browser.tabs.remote.autostart.2", false); user_pref("network.http.spdy.enabled", false); user_pref("browser.tabs.remote.autostart", false); user_pref("browser.tabs.remote.autostart.2", false); user_pref("network.http.spdy.enabled", false); user_pref("browser.tabs.remote.autostart", false); user_pref("browser.tabs.remote.autostart.2", false); user_pref("network.http.spdy.enabled", false); user_pref("browser.tabs.remote.autostart", false); user_pref("browser.tabs.remote.autostart.2", false); user_pref("network.http.spdy.enabled", false); user_pref("browser.tabs.remote.autostart", false); user_pref("browser.tabs.remote.autostart.2", false); user_pref("network.http.spdy.enabled", false); user_pref("browser.tabs.remote.autostart", false); user_pref("browser.tabs.remote.autostart.2", false); user_pref("network.http.spdy.enabled", false); user_pref("browser.tabs.remote.autostart", false); user_pref("browser.tabs.remote.autostart.2", false); user_pref("network.http.spdy.enabled", false); user_pref("browser.tabs.remote.autostart", false); user_pref("browser.tabs.remote.autostart.2", false); user_pref("network.http.spdy.enabled", false); user_pref("browser.tabs.remote.autostart", false); user_pref("browser.tabs.remote.autostart.2", false); user_pref("network.http.spdy.enabled", false); user_pref("browser.tabs.remote.autostart", false); user_pref("browser.tabs.remote.autostart.2", false); user_pref("network.http.spdy.enabled", false); user_pref("browser.tabs.remote.autostart", false); user_pref("browser.tabs.remote.autostart.2", false); does that ring a bell ?
இது உங்களுக்கு பயனுள்ளதாக இருந்ததா?
மேற்கோள்
பதிவிடப்பட்டது

கேள்வியின் உரிமையாளர்

any update ?? Thank You in advance Vincent

any update ?? Thank You in advance Vincent
இது உங்களுக்கு பயனுள்ளதாக இருந்ததா?
மேற்கோள்
cor-el
  • Top 10 Contributor
  • Moderator
17521 தீர்வுகள் 158427 பதில்கள்
பதிவிடப்பட்டது

You can try to clear the user.js file and set it to read-only.

It sounds that other software regularly adds these same lines to the user.js file and doesn't check whether these lines are already present).

You can try to clear the user.js file and set it to read-only. It sounds that other software regularly adds these same lines to the user.js file and doesn't check whether these lines are already present).
இது உங்களுக்கு பயனுள்ளதாக இருந்ததா?
மேற்கோள்
பதிவிடப்பட்டது

கேள்வியின் உரிமையாளர்

Thank You for the Support :-)

Flagging Read-Only both ... .. C:\Data\Firefox\browser\defaults\profile\user.js (and) .. C:\Users\XXX\AppData\Roaming\Mozilla\Firefox\Profiles\XXX.default-release\prefs.js solves the issue

Regards, V.

Thank You for the Support :-) Flagging Read-Only both ... .. C:\Data\Firefox\browser\defaults\profile\user.js (and) .. C:\Users\XXX\AppData\Roaming\Mozilla\Firefox\Profiles\XXX.default-release\prefs.js solves the issue Regards, V.
இது உங்களுக்கு பயனுள்ளதாக இருந்ததா?
மேற்கோள்
cor-el
  • Top 10 Contributor
  • Moderator
17521 தீர்வுகள் 158427 பதில்கள்
பதிவிடப்பட்டது

You shouldn't set prefs.js as read-only because Firefox uses it to store internal data. It is likely that you will get a lot of numbered prefs-##.js temp files that can't be renamed to prefs.js as the result of this action.

You shouldn't set prefs.js as read-only because Firefox uses it to store internal data. It is likely that you will get a lot of numbered prefs-##.js temp files that can't be renamed to prefs.js as the result of this action.
இது உங்களுக்கு பயனுள்ளதாக இருந்ததா?
மேற்கோள்
பதிவிடப்பட்டது

கேள்வியின் உரிமையாளர்

Thank You for the feedback but unfortunately, I tried, if I don't mark pref as Read-Only as well I get back in the previous situation.

Thank You for the feedback but unfortunately, I tried, if I don't mark pref as Read-Only as well I get back in the previous situation.
இது உங்களுக்கு பயனுள்ளதாக இருந்ததா?
மேற்கோள்
alex_mayorga
  • Top 25 Contributor
  • Moderator
369 தீர்வுகள் 2887 பதில்கள்
பதிவிடப்பட்டது

Hi Vincent!

As a last resort you might want to https://support.mozilla.org/en-US/kb/refresh-firefox-reset-add-ons-and-settings and see if that solves the issue.

Please let us know if this solves your question.

Thanks!

Hi Vincent! As a last resort you might want to https://support.mozilla.org/en-US/kb/refresh-firefox-reset-add-ons-and-settings and see if that solves the issue. Please let us know if this solves your question. Thanks!
இது உங்களுக்கு பயனுள்ளதாக இருந்ததா?
மேற்கோள்
கேள்வி எழுப்பு

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.