Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

History is not being saved Only shows up to May 2019.

  • 3 பதிலளிப்புகள்
  • 2 இந்த பிரச்னைகள் உள்ளது
  • 128 views
  • Last reply by graphicfunn

When I click on History Show All History I only get a list showing May, April and Older than 6 months. How do I get all my history to show again?

தீர்வு தேர்ந்தெடுக்கப்பட்டது

Try going to Help -> Troubleshooting Information. Scroll down the page to the "Places Database" section and click the "Verify Integrity" button.

It may take a few seconds.

Copy the output of that run (if it doesn't help, we'd like you to paste it here), and restart Firefox, then visit a few pages and see if history starts appearing.

If it doesn't help, please paste the output of the verify integrity here so we can try and advise you further.

Read this answer in context 👍 1

All Replies (3)

தீர்வு தேர்ந்தெடுக்கப்பட்டது

Try going to Help -> Troubleshooting Information. Scroll down the page to the "Places Database" section and click the "Verify Integrity" button.

It may take a few seconds.

Copy the output of that run (if it doesn't help, we'd like you to paste it here), and restart Firefox, then visit a few pages and see if history starts appearing.

If it doesn't help, please paste the output of the verify integrity here so we can try and advise you further.

Also make sure you do not run Firefox in permanent Private Browsing mode (Always use Private Browsing mode; Never Remember History).

  • Options/Preferences -> Privacy & Security
    Firefox will: "Use custom settings for history"
  • remove checkmark: [ ] "Always use Private Browsing mode"

I was able to get it to start showing the history again by just turning show history off and on a couple times but that does not help with all that was lost even the last few days. I guess there is no way to retrieve that history? But in any case I guess the problem is solved. Thx