X
Tap here to go to the mobile version of the site.

ஆதரவு மன்றம்

On starting Firefox I get 2 homepages instead of one

  • 12 replies
  • 1 இந்த பிரச்சனை உள்ளது
  • Last reply by mgs1
பதிவிடப்பட்டது

I am using Firefox version 68.0.1 on my laptop with Ubuntu 18.04LTS. Browser is Google.uk Every time I start Firefox it gives two homepages instead of one. This means if I start typing something too quickly - some of the type goes on the first homepage and some on the second ! I find this very annoying.

I am using Firefox version 68.0.1 on my laptop with Ubuntu 18.04LTS. Browser is Google.uk Every time I start Firefox it gives two homepages instead of one. This means if I start typing something too quickly - some of the type goes on the first homepage and some on the second ! I find this very annoying.

தீர்வு தேர்ந்தெடுக்கப்பட்டது

I have just used the 'updater' to get the latest version of Firefox 68.0.2 (64 bit) - the previous version I was using was 68.0.1. Lo and behold only one window is appearing! So I'll mark my post as solved. Thanks for the comprehensive new install method and will make a record of it for use if the problem occurs again.

Read this answer in context 0
மேற்கோள்

Additional System Details

பயன்பாடு

  • User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:68.0) Gecko/20100101 Firefox/68.0

கூடுதல் தகவல்

FredMcD
  • Top 10 Contributor
4225 தீர்வுகள் 58977 பதில்கள்
பதிவிடப்பட்டது

Is this two separate tabs or two windows? Are they the same homepage? What is your homepage?

https://support.mozilla.org/en-US/kb/how-to-set-the-home-page

Type about:config<enter> in the address bar. If a warning screen comes up, press the I Accept the Risk button. At the top of the screen is a search bar. Type browser.startup.homepage

What is the value? Right-click and select Reset to restore its default value; about:home

Is this two separate tabs or two windows? Are they the same homepage? What is your homepage? https://support.mozilla.org/en-US/kb/how-to-set-the-home-page Type '''about:config'''<enter> in the address bar. If a warning screen comes up, press the '''I Accept the Risk''' button. At the top of the screen is a search bar. Type '''browser.startup.homepage''' What is the value? Right-click and select '''Reset''' to restore its default value; '''about:home'''
இது உங்களுக்கு பயனுள்ளதாக இருந்ததா?
மேற்கோள்
பதிவிடப்பட்டது

கேள்வியின் உரிமையாளர்

Thanks FredMcD for responding. In Preferences - Home - New Windows and tabs - the homepageand new windows is set to 'Firefox home' and new tabs to 'Firefox home' The same thing occurs if I set the above two lines to 'Blank page' The windows has the words 'New tab' top left.

browser.startup.homepage has value ' about:blank' setting this to ' about:home' make no difference

Thanks FredMcD for responding. In Preferences - Home - New Windows and tabs - the homepageand new windows is set to 'Firefox home' and new tabs to 'Firefox home' The same thing occurs if I set the above two lines to 'Blank page' The windows has the words 'New tab' top left. browser.startup.homepage has value ' about:blank' setting this to ' about:home' make no difference
இது உங்களுக்கு பயனுள்ளதாக இருந்ததா?
மேற்கோள்
FredMcD
  • Top 10 Contributor
4225 தீர்வுகள் 58977 பதில்கள்
பதிவிடப்பட்டது

FredMcD said

Is this two separate tabs or two windows?
Are they the same homepage?

Start Firefox in Safe Mode {web link}

A small dialog should appear. Click Start In Safe Mode (not Refresh). Is the problem still there?

''FredMcD [[#answer-1244690|said]]'' <blockquote> Is this two separate tabs or two windows?<br> Are they the same homepage? </blockquote> [https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode Start Firefox in Safe Mode] {web link} A small dialog should appear. Click '''Start In Safe Mode''' (not Refresh). Is the problem still there?
இது உங்களுக்கு பயனுள்ளதாக இருந்ததா?
மேற்கோள்
பதிவிடப்பட்டது

கேள்வியின் உரிமையாளர்

Two web pages - the second arriving about 2 secs after first. The problem does not happen in safe mode

Two web pages - the second arriving about 2 secs after first. The problem does not happen in safe mode
இது உங்களுக்கு பயனுள்ளதாக இருந்ததா?
மேற்கோள்
FredMcD
  • Top 10 Contributor
4225 தீர்வுகள் 58977 பதில்கள்
பதிவிடப்பட்டது

It could be the work of one of your add-ons, or it could be Hardware Acceleration. How to disable Hardware Acceleration {web link}

Type about:addons<enter> in the address bar to open your Add-ons Manager. Hot key; <Control> (Mac=<Command>) <Shift> A)

In the Add-ons Manager, on the left, select Extensions. Disable a few add-ons, then Restart Firefox.

Some added toolbar and anti-virus add-ons are known to cause Firefox issues. Disable All Of them.

If the problem continues, disable some more (restarting FF). Continue until the problem is gone. After, you know what group is causing the issue. Re-enable the last group ONE AT A TIME (restarting FF) until the problem returns.

Once you think you found the problem, disable that and re-enable all the others, then restart again. Let us know who the suspect is, detective.

It could be the work of one of your add-ons, or it could be '''Hardware Acceleration. ''' ''[https://support.mozilla.org/en-US/kb/forum-response-disable-hardware-acceleration How to disable Hardware Acceleration]'' {web link} Type '''about:addons'''<enter> in the address bar to open your Add-ons Manager. Hot key; '''<Control> ''(Mac=<Command>)'' <Shift> A) ''' In the Add-ons Manager, on the left, select '''Extensions. ''' Disable a few add-ons, then '''Restart Firefox. ''' Some added toolbar and anti-virus add-ons are known to cause Firefox issues. '''Disable All Of them. ''' If the problem continues, disable some more (restarting FF). Continue until the problem is gone. After, you know what group is causing the issue. Re-enable the last group '''ONE AT A TIME''' (restarting FF) until the problem returns. Once you think you found the problem, disable that and re-enable all the others, then restart again. Let us know who the suspect is, detective.
இது உங்களுக்கு பயனுள்ளதாக இருந்ததா?
மேற்கோள்
பதிவிடப்பட்டது

கேள்வியின் உரிமையாளர்

I have checked and I do not have any Addons. Only Plugin is Video codec automatically installed by Mozilla

I have checked and I do not have any Addons. Only Plugin is Video codec automatically installed by Mozilla
இது உங்களுக்கு பயனுள்ளதாக இருந்ததா?
மேற்கோள்
FredMcD
  • Top 10 Contributor
4225 தீர்வுகள் 58977 பதில்கள்
பதிவிடப்பட்டது

And Hardware Acceleration?

What is your primary home page link? Are there any links in it?

And Hardware Acceleration? What is your primary home page link? Are there any links in it?
இது உங்களுக்கு பயனுள்ளதாக இருந்ததா?
மேற்கோள்
பதிவிடப்பட்டது

கேள்வியின் உரிமையாளர்

Not sure what you mean by homepage links etc. Starting computer gives normal launcher column on left of screen which includes firefox. No acceleration Thanks for pursuing this - am fast suspecting a bug.

Not sure what you mean by homepage links etc. Starting computer gives normal launcher column on left of screen which includes firefox. No acceleration Thanks for pursuing this - am fast suspecting a bug.
இது உங்களுக்கு பயனுள்ளதாக இருந்ததா?
மேற்கோள்
FredMcD
  • Top 10 Contributor
4225 தீர்வுகள் 58977 பதில்கள்
பதிவிடப்பட்டது

Let’s do a full clean re-install;

Note: Firefox comes in three or more folders on all computers. They are;

Maintenance: (Programs Folder) <Windows Only> Firefox itself: (Programs Folder) And two folders in the profile of each user on the computer for each Firefox profile for that user.

If you remove the Firefox folder, the user profiles would not be affected.


Download Firefox For All languages And Systems {web link}

Save the file. Then Close Firefox.

Using your file browser, open the Programs Folder on your computer.

Windows: C:\Program Files C:\Program Files (x86) Note: Check Both Folders

Mac: Open the "Applications" folder. https://support.mozilla.org/en-US/kb/how-download-and-install-firefox-mac

Linux: Check your user manual. If you installed Firefox with the distro-based package manager, you should use the same way to uninstall it. See Install Firefox on Linux; https://support.mozilla.org/en-US/kb/install-firefox-linux

If you downloaded and installed the binary package from the Firefox download page, simply remove the folder Firefox in your home directory. http://www.mozilla.org/firefox#desktop ++++++++++++++++++++++++++++ Look for, and remove any Mozilla or Firefox program folders. Do not remove the Mozilla Thunderbird folder if there is one.

Do Not remove any profile folders.

After rebooting the computer, run a registry scanner if you have one. Then run the installer. +++++++++++++++++++++++++++ If there is a problem, start your Computer in safe mode and try again.

http://encyclopedia2.thefreedictionary.com/Linux+Safe+Mode This shows how to Start all Computers in Safe Mode; Free Online Encyclopedia

Let’s do a full clean re-install; Note: Firefox comes in three or more folders on all computers. They are; Maintenance: (Programs Folder) <Windows Only> Firefox itself: (Programs Folder) And two folders in the profile of each user on the computer for each Firefox profile for that user. If you remove the Firefox folder, the user profiles would not be affected. ----------- [http://www.mozilla.org/en-US/firefox/all/ Download Firefox For All languages And Systems] {web link} Save the file. Then '''Close Firefox. ''' Using your file browser, open the '''Programs Folder''' on your computer. '''Windows: ''' C:\Program Files C:\Program Files (x86) '''Note:''' Check Both Folders '''Mac: ''' Open the ''' "Applications" ''' folder. https://support.mozilla.org/en-US/kb/how-download-and-install-firefox-mac '''Linux: ''' Check your user manual. If you installed Firefox with the distro-based package manager, you should use the same way to uninstall it. See Install Firefox on Linux; https://support.mozilla.org/en-US/kb/install-firefox-linux If you downloaded and installed the binary package from the Firefox download page, simply remove the folder Firefox in your home directory. http://www.mozilla.org/firefox#desktop ++++++++++++++++++++++++++++ Look for, and remove any '''Mozilla''' or '''Firefox''' program folders. Do not remove the '''Mozilla Thunderbird''' folder if there is one. '''Do Not''' remove any profile folders. After rebooting the computer, run a registry scanner if you have one. Then run the installer. +++++++++++++++++++++++++++ If there is a problem, start your '''Computer''' in safe mode and try again. http://encyclopedia2.thefreedictionary.com/Linux+Safe+Mode This shows how to Start all Computers in Safe Mode; Free Online Encyclopedia
இது உங்களுக்கு பயனுள்ளதாக இருந்ததா?
மேற்கோள்
பதிவிடப்பட்டது

தீர்வு தேர்ந்தெடுக்கப்பட்டது

I have just used the 'updater' to get the latest version of Firefox 68.0.2 (64 bit) - the previous version I was using was 68.0.1. Lo and behold only one window is appearing! So I'll mark my post as solved. Thanks for the comprehensive new install method and will make a record of it for use if the problem occurs again.

I have just used the 'updater' to get the latest version of Firefox 68.0.2 (64 bit) - the previous version I was using was 68.0.1. Lo and behold only one window is appearing! So I'll mark my post as solved. Thanks for the comprehensive new install method and will make a record of it for use if the problem occurs again.
இது உங்களுக்கு பயனுள்ளதாக இருந்ததா?
மேற்கோள்
FredMcD
  • Top 10 Contributor
4225 தீர்வுகள் 58977 பதில்கள்
பதிவிடப்பட்டது

That was very good work. Well done.

That was very good work. Well done.
இது உங்களுக்கு பயனுள்ளதாக இருந்ததா?
மேற்கோள்
பதிவிடப்பட்டது

கேள்வியின் உரிமையாளர்

Postscript. I have the found the cause of two windows appearing - it has nothing to do with 'Upgrading' after all.

On my startup screen when I turn on the laptop I have a number of shortcut files - to active these I need to 'double click' on them.

But Firefox on the side bar Launcher only requires 'one click' so a 'double click' will produce two windows!

As simple as that - but double clicking is so ingrained that I still make the mistake. Why there is a difference perhaps someone could enlighten me.

Postscript. I have the found the cause of two windows appearing - it has nothing to do with 'Upgrading' after all. On my startup screen when I turn on the laptop I have a number of shortcut files - to active these I need to 'double click' on them. But Firefox on the side bar Launcher only requires 'one click' so a 'double click' will produce two windows! As simple as that - but double clicking is so ingrained that I still make the mistake. Why there is a difference perhaps someone could enlighten me.
இது உங்களுக்கு பயனுள்ளதாக இருந்ததா?
மேற்கோள்
கேள்வி எழுப்பு

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.