X
Tap here to go to the mobile version of the site.

ஆதரவு மன்றம்

How to disable multiple task manager processes?

  • 10 replies
  • 3 இந்த பிரச்னைகள் உள்ளது
  • Last reply by benmillan
பதிவிடப்பட்டது

I had once changed a setting which allowed FireFox to only one run process, but somethings changed and now there are about 15 firefox.exe processes running in my task manager and would like to change it back to a single process.....what setting fixes this?

I had once changed a setting which allowed FireFox to only one run process, but somethings changed and now there are about 15 firefox.exe processes running in my task manager and would like to change it back to a single process.....what setting fixes this?
மேற்கோள்

Additional System Details

பயன்பாடு

  • User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:68.0) Gecko/20100101 Firefox/68.0

கூடுதல் தகவல்

McCoy
  • Top 10 Contributor
545 தீர்வுகள் 5143 பதில்கள்
பதிவிடப்பட்டது

Hello BigJohnny,

Multi-process (e10s) can no longer be disabled on the "about:config" page - see :

https://techdows.com/2019/05/mozilla-firefox-68-doesnt-allow-turning-off-e10s.html

If however, you really want to disable it, you can set an environment variable to disable multi-process. :
• set MOZ_FORCE_DISABLE_E10S=1
How to set environment variables : http://www.computerhope.com/issues/ch000549.htm

You can use the set command to create a temporary environment variable.

  • open command prompt window
  • change to installation directory
  • type "set MOZ_FORCE_DISABLE_E10S=1" and press enter
  • type "firefox.exe" and press enter

How to use set command : http://www.computerhope.com/sethlp.htm


Or you could set an environment variable in the Windows Control Panel => System.

You can create a firefox-e10s.cmd file with this content:

set MOZ_FORCE_DISABLE_E10S=1 start "" "<path_to_firefox>\firefox.exe"

• (64-bit Firefox) "C:\Program Files\Mozilla Firefox\" • (32-bit Firefox) "C:\Program Files (x86)\Mozilla Firefox\"

(edit: typo)

Hello BigJohnny, Multi-process (e10s) can no longer be disabled on the "about:config" page - see : https://techdows.com/2019/05/mozilla-firefox-68-doesnt-allow-turning-off-e10s.html If however, you really want to disable it, you can set an environment variable to disable multi-process. :<BR> • set MOZ_FORCE_DISABLE_E10S=1<BR> How to set environment variables : http://www.computerhope.com/issues/ch000549.htm You can use the set command to create a temporary environment variable. * open command prompt window * change to installation directory * type "set MOZ_FORCE_DISABLE_E10S=1" and press enter * type "firefox.exe" and press enter How to use set command : http://www.computerhope.com/sethlp.htm -------------------------------------------------------------------------------------------------------- Or you could set an environment variable in the Windows Control Panel => System. You can create a firefox-e10s.cmd file with this content: set MOZ_FORCE_DISABLE_E10S=1 start "" "<path_to_firefox>\firefox.exe" • (64-bit Firefox) "C:\Program Files\Mozilla Firefox\" • (32-bit Firefox) "C:\Program Files (x86)\Mozilla Firefox\" (edit: typo)

McCoy மூலமாக திருத்தப்பட்டது

இது உங்களுக்கு பயனுள்ளதாக இருந்ததா? 1
மேற்கோள்
பதிவிடப்பட்டது

கேள்வியின் உரிமையாளர்

so is there a reason it uses so many processes? I'm looking at 12 processes right now. if I use just one process it ends up taking up to about 4 million kb of memory, but it's using about the same or more with all the processes as well

so is there a reason it uses so many processes? I'm looking at 12 processes right now. if I use just one process it ends up taking up to about 4 million kb of memory, but it's using about the same or more with all the processes as well
இது உங்களுக்கு பயனுள்ளதாக இருந்ததா?
மேற்கோள்
cor-el
  • Top 10 Contributor
  • Moderator
17539 தீர்வுகள் 158593 பதில்கள்
பதிவிடப்பட்டது

It is quite normal to see more Firefox processes running.

  • one process for the main Firefox thread (user interface)
  • one or more content processes (default is 8), see:
    Options/Preferences -> General -> Performance
    remove checkmark: [ ] "Use recommended performance settings"
  • one process for the compositor thread
  • one process for the WebRender when this feature is enabled

You can find the current multi-process state on the Troubleshooting Information page (about:support).

  • "Help -> Troubleshooting Information" -> "Application Basics":
    Multiprocess Windows
    Remote Processes

See also the Remote Processes section further down for more detail.

It is quite normal to see more Firefox processes running. *one process for the main Firefox thread (user interface) *one or more content processes (default is 8), see:<br>Options/Preferences -> General -> Performance<br>remove checkmark: [ ] "Use recommended performance settings" *one process for the compositor thread *one process for the WebRender when this feature is enabled You can find the current multi-process state on the Troubleshooting Information page (about:support). *"Help -> Troubleshooting Information" -> "Application Basics":<br>Multiprocess Windows<br>Remote Processes See also the Remote Processes section further down for more detail.
இது உங்களுக்கு பயனுள்ளதாக இருந்ததா? 1
மேற்கோள்
Bill Mayhew 0 தீர்வுகள் 10 பதில்கள்
பதிவிடப்பட்டது

I got a half-dozen firefox.exe processes on my laptop after updating to 68.

Is this my payback for keeping Firefox (manually) updated??

(NOT a happy camper, but at least it's still (nominally) working...)

I got a half-dozen firefox.exe processes on my laptop after updating to 68. Is this my payback for keeping Firefox (manually) updated?? (NOT a happy camper, but at least it's still (nominally) working...)
இது உங்களுக்கு பயனுள்ளதாக இருந்ததா?
மேற்கோள்
Bill Mayhew 0 தீர்வுகள் 10 பதில்கள்
பதிவிடப்பட்டது

6 processes on a single-core CPU are a bit much... esp. when you add in all the Windows disServices ;) ... I currently have 13 svchost.exe's .

But, good news... performance mysteriously improved, now 90%+ idle. (68.0.1 64-bit)

But I still have 6 firefox.exe's... mysteriously only using a total of 7% CPU... which I can live with.

6 processes on a single-core CPU are a bit much... esp. when you add in all the Windows disServices ;) ... I currently have 13 svchost.exe's . But, good news... performance mysteriously improved, now 90%+ idle. (68.0.1 64-bit) But I still have 6 firefox.exe's... mysteriously only using a total of 7% CPU... which I can live with.

Bill Mayhew மூலமாக திருத்தப்பட்டது

இது உங்களுக்கு பயனுள்ளதாக இருந்ததா?
மேற்கோள்
Eldar Value 4 தீர்வுகள் 45 பதில்கள்
பதிவிடப்பட்டது

Bill Mayhew said

6 processes on a single-core CPU are a bit much... esp. when you add in all the Windows disServices ;) ... I currently have 13 svchost.exe's . But, good news... performance mysteriously improved, now 90%+ idle. (68.0.1 64-bit) But I still have 6 firefox.exe's... mysteriously only using a total of 7% CPU... which I can live with.

if you're think you've a malware running in your pc you can try to perform a scan with freeware portable tool called adwcleaner.

To disable multi processes go to `about:config?filter=browser.tabs.remote.autostart` and make sure to change the value to `false`, after you've done that, restart firefox.

''Bill Mayhew [[#answer-1245474|said]]'' <blockquote> 6 processes on a single-core CPU are a bit much... esp. when you add in all the Windows disServices ;) ... I currently have 13 svchost.exe's . But, good news... performance mysteriously improved, now 90%+ idle. (68.0.1 64-bit) But I still have 6 firefox.exe's... mysteriously only using a total of 7% CPU... which I can live with. </blockquote> if you're think you've a malware running in your pc you can try to perform a scan with freeware portable tool called adwcleaner. To disable multi processes go to `about:config?filter=browser.tabs.remote.autostart` and make sure to change the value to `false`, after you've done that, restart firefox.
இது உங்களுக்கு பயனுள்ளதாக இருந்ததா?
மேற்கோள்
cor-el
  • Top 10 Contributor
  • Moderator
17539 தீர்வுகள் 158593 பதில்கள்
பதிவிடப்பட்டது

^ Quote; To disable multi processes go to `about:config?filter=browser.tabs.remote.autostart` and make sure to change the value to `false`, after you've done that, restart firefox.

That is not correct. In Firefox 68 and later you can no longer disable multi-process via a pref. As posted above, you need to use an environment variable (MOZ_FORCE_DISABLE_E10S=1).

^ Quote; ''To disable multi processes go to `about:config?filter=browser.tabs.remote.autostart` and make sure to change the value to `false`, after you've done that, restart firefox.'' That is not correct. In Firefox 68 and later you can no longer disable multi-process via a pref. As posted above, you need to use an environment variable (MOZ_FORCE_DISABLE_E10S=1).
இது உங்களுக்கு பயனுள்ளதாக இருந்ததா?
மேற்கோள்
Bill Mayhew 0 தீர்வுகள் 10 பதில்கள்
பதிவிடப்பட்டது

உதவிகரமான பதில்

I expect a league-leading browser like Firefox to accommodate ALL its long-term users - even on low-end laptops - WITHOUT *workarounds* like environment variables. Firefox should be able to tell when it's running on single-core machines and STOP adding MULTIPLE PROCESSES to the workload,

VERY TACKY, Mozilla!!!

I expect a league-leading browser like Firefox to accommodate ALL its long-term users - even on low-end laptops - WITHOUT *workarounds* like environment variables. Firefox should be able to tell when it's running on single-core machines and STOP adding MULTIPLE PROCESSES to the workload, VERY TACKY, Mozilla!!!
இது உங்களுக்கு பயனுள்ளதாக இருந்ததா? 2
மேற்கோள்
benmillan 0 தீர்வுகள் 3 பதில்கள்
பதிவிடப்பட்டது

McCoy said

Hello BigJohnny, Multi-process (e10s) can no longer be disabled on the "about:config" page - see : https://techdows.com/2019/05/mozilla-firefox-68-doesnt-allow-turning-off-e10s.html If however, you really want to disable it, you can set an environment variable to disable multi-process. :
• set MOZ_FORCE_DISABLE_E10S=1
How to set environment variables : http://www.computerhope.com/issues/ch000549.htm You can use the set command to create a temporary environment variable.
  • open command prompt window
  • change to installation directory
  • type "set MOZ_FORCE_DISABLE_E10S=1" and press enter
  • type "firefox.exe" and press enter
How to use set command : http://www.computerhope.com/sethlp.htm

Or you could set an environment variable in the Windows Control Panel => System.

You can create a firefox-e10s.cmd file with this content:

set MOZ_FORCE_DISABLE_E10S=1 start "" "<path_to_firefox>\firefox.exe"

• (64-bit Firefox) "C:\Program Files\Mozilla Firefox\" • (32-bit Firefox) "C:\Program Files (x86)\Mozilla Firefox\"

(edit: typo)

I tried this and it doesn't work.

''McCoy [[#answer-1240246|said]]'' <blockquote> Hello BigJohnny, Multi-process (e10s) can no longer be disabled on the "about:config" page - see : https://techdows.com/2019/05/mozilla-firefox-68-doesnt-allow-turning-off-e10s.html If however, you really want to disable it, you can set an environment variable to disable multi-process. :<BR> • set MOZ_FORCE_DISABLE_E10S=1<BR> How to set environment variables : http://www.computerhope.com/issues/ch000549.htm You can use the set command to create a temporary environment variable. * open command prompt window * change to installation directory * type "set MOZ_FORCE_DISABLE_E10S=1" and press enter * type "firefox.exe" and press enter How to use set command : http://www.computerhope.com/sethlp.htm -------------------------------------------------------------------------------------------------------- Or you could set an environment variable in the Windows Control Panel => System. You can create a firefox-e10s.cmd file with this content: set MOZ_FORCE_DISABLE_E10S=1 start "" "<path_to_firefox>\firefox.exe" • (64-bit Firefox) "C:\Program Files\Mozilla Firefox\" • (32-bit Firefox) "C:\Program Files (x86)\Mozilla Firefox\" (edit: typo) </blockquote> I tried this and it doesn't work.
இது உங்களுக்கு பயனுள்ளதாக இருந்ததா?
மேற்கோள்
benmillan 0 தீர்வுகள் 3 பதில்கள்
பதிவிடப்பட்டது

I personally don't care what the reasons for multiple processes are, I just want to get rid of them.

Firefox harasses me to update it, then I can no longer use it because it's hogging all of my system resources. I had it fixed before, then made the mistake of updating again, and so on, for about the past two years.

If this can't be fixed, then I'm sure as hell not going to sink a few thousand into a newer PC just so I can use what I already had.

I tried the about:config menu, tried environment variables, tried the command prompt, tried rebooting and did a couple full malware scans.

Firefox is STILL hogging system resources, and it's so bad that I can't even watch a video.

If no one knows of a good, PERMANENT solution, then does anyone know of another privacy-friendly browser that doesn't do this?

Someone please help!!!

I personally don't care what the reasons for multiple processes are, I just want to get rid of them. Firefox harasses me to update it, then I can no longer use it because it's hogging all of my system resources. I had it fixed before, then made the mistake of updating again, and so on, for about the past two years. If this can't be fixed, then I'm sure as hell not going to sink a few thousand into a newer PC just so I can use what I already had. I tried the about:config menu, tried environment variables, tried the command prompt, tried rebooting and did a couple full malware scans. Firefox is STILL hogging system resources, and it's so bad that I can't even watch a video. If no one knows of a good, PERMANENT solution, then does anyone know of another privacy-friendly browser that doesn't do this? Someone please help!!!
இது உங்களுக்கு பயனுள்ளதாக இருந்ததா?
மேற்கோள்
கேள்வி எழுப்பு

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.