X
Tap here to go to the mobile version of the site.

ஆதரவு மன்றம்

Upgrading to Firefox 68 enabled the address bar search dropdown, can I disable this?

  • 6 replies
  • 1 இந்த பிரச்சனை உள்ளது
  • Last reply by cor-el
பதிவிடப்பட்டது

After an upgrade to FF68 the address bar now has a drop down and it uses my search provider. I previously was able to type a term or website just in the bar itself, no drop down, no clutter.

Is there any way to turn this off? I had previously created a css file in my chrome directory and it was working just fine.

Chrome.css file with the following content in order to hide the addressbar dropdown-menu:

  1. PopupAutoCompleteRichResult {
 display: none;

}

I have also gone into about:config and previously changed settings like url.dropdown.search or whatever it was. Turned off search suggestions and a couple others.

Should I modify or check anything else?

After an upgrade to FF68 the address bar now has a drop down and it uses my search provider. I previously was able to type a term or website just in the bar itself, no drop down, no clutter. Is there any way to turn this off? I had previously created a css file in my chrome directory and it was working just fine. Chrome.css file with the following content in order to hide the addressbar dropdown-menu: #PopupAutoCompleteRichResult { display: none; } I have also gone into about:config and previously changed settings like url.dropdown.search or whatever it was. Turned off search suggestions and a couple others. Should I modify or check anything else?
Attached screenshots

தீர்வு தேர்ந்தெடுக்கப்பட்டது

Why just not set the browser.urlbar.maxRichResults to 0 in about:config?

Read this answer in context 1
மேற்கோள்

Additional System Details

நிறுவப்பட்ட நிரல்கள்

Ghostery, Adblock Plus, https everywhere.

பயன்பாடு

  • User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:68.0) Gecko/20100101 Firefox/68.0

கூடுதல் தகவல்

TyDraniu
  • Top 25 Contributor
301 தீர்வுகள் 1686 பதில்கள்
பதிவிடப்பட்டது

தீர்வு தேர்ந்தெடுக்கப்பட்டது

Why just not set the browser.urlbar.maxRichResults to 0 in about:config?

Why just not set the ''browser.urlbar.maxRichResults'' to '''0''' in about:config?
இது உங்களுக்கு பயனுள்ளதாக இருந்ததா? 1
மேற்கோள்
பதிவிடப்பட்டது

கேள்வியின் உரிமையாளர்

Excellent that worked like a charm! I had tried several other about:config settings over many different versions, and they seemed to work just fine. Then about 2 or 3 versions ago they all stopped. Someone suggested the css file and that worked up until version 68,

Thank you!

Excellent that worked like a charm! I had tried several other about:config settings over many different versions, and they seemed to work just fine. Then about 2 or 3 versions ago they all stopped. Someone suggested the css file and that worked up until version 68, Thank you!
இது உங்களுக்கு பயனுள்ளதாக இருந்ததா?
மேற்கோள்
cor-el
  • Top 10 Contributor
  • Moderator
17344 தீர்வுகள் 156777 பதில்கள்
பதிவிடப்பட்டது

உதவிகரமான பதில்

In Firefox 68 with the change from XUL to XHTML, you need this code in userChrome.css.

#urlbar-results { display:none!important; }
In Firefox 68 with the change from XUL to XHTML, you need this code in userChrome.css. #urlbar-results { display:none!important; }
இது உங்களுக்கு பயனுள்ளதாக இருந்ததா? 1
மேற்கோள்
பதிவிடப்பட்டது

கேள்வியின் உரிமையாளர்

Right on! That works too! While the first solution got rid of text and most of the drop down (there was still a tiny white bar showing if that makes sense) This one removed it completely.

Thanks both for taking a look!

Right on! That works too! While the first solution got rid of text and most of the drop down (there was still a tiny white bar showing if that makes sense) This one removed it completely. Thanks both for taking a look!
இது உங்களுக்கு பயனுள்ளதாக இருந்ததா?
மேற்கோள்
l_bratch 0 தீர்வுகள் 1 பதில்கள்
பதிவிடப்பட்டது

Is it possible to remove just the top "Visit" suggestion from the dropdown? This was possible from Firefox 43 and Firefox 67 using:

#PopupAutoCompleteRichResult richlistitem[actiontype="visiturl"]{
  display:none !important;
}

Thanks Luke

Is it possible to remove just the top "Visit" suggestion from the dropdown? This was possible from Firefox 43 and Firefox 67 using: #PopupAutoCompleteRichResult richlistitem[actiontype="visiturl"]{ display:none !important; } Thanks Luke
இது உங்களுக்கு பயனுள்ளதாக இருந்ததா?
மேற்கோள்
cor-el
  • Top 10 Contributor
  • Moderator
17344 தீர்வுகள் 156777 பதில்கள்
பதிவிடப்பட்டது

This panel uses code in the HTML namespace and this has the code to be placed above this line. You can alternatively use a separate file for this namespace and use @import url(""); This rule also needs to be above the default XUL @namespace line in userChrome.css.

Add code to the userChrome.css file above the default @namespace line.


@import url("chrome-html.css");

#urlbar-results #urlbarView-row-0 {
  display:none !important;
}

@namespace url("http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul"); /* only needed once */
This panel uses code in the HTML namespace and this has the code to be placed above this line. You can alternatively use a separate file for this namespace and use @import url(""); This rule also needs to be above the default XUL @namespace line in userChrome.css. Add code to the <b>userChrome.css</b> file <b>above</b> the default @namespace line. *http://kb.mozillazine.org/userChrome.css <hr> <pre><nowiki> @import url("chrome-html.css"); #urlbar-results #urlbarView-row-0 { display:none !important; } @namespace url("http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul"); /* only needed once */ </nowiki></pre>
இது உங்களுக்கு பயனுள்ளதாக இருந்ததா? 1
மேற்கோள்
கேள்வி எழுப்பு

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.