X
Tap here to go to the mobile version of the site.

ஆதரவு மன்றம்

Setting to block embedded videos from initially playing?

  • 3 replies
  • 1 இந்த பிரச்சனை உள்ளது
  • Last reply by xytsrm
பதிவிடப்பட்டது

When Firefox was initially run it blocked embedded videos from automatically playing; they had to be manually started. Now, the only feature found in the privacy setting is to stop the sound from automatically playing.

What happened to the original capability, to stop videos from automatically playing?

When Firefox was initially run it blocked embedded videos from automatically playing; they had to be manually started. Now, the only feature found in the privacy setting is to stop the sound from automatically playing. What happened to the original capability, to stop videos from automatically playing?

தீர்வு தேர்ந்தெடுக்கப்பட்டது

Note that some players that are created via JavaScript may not be caught by Firefox and might still start playing.

Read this answer in context 0
மேற்கோள்

Additional System Details

பயன்பாடு

  • User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:67.0) Gecko/20100101 Firefox/67.0

கூடுதல் தகவல்

McCoy
  • Top 10 Contributor
469 தீர்வுகள் 4268 பதில்கள்
பதிவிடப்பட்டது

உதவிகரமான பதில்

Hello xytsrm,

Would you try this please :

Type in the address bar about:config and press Enter (promise to be careful, if asked)

Type in the search bar media.autoplay

and check the values of these preferences :

media.autoplay.default = 1 [0=Allowed, 1=Blocked, 2=Prompt]

media.autoplay.allow-muted = false

media.autoplay.enabled.user-gestures-needed :

You'll have to experiment with the value, to see whether false or true works for you.

Also try to toggle :

media.block-autoplay-until-in-foreground

After you've made changes, close and restart Firefox.


Also see this article (which I think you've already read, but just in case) :

https://support.mozilla.org/en-US/kb/block-autoplay

Hello xytsrm, Would you try this please : Type in the address bar '''about:config''' and press Enter (promise to be careful, if asked) Type in the search bar '''media.autoplay''' and check the values of these preferences : '''media.autoplay.default''' = '''1''' [0=Allowed, 1=Blocked, 2=Prompt] '''media.autoplay.allow-muted''' = '''false''' '''media.autoplay.enabled.user-gestures-needed''' : You'll have to experiment with the value, to see whether '''false''' or '''true''' works for you. Also try to toggle : '''media.block-autoplay-until-in-foreground''' After you've made changes, close and restart Firefox. ------------------------------------------------------------------------------------------- Also see this article (which I think you've already read, but just in case) : https://support.mozilla.org/en-US/kb/block-autoplay
இது உங்களுக்கு பயனுள்ளதாக இருந்ததா? 1
மேற்கோள்
cor-el
  • Top 10 Contributor
  • Moderator
17277 தீர்வுகள் 156165 பதில்கள்
பதிவிடப்பட்டது

தீர்வு தேர்ந்தெடுக்கப்பட்டது

Note that some players that are created via JavaScript may not be caught by Firefox and might still start playing.

Note that some players that are created via JavaScript may not be caught by Firefox and might still start playing.
இது உங்களுக்கு பயனுள்ளதாக இருந்ததா?
மேற்கோள்
பதிவிடப்பட்டது

கேள்வியின் உரிமையாளர்

McCoy said

Hello xytsrm, Would you try this please : Type in the address bar about:config and press Enter (promise to be careful, if asked) Type in the search bar media.autoplay and check the values of these preferences : media.autoplay.default = 1 [0=Allowed, 1=Blocked, 2=Prompt] media.autoplay.allow-muted = false media.autoplay.enabled.user-gestures-needed : You'll have to experiment with the value, to see whether false or true works for you. Also try to toggle : media.block-autoplay-until-in-foreground After you've made changes, close and restart Firefox.

Also see this article (which I think you've already read, but just in case) :

https://support.mozilla.org/en-US/kb/block-autoplay

Thanks,

Some how media.autoplay.allow-muted = false was changed to "True". Perhaps I inadvertently clicked on the icon in the address-bar, turning the blocking off.

Changing back to "false" again stopped the videos from initially playing.

Thanks again. X

''McCoy [[#answer-1232435|said]]'' <blockquote> Hello xytsrm, Would you try this please : Type in the address bar '''about:config''' and press Enter (promise to be careful, if asked) Type in the search bar '''media.autoplay''' and check the values of these preferences : '''media.autoplay.default''' = '''1''' [0=Allowed, 1=Blocked, 2=Prompt] '''media.autoplay.allow-muted''' = '''false''' '''media.autoplay.enabled.user-gestures-needed''' : You'll have to experiment with the value, to see whether '''false''' or '''true''' works for you. Also try to toggle : '''media.block-autoplay-until-in-foreground''' After you've made changes, close and restart Firefox. ------------------------------------------------------------------------------------------- Also see this article (which I think you've already read, but just in case) : https://support.mozilla.org/en-US/kb/block-autoplay </blockquote> Thanks, Some how ''media.autoplay.allow-muted''' = '''false'' was changed to "True". Perhaps I inadvertently clicked on the icon in the address-bar, turning the blocking off. Changing back to "false" again stopped the videos from initially playing. Thanks again. X
இது உங்களுக்கு பயனுள்ளதாக இருந்ததா?
மேற்கோள்
கேள்வி எழுப்பு

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.