X
Tap here to go to the mobile version of the site.

ஆதரவு மன்றம்

firefox will not accept cookies even though cookies setting is standard.

  • 26 replies
  • 1 இந்த பிரச்சனை உள்ளது
  • Last reply by cor-el
பதிவிடப்பட்டது

Firefox keeps saying it cannot continue to create a firefox account because cookies are disabled. I check my cookies setting and cookies setting is standard. Firefox will not create an account because it keeps saying cookies are disable when they are not disabled. I have had to do this using Chrome.

Firefox keeps saying it cannot continue to create a firefox account because cookies are disabled. I check my cookies setting and cookies setting is standard. Firefox will not create an account because it keeps saying cookies are disable when they are not disabled. I have had to do this using Chrome.

தீர்வு தேர்ந்தெடுக்கப்பட்டது

Hi all,

I set up firefox on my Samsung 7 phone and Sync worked with no issues.

I think my laptop is heading towards the window! Its not just firefox causing me grief.

Thanks again for all your suggestions.

Read this answer in context 0
மேற்கோள்

Additional System Details

நிறுவப்பட்ட நிரல்கள்

nothing yet.

பயன்பாடு

  • User Agent: Mozilla/5.0 (Windows NT 6.3; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/74.0.3729.169 Safari/537.36/loLhTcEz-7

கூடுதல் தகவல்

FredMcD
  • Top 10 Contributor
4248 தீர்வுகள் 59425 பதில்கள்
பதிவிடப்பட்டது
https://support.mozilla.org/en-US/kb/websites-say-cookies-are-blocked-unblock-them
இது உங்களுக்கு பயனுள்ளதாக இருந்ததா? 0
மேற்கோள்
பதிவிடப்பட்டது

கேள்வியின் உரிமையாளர்

I've done everything that the above page suggests and I still cannot sign in using Firefox. It keeps saying cookies are blocked when they are not blocked.

I've done everything that the above page suggests and I still cannot sign in using Firefox. It keeps saying cookies are blocked when they are not blocked.
இது உங்களுக்கு பயனுள்ளதாக இருந்ததா?
மேற்கோள்
WestEnd
  • Top 25 Contributor
60 தீர்வுகள் 5379 பதில்கள்
பதிவிடப்பட்டது

What security or adblocker do you have installed? This would be the only reason why it's not working if settings are default.

What security or adblocker do you have installed? This would be the only reason why it's not working if settings are default.
இது உங்களுக்கு பயனுள்ளதாக இருந்ததா? 0
மேற்கோள்
FredMcD
  • Top 10 Contributor
4248 தீர்வுகள் 59425 பதில்கள்
பதிவிடப்பட்டது

When you're on that site, click on the 'i' in a circle, next to the padlock at the left side of the address bar. Then click on the little black arrow on the dropdown (next to 'Connection') and then on "More Information", which will take you to "Page Info". Click on the 'Permissions" tab and scroll down to "Set Cookies". Uncheck "Use Default" and check "Allow". Then close and restart Firefox.

When you're on that site, click on the 'i' in a circle, next to the padlock at the left side of the address bar. Then click on the little black arrow on the dropdown (next to 'Connection') and then on "More Information", which will take you to "Page Info". Click on the 'Permissions" tab and scroll down to "Set Cookies". Uncheck "Use Default" and check "Allow". Then close and restart Firefox.
இது உங்களுக்கு பயனுள்ளதாக இருந்ததா? 0
மேற்கோள்
cor-el
  • Top 10 Contributor
  • Moderator
17482 தீர்வுகள் 157978 பதில்கள்
பதிவிடப்பட்டது

Make sure you allow cookies for accounts.firefox.com. Also make sure that you do not use Private Browsing mode to avoid issues with other types of storage.

In case of issues try to log in to the Firefox Account via this website.

Make sure you allow cookies for accounts.firefox.com. Also make sure that you do not use Private Browsing mode to avoid issues with other types of storage. In case of issues try to log in to the Firefox Account via this website. *https://accounts.firefox.com/signin *https://accounts.firefox.com/settings
இது உங்களுக்கு பயனுள்ளதாக இருந்ததா? 0
மேற்கோள்
McCoy
  • Top 10 Contributor
534 தீர்வுகள் 5035 பதில்கள்
பதிவிடப்பட்டது

cor-el said

Make sure you allow cookies for accounts.firefox.com.

FredMcD said

When you're on that site, click on the 'i' in a circle, next to the padlock at the left side of the address bar.
Then click on the little black arrow on the dropdown (next to 'Connection') and then on "More Information", which will take you to "Page Info".
Click on the 'Permissions" tab and scroll down to "Set Cookies".
Uncheck "Use Default" and check "Allow".
Then close and restart Firefox.
''cor-el [[#answer-1228524|said]]'' <blockquote> Make sure you allow cookies for accounts.firefox.com. </blockquote> ''FredMcD [[#answer-1228501|said]]'' <blockquote> When you're on that site, click on the 'i' in a circle, next to the padlock at the left side of the address bar.<BR> Then click on the little black arrow on the dropdown (next to 'Connection') and then on "More Information", which will take you to "Page Info".<BR> Click on the 'Permissions" tab and scroll down to "Set Cookies". <BR> Uncheck "Use Default" and check "Allow".<BR> Then close and restart Firefox. </blockquote>
இது உங்களுக்கு பயனுள்ளதாக இருந்ததா? 0
மேற்கோள்
பதிவிடப்பட்டது

கேள்வியின் உரிமையாளர்

I am running out of things to untick, allow, turn off, disable, uninstall, restart, to try to get it working. I've looked for every possible allow cookie section and nothing works. I enter into Sync and try to sync firefox and I am not allowed to as cookies are disabled when they are not. I appreciate the replies to my issue, and thank you for your time, but I have already tried what you have suggested and firefox will not let me sync firefox because cookies are disabled when they are not.

I am running out of things to untick, allow, turn off, disable, uninstall, restart, to try to get it working. I've looked for every possible allow cookie section and nothing works. I enter into Sync and try to sync firefox and I am not allowed to as cookies are disabled when they are not. I appreciate the replies to my issue, and thank you for your time, but I have already tried what you have suggested and firefox will not let me sync firefox because cookies are disabled when they are not.
இது உங்களுக்கு பயனுள்ளதாக இருந்ததா?
மேற்கோள்
McCoy
  • Top 10 Contributor
534 தீர்வுகள் 5035 பதில்கள்
பதிவிடப்பட்டது

Hello Stephen,

So sorry you had to go through all this trouble - would you try one more thing though  ?

Type in the address bar about:config and press Enter (promise to be careful, if asked)

Type in the search bar dom.storage.enabled

and make sure its value is set to true

If you had to change the value, then close and restart Firefox.


Also see this article, especially the section :

Firefox Sync shows a "Cookies are still disabled" error message

Hello Stephen, So sorry you had to go through all this trouble - would you try one more thing though ? Type in the address bar '''about:config''' and press Enter (promise to be careful, if asked) Type in the search bar '''dom.storage.enabled''' and make sure its value is set to '''true''' If you had to change the value, then close and restart Firefox. -------------------------------------------------------------------------------------------- Also see this article, especially the section : [https://support.mozilla.org/en-US/kb/firefox-sync-troubleshooting-and-tips Firefox Sync shows a "Cookies are still disabled" error message]
இது உங்களுக்கு பயனுள்ளதாக இருந்ததா?
மேற்கோள்
cor-el
  • Top 10 Contributor
  • Moderator
17482 தீர்வுகள் 157978 பதில்கள்
பதிவிடப்பட்டது

Any messages in the Web Console about blocked cookies or security issues?

Any messages in the Web Console about blocked cookies or security issues? *"3-bar" menu button or Tools -> Web Developer *https://developer.mozilla.org/en-US/Tools/Web_Console
இது உங்களுக்கு பயனுள்ளதாக இருந்ததா?
மேற்கோள்
பதிவிடப்பட்டது

கேள்வியின் உரிமையாளர்

Attached is a photo of the Web_Console when firefox says cookies are disabled when they are not.

Attached is a photo of the Web_Console when firefox says cookies are disabled when they are not.
இது உங்களுக்கு பயனுள்ளதாக இருந்ததா?
மேற்கோள்
பதிவிடப்பட்டது

கேள்வியின் உரிமையாளர்

Photo showing Dom_Storage_enabled set to TRUE.

Photo showing Dom_Storage_enabled set to TRUE.
இது உங்களுக்கு பயனுள்ளதாக இருந்ததா?
மேற்கோள்
McCoy
  • Top 10 Contributor
534 தீர்வுகள் 5035 பதில்கள்
பதிவிடப்பட்டது

stephenlinton1 said

Photo showing Dom_Storage_enabled set to TRUE.

Thank you  !

I just found this (4-yo) bug report :

https://bugzilla.mozilla.org/show_bug.cgi?id=1210362

If you want to, you could vote to show your interest for a bug report :

https://bugzilla.mozilla.org/page.cgi?id=voting.html


And then maybe scroll all the way down here to see what solved the problem for this user :

https://github.com/mozilla/fxa-content-server/issues/4796

''stephenlinton1 [[#answer-1228942|said]]'' <blockquote> Photo showing Dom_Storage_enabled set to TRUE. </blockquote> Thank you ! I just found this (4-yo) bug report : https://bugzilla.mozilla.org/show_bug.cgi?id=1210362 If you want to, you could vote to show your interest for a bug report : https://bugzilla.mozilla.org/page.cgi?id=voting.html --------------------------------------------------------------------------------------------- And then maybe scroll all the way down here to see what solved the problem for this user : https://github.com/mozilla/fxa-content-server/issues/4796
இது உங்களுக்கு பயனுள்ளதாக இருந்ததா?
மேற்கோள்
cor-el
  • Top 10 Contributor
  • Moderator
17482 தீர்வுகள் 157978 பதில்கள்
பதிவிடப்பட்டது

Make sure you do not run Firefox in permanent Private Browsing mode (Always use Private Browsing mode; Never Remember History).

  • Options/Preferences -> Privacy & Security
    Firefox will: "Use custom settings for history"
  • remove checkmark: [ ] "Always use Private Browsing mode"
Make sure you do not run Firefox in permanent Private Browsing mode (Always use Private Browsing mode; Never Remember History). *https://support.mozilla.org/en-US/kb/private-browsing-use-firefox-without-history *Options/Preferences -> Privacy & Security<br>Firefox will: "Use custom settings for history" *remove checkmark: [ ] "Always use Private Browsing mode"
இது உங்களுக்கு பயனுள்ளதாக இருந்ததா?
மேற்கோள்
McCoy
  • Top 10 Contributor
534 தீர்வுகள் 5035 பதில்கள்
பதிவிடப்பட்டது

Shane Tomlinson (Sync developer) just opened this issue :

https://github.com/mozilla/fxa/issues/1560

Shane Tomlinson (Sync developer) just opened this issue : https://github.com/mozilla/fxa/issues/1560
இது உங்களுக்கு பயனுள்ளதாக இருந்ததா?
மேற்கோள்
பதிவிடப்பட்டது

கேள்வியின் உரிமையாளர்

I'm starting to think the problem is with my laptop. The question I'm asking is whether to reformat or buy a new laptop.

So far all suggestions given haven't changed how Firefox operates.

Thank you for all your suggestions and the time given to try and resolve my problem. I appreciate the efforts you have gone to to assist me.

Steve.

I'm starting to think the problem is with my laptop. The question I'm asking is whether to reformat or buy a new laptop. So far all suggestions given haven't changed how Firefox operates. Thank you for all your suggestions and the time given to try and resolve my problem. I appreciate the efforts you have gone to to assist me. Steve.
இது உங்களுக்கு பயனுள்ளதாக இருந்ததா?
மேற்கோள்
McCoy
  • Top 10 Contributor
534 தீர்வுகள் 5035 பதில்கள்
பதிவிடப்பட்டது

Hello again Steve,

You're not in permanent private browsing mode  ?

And you have no add-ons that might be interfering ?

(see cor-el's post here and Shane Tomlinson's post on github)

Hello again Steve, You're not in permanent private browsing mode ? And you have no add-ons that might be interfering ? (see cor-el's post here and Shane Tomlinson's post on github)
இது உங்களுக்கு பயனுள்ளதாக இருந்ததா?
மேற்கோள்
பதிவிடப்பட்டது

கேள்வியின் உரிமையாளர்

Hi again,

Not in private browsing mode only two add-ons.

Steve.

Hi again, Not in private browsing mode only two add-ons. Steve.
இது உங்களுக்கு பயனுள்ளதாக இருந்ததா?
மேற்கோள்
McCoy
  • Top 10 Contributor
534 தீர்வுகள் 5035 பதில்கள்
பதிவிடப்பட்டது

stephenlinton1 said

only two add-ons.

Would you mind telling us which add-ons - or (just for now) disable them and see if that will make a difference  ?

''stephenlinton1 [[#answer-1229268|said]]'' <blockquote> only two add-ons. </blockquote> Would you mind telling us which add-ons - or (just for now) disable them and see if that will make a difference ?
இது உங்களுக்கு பயனுள்ளதாக இருந்ததா?
மேற்கோள்
பதிவிடப்பட்டது

கேள்வியின் உரிமையாளர்

OpenH264 Video Codec provided by Cisco Systems, Inc Widevine Content Decryption Module provided by Google Inc

these are the two Add-ons.

OpenH264 Video Codec provided by Cisco Systems, Inc Widevine Content Decryption Module provided by Google Inc these are the two Add-ons.
இது உங்களுக்கு பயனுள்ளதாக இருந்ததா?
மேற்கோள்
McCoy
  • Top 10 Contributor
534 தீர்வுகள் 5035 பதில்கள்
பதிவிடப்பட்டது

stephenlinton1 said

OpenH264 Video Codec provided by Cisco Systems, Inc Widevine Content Decryption Module provided by Google Inc these are the two Add-ons.

Thank you !

What I should have asked : do you have any extensions installed (cause these two are plugins)  ?

"Add-ons" is the collective name for extensions, plugins, dictionaries and themes - you weren't to know; my bad.

''stephenlinton1 [[#answer-1229273|said]]'' <blockquote> OpenH264 Video Codec provided by Cisco Systems, Inc Widevine Content Decryption Module provided by Google Inc these are the two Add-ons. </blockquote> Thank you ! What I should have asked : do you have any extensions installed (cause these two are plugins) ? "Add-ons" is the collective name for extensions, plugins, dictionaries and themes - you weren't to know; my bad.
இது உங்களுக்கு பயனுள்ளதாக இருந்ததா?
மேற்கோள்
கேள்வி எழுப்பு

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.