Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Can't play vp9/opus videos in FF

  • 11 பதிலளிப்புகள்
  • 1 இந்த பிரச்சனை உள்ளது
  • Last reply by Michele31416

This is Firefox 52.0.2 32 bit ESR, Solaris 10U13 Sparc, on a 2.75 GHz. quad core Sparc VII Sun M3000 from a Sun Ray 2fs thin client.

ffmpeg, libx264 and libx265 have all been installed from Flash 11.2 r202 is also installed.

A look at shows all six boxes under "What does this browser support?" are checked. The box "The HTML5 player is currently used when possible" is also checked.

I can play some videos fine, for example this H264 test page:

(Actually, there's no sound but this is a Sun Ray audio issue, not Firefox).

All three of the test videos here: also play OK (or they did before the author of this page removed the files).

All three test videos on this page also play OK:

Some Youtube videos also play fine, like this one: or this one:

The right-click "stats for nerds" shows they use avc1 and mp4a codecs.

But any video that uses vp9 and opus codecs does not play. It just sits there with a spinning circle on a black background forever. And that seems like the vast majority of videos on Youtube.

In fact avc1/opus videos on Youtube also fail to start. This happens even with all FF add-ons disabled.

Oddly on, the small preview window videos play OK but when clicked to full-size, they just give the spinning circle. (I can't tell what format those are).

Is there any way to get these opus videos to play?

All Replies (11)

VP9 is disabled in Firefox because it caused stability issues (crashes). You can try to enable it at your own risk.

See the about:config page:

  • media.eme.vp9-in-mp4.enabled

You can open the about:config page via the location/address bar. You can accept the warning and click "I accept the risk!" to continue.

Thanks for the idea. I didn't have that key so I created it, set it to True, and restarted FF. Sadly, it didn't work. I still get the endless spinning circle on VP9 videos.

Is it perhaps because I need the actual VP9 decoder itself? I downloaded it from here:

but haven't actually tried doing anything with it yet. It's not clear it will work in Solaris Sparc anyway.

I missed that you use Firefox 52.9.0. This might be about WebM in the version (about:config -> media.webm).

  • media.opus.enabled
  • media.webm.enabled

You can reset the above mentioned pref to remove it.

VP9 works for me on this page in Firefox 52.9.0.

Hmm, I already had both of those keys set to True but when I tried playing the link you gave, both the VP9 and VP8 videos actually played. They were missing the red channel, but at least they ran to completion.

So then that would seem to point the finger at Youtube. So I guess the question isn't "VP9 doesn't play" but becomes "VP9 doesn't play in Youtube". I've read bunches of complaints about people not being able to play Youtube videos in FF, but none like this.

Can you post a link to a video that doesn't play because you only posted links to videos that work, so there is nothing to test?

Oh sure, good point. Any Youtube video that uses VP9 fails. Eg.

Things that use avc1 do work: (although the bunch of ads that precede this one do not play).

I tested the first video and it plays with Firefox 52.

Interesting. I can get Youtube VP9 videos to play in FF 52.9.0 on my XP PC but they don't play in FF 52.0.2 on my Solaris 10 Sparc machine.

Which 52 version are you using? What platform? Any add-ons?

Well having heard nothing back, I'm going to go on the assumption that I need the actual VP9 decoder on this machine. I'm trying to build it now but it's being stubbron.

Apparently I had the wrong VP9. I downloaded and it compiled just fine. I did need to replace the diff that came with Solaris with the GNU version from OpenCSW but that was it. I now have the VP9 decoder for Solaris Sparc.

The next question is, how do I tell Firefox where to find it? I have a file called vpxdec. Where does it go?

Well for the benefit of anyone else with this problem in the meantime I found a workaround. I installed the H264ify extension. This causes VP9 videos to be played with H264. That worked fine. Youtube videos now play in Solaris Sparc. Logging out of my JDE session and then back in solved the missing audio problem.