X
Tap here to go to the mobile version of the site.

ஆதரவு மன்றம்

Internet speed significantly slow on Firefox than on other apps

பதிவிடப்பட்டது

My wifi plan is of 50 Mbps. When checked on Firefox via Ookla speedtest it shows only 9 to 10 Mbps. It has been showing this since the past week, before that it was accurate to 50 Mbps. Also when checked on Ookla Speedtest app on Windows, the speed is accurate (50 Mbps). I was trying to attach screenshots but it is stuck on 'Loading'.

My wifi plan is of 50 Mbps. When checked on Firefox via Ookla speedtest it shows only 9 to 10 Mbps. It has been showing this since the past week, before that it was accurate to 50 Mbps. Also when checked on Ookla Speedtest app on Windows, the speed is accurate (50 Mbps). I was trying to attach screenshots but it is stuck on 'Loading'.

தீர்வு தேர்ந்தெடுக்கப்பட்டது

OK That's a microsoft tool, btw. Save it for a rainy day.

If there isn't anything else, don't forget to mark your post as solved.

Great work!

Read this answer in context 1
மேற்கோள்

Additional System Details

நிறுவப்பட்ட நிரல்கள்

  • Shockwave Flash 32.0 r0

பயன்பாடு

  • User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:67.0) Gecko/20100101 Firefox/67.0

கூடுதல் தகவல்

பதிவிடப்பட்டது

கேள்வியின் உரிமையாளர்

I've attached screenshots below. They are tested simultaneously.

I've attached screenshots below. They are tested simultaneously.
இது உங்களுக்கு பயனுள்ளதாக இருந்ததா?
மேற்கோள்
My_Cheese_Is_Slippin'
  • Top 10 Contributor
60 தீர்வுகள் 739 பதில்கள்
பதிவிடப்பட்டது

உதவிகரமான பதில்

Hi MMG97, Connectivity issues can be tricky. And getting the best connection results takes some time. They also vary from time to time if you are wireless. I'm on ethernet cable. I have a 55 Mbps plan and I consistently download at 82 Mbps.

First of all, check that your proxy settings are the same in both Firefox and the app that you are using.

Second, I noticed that your speed tests were done using different servers. Always use the same server for comparison.

For some real help with internet connection issues and speedtests go to dslreports.com. They have lots of tools, articles, tips & tricks and a forum to ask questions.

Hope this helps.

Hi MMG97, Connectivity issues can be tricky. And getting the best connection results takes some time. They also vary from time to time if you are wireless. I'm on ethernet cable. I have a 55 Mbps plan and I consistently download at 82 Mbps. First of all, check that your proxy settings are the same in both Firefox and the app that you are using. Second, I noticed that your speed tests were done using different servers. Always use the same server for comparison. For some real help with internet connection issues and speedtests go to dslreports.com. They have lots of tools, articles, tips & tricks and a forum to ask questions. Hope this helps.
இது உங்களுக்கு பயனுள்ளதாக இருந்ததா? 1
மேற்கோள்
பதிவிடப்பட்டது

கேள்வியின் உரிமையாளர்

Thanks for responding. The proxy settings on both the apps are on 'Auto' and as you said, I kept the servers same this time. Still the same result.

Thanks for responding. The proxy settings on both the apps are on 'Auto' and as you said, I kept the servers same this time. Still the same result.
இது உங்களுக்கு பயனுள்ளதாக இருந்ததா?
மேற்கோள்
My_Cheese_Is_Slippin'
  • Top 10 Contributor
60 தீர்வுகள் 739 பதில்கள்
பதிவிடப்பட்டது

உதவிகரமான பதில்

Hi again, I get a little better result when Firefox is set to Use System Proxy Settings.

What stands out to me in your screenshot is the unusually long ping. When I do a speed test the ping is normally 7-9 ms. Try different servers which will give you the fastest ping. They are usually the ones which are the closest to you.

Do you have an anti-virus which might be buffering your connection? Try to disable it temporarily and run another test.

Hi again, I get a little better result when Firefox is set to Use System Proxy Settings. What stands out to me in your screenshot is the unusually long ping. When I do a speed test the ping is normally 7-9 ms. Try different servers which will give you the fastest ping. They are usually the ones which are the closest to you. Do you have an anti-virus which might be buffering your connection? Try to disable it temporarily and run another test.
இது உங்களுக்கு பயனுள்ளதாக இருந்ததா? 1
மேற்கோள்
My_Cheese_Is_Slippin'
  • Top 10 Contributor
60 தீர்வுகள் 739 பதில்கள்
பதிவிடப்பட்டது

Hi MMG97, Another thought. Did you try re-booting your router/dsl?


Nevermind. I'm overthinking..

Hi MMG97, Another thought. Did you try re-booting your router/dsl? Nevermind. I'm overthinking..

My_Cheese_Is_Slippin' மூலமாக திருத்தப்பட்டது

இது உங்களுக்கு பயனுள்ளதாக இருந்ததா? 1
மேற்கோள்
பதிவிடப்பட்டது

கேள்வியின் உரிமையாளர்

I appreciate your help but I've tried everything. Not just on Firefox but this issue is consistent with Chrome and Microsoft Edge too. I don't think there's any issue with my wifi or router because the speeds on cellphones is accurate. I'm starting to think it has something to do with windows update I guess. XD Thank you for your help though. :)

I appreciate your help but I've tried everything. Not just on Firefox but this issue is consistent with Chrome and Microsoft Edge too. I don't think there's any issue with my wifi or router because the speeds on cellphones is accurate. I'm starting to think it has something to do with windows update I guess. XD Thank you for your help though. :)
இது உங்களுக்கு பயனுள்ளதாக இருந்ததா?
மேற்கோள்
My_Cheese_Is_Slippin'
  • Top 10 Contributor
60 தீர்வுகள் 739 பதில்கள்
பதிவிடப்பட்டது

I'm sorry to hear that we couldn't get the issue resolved today. Maybe you can get some answers from tenforums.com or microsoft community forum.

Good Luck!

I'm sorry to hear that we couldn't get the issue resolved today. Maybe you can get some answers from tenforums.com or microsoft community forum. Good Luck!
இது உங்களுக்கு பயனுள்ளதாக இருந்ததா?
மேற்கோள்
பதிவிடப்பட்டது

கேள்வியின் உரிமையாளர்

Well god bless windows' 'uninstall updates' feature. I uninstalled the latest update and the speeds are back to normal. Thank you so much for keeping up with me anyways. :p

Well god bless windows' 'uninstall updates' feature. I uninstalled the latest update and the speeds are back to normal. Thank you so much for keeping up with me anyways. :p
இது உங்களுக்கு பயனுள்ளதாக இருந்ததா?
மேற்கோள்
My_Cheese_Is_Slippin'
  • Top 10 Contributor
60 தீர்வுகள் 739 பதில்கள்
பதிவிடப்பட்டது

Great! I'm glad you found the culprit! Can you keep the update from re-installing automatically?

Maybe this would help (temporarily): https://www.tenforums.com/tutorials/8280-hide-show-windows-updates-windows-10-a.html

Great! I'm glad you found the culprit! Can you keep the update from re-installing automatically? Maybe this would help (temporarily): https://www.tenforums.com/tutorials/8280-hide-show-windows-updates-windows-10-a.html
இது உங்களுக்கு பயனுள்ளதாக இருந்ததா? 1
மேற்கோள்
பதிவிடப்பட்டது

கேள்வியின் உரிமையாளர்

I disabled the windows updates for now. If any problem arises I'll try that fix.

I disabled the windows updates for now. If any problem arises I'll try that fix.
இது உங்களுக்கு பயனுள்ளதாக இருந்ததா?
மேற்கோள்
My_Cheese_Is_Slippin'
  • Top 10 Contributor
60 தீர்வுகள் 739 பதில்கள்
பதிவிடப்பட்டது

தீர்வு தேர்ந்தெடுக்கப்பட்டது

OK That's a microsoft tool, btw. Save it for a rainy day.

If there isn't anything else, don't forget to mark your post as solved.

Great work!

OK That's a microsoft tool, btw. Save it for a rainy day. If there isn't anything else, don't forget to mark your post as solved. Great work!
இது உங்களுக்கு பயனுள்ளதாக இருந்ததா? 1
மேற்கோள்
கேள்வி எழுப்பு

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.