Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox is blocking the Wayback Machine ffs. It is not displaying the [Advanced] button so I can't override it. Please fix it.

  • 14 பதிலளிப்புகள்
  • 1 இந்த பிரச்சனை உள்ளது
  • 784 views
  • Last reply by FredMcD

So when I try to visit archive.org or its wayback machine, I get "Secure Connection Failed" Two widgets are offered: a tickbox for reporting issues and a [Try Again] button. Your Help says to click on the [Advanced] button but there isn't one.

Before anybody gives me a lesson in online security, I would ask that you focus on your usability issue and not my personal habits, thanks.

தீர்வு தேர்ந்தெடுக்கப்பட்டது

Problem now resolved. Not an FF issue after all, my apologies. Turned out that the router's PoP had an adult-only content filter enabled, neither the the off switch nor even the fact of its existence was available via the router admin UI, I happened to log in to my account on the ISP web site (Vodafone), where I stumbled across the filter and disabled it from there. Still, had all the FF help pages not banged on about the [Advanced] button that appears not to exist in the Linux build of 60.6.2esr, I might have cottoned on sooner. One might expect that an ESR release would have ESR grade help documentation to go with it. Sadly not. Thanks all for your help, anyway.

Read this answer in context 👍 0

All Replies (14)

Sorry, all that is no help. Firefox used to open a dialog so that I could make exceptions on a site by site basis. That option is not being offered to me here. Your help system now tells me that instead I have to contact the web admins of a truly venerable institution such as the Wayback Machine. That is idiocy. Surely the ability to make my own security judgements has not been totally hijacked by the Firefox dev team?

Clicked on the link and had no issues getting to the site. I think you got security issues blocking or adblocker causing your site issues.

I have Adblock Plus and Noscript, Both are set to let it through. Toggling them off/on does not clear the problem. My router has a firewall with its domain name blacklist empty. Nothing else blocks like this, this is a first for me in many a year. Firefox is still adamant that "The page you are trying to view cannot be shown because the authenticity of the received data could not be verified." Can you clarify what you mean by "security issues blocking"?

Start Firefox in Safe Mode {web link}

A small dialog should appear. Click Start In Safe Mode (not Refresh). Is the problem still there?


Start your Computer in safe mode with network support. Then start Firefox. Try Secure websites. Is the problem still there?

http://encyclopedia2.thefreedictionary.com/Linux+Safe+Mode Starting Any Computer In Safe Mode; Free Online Encyclopedia

Thank you for the suggestions, though I have no idea what underlies them. Sadly:

Started FF in safe mode, still blocked. as root did # telinit 1, then # startx, then FF in safe mode. still blocked.

But what is this "Secure websites"? I cannot find a menu option which matches that, nor can I find anything on the help search/website etc. Where do I find it? How do I recognize it? What do I do when I have it open?

steelpillow மூலமாக திருத்தப்பட்டது

FredMcD said

Try Secure websites

A website whose address starts with https:// is a secured site. https://archive.org/

FredMcD said

FredMcD said
Try Secure websites

A website whose address starts with https:// is a secured site. https://archive.org/

All the other secure (https) sites I have been visiting are fine. I have not found another site with this problem, that's why I came here to ask.

steelpillow மூலமாக திருத்தப்பட்டது

Note that the OP is on Linux, so suggestions for Windows won't help.


Try to rename the cert9.db (cert9OLD.db) file and remove the previously used cert8.db file in the Firefox profile folder with Firefox closed to remove intermediate certificates and exceptions that Firefox has cached.

If this has helped to solve the problem then you can remove the renamed cert9OLD.db file. Otherwise you can undo the rename and restore cert9.db.

You can use the button on the "Help -> Troubleshooting Information" (about:support) page to go to the current Firefox profile folder or use the about:profiles page.

No change, still bad. Is there a log somewhere that could give further information about what is going wrong?

Does the security tab in the Network Monitor give any detail?

If you get the neterror page then check if there is more detail available.

  • click the "Advanced" button show more details
  • click the blue error text if you see such a text to see if there is more detail available
  • click "Copy text to clipboard" and paste the text in a reply

If clicking the blue error text doesn't provide the certificate chain then try these steps to inspect the certificate.

  • open the Servers tab in the Certificate Manager
    • Options/Preferences -> Privacy & Security
      Certificates: View Certificates -> Servers: "Add Exception"
  • paste the URL of the website (https://xxx.xxx) in it's Location field

Let Firefox retrieve the certificate -> "Get Certificate"

  • click the "View" button and inspect the certificate

You can find detail like the issuer of the certificate and intermediate certificates in the Details tab.


If the [Advanced] button ever really matters, as I said in the title of this post, I don't have one. Maybe because I am on Linux? Or maybe it appears on the "Your connection is not secure" page but not the "Secure Connection Failed" page that I am getting? Or am I missing something?

The Firefox Monitor Network tool shows only the GET request for the page, no other activity at all. I cannot see a Security tab anywhere, where should I be looking? Clicking the blue highlight on the GET request brings up no certificate info, but it does give this Header info:

Request URL: https://archive.org/ Request method: GET Request headers (1.423 kB) Accept: text/html,application/xhtml+xm…plication/xml;q=0.9,*/*;q=0.8 Accept-Encoding: gzip, deflate, br Accept-Language: en,en-GB;q=0.7,en-US;q=0.3 Connection: keep-alive Cookie: AMCV_F0695E09512D2BCD0A490D4D%…ca=P0-304083302-1555087297068 Host: archive.org Upgrade-Insecure-Requests: 1 User-Agent: Mozilla/5.0 (X11; Linux x86_64…) Gecko/20100101 Firefox/60.0

I have no idea whether "Upgrade-Insecure-Requests: 1" is relevant.

Cannot find anything called a "Certificate Manager" either in my UI or the Help so I have not been able to follow that procedure. Clicked the i icon at LH end of the address bar, followed through to More Information, but the form is basically blank - no web site identity info or anything - and the [View Certificate] button does nothing. I am looking at the Secure Connection Failed page here, as it is the only one that gets displayed. When I visit other sites, the certificate viewer opens just fine. But no sign of a Servers tab, so maybe I am looking in the wrong place for this "Certificate Manager"?

steelpillow மூலமாக திருத்தப்பட்டது

தீர்வு தேர்ந்தெடுக்கப்பட்டது

Problem now resolved. Not an FF issue after all, my apologies. Turned out that the router's PoP had an adult-only content filter enabled, neither the the off switch nor even the fact of its existence was available via the router admin UI, I happened to log in to my account on the ISP web site (Vodafone), where I stumbled across the filter and disabled it from there. Still, had all the FF help pages not banged on about the [Advanced] button that appears not to exist in the Linux build of 60.6.2esr, I might have cottoned on sooner. One might expect that an ESR release would have ESR grade help documentation to go with it. Sadly not. Thanks all for your help, anyway.

steelpillow மூலமாக திருத்தப்பட்டது

That was very good work. Well done.