X
Tap here to go to the mobile version of the site.

ஆதரவு மன்றம்

இந்த இழை மூடப்பட்டது. Please ask a new question if you need help.

I'm unable to change menu language

  • 16 replies
  • 1 இந்த பிரச்சனை உள்ளது
  • Last reply by Chris Ilias
பதிவிடப்பட்டது

The main "Firefox" menu is in Japanese, but all the rest of the menus (File, Edit, View, History, etc.) are in English.

How can I change the "Firefox" menu's language back to English? I've already tried it in settings.

I am unable to attach screenshots for an unknown reason so will instead link them here:

https://take.ms/K86Jh

https://take.ms/IhA2L

https://take.ms/5qMoL

MacOS 10.14.4 FF Quantum 66.0.3 (64-bit)

The main "Firefox" menu is in Japanese, but all the rest of the menus (File, Edit, View, History, etc.) are in English. How can I change the "Firefox" menu's language back to English? I've already tried it in settings. I am unable to attach screenshots for an unknown reason so will instead link them here: https://take.ms/K86Jh https://take.ms/IhA2L https://take.ms/5qMoL MacOS 10.14.4 FF Quantum 66.0.3 (64-bit)

mgibson323 மூலமாக திருத்தப்பட்டது

தீர்வு தேர்ந்தெடுக்கப்பட்டது

I'm on macOS and I managed to reproduce this.

To fix this, you'll need to uninstall the Japanese language.

  1. To go Tools > Addons > Languages.
  2. Beside Japanese, click Remove.
  3. Restart Firefox.
Read this answer in context 1

Additional System Details

நிறுவப்பட்ட நிரல்கள்

  • Shockwave Flash 32.0 r0

பயன்பாடு

  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.14; rv:66.0) Gecko/20100101 Firefox/66.0

கூடுதல் தகவல்

WestEnd
  • Top 25 Contributor
60 தீர்வுகள் 5379 பதில்கள்
பதிவிடப்பட்டது

I for myself use Chrome for this feature so it can change languages on the fly. I use Windows but having Chrome being able to go to English helps alot especially on Online retailer sites.

Did you close and restart the Browser after doing that change?

I for myself use Chrome for this feature so it can change languages on the fly. I use Windows but having Chrome being able to go to English helps alot especially on Online retailer sites. Did you close and restart the Browser after doing that change?
பதிவிடப்பட்டது

கேள்வியின் உரிமையாளர்

WestEnd said

Did you close and restart the Browser after doing that change?

The change to test Japanese was over 2 months ago, and was reverted the same day. I quit the browser daily.

''WestEnd [[#answer-1214367|said]]'' <blockquote> Did you close and restart the Browser after doing that change? </blockquote> The change to test Japanese was over 2 months ago, and was reverted the same day. I quit the browser daily.
cor-el
  • Top 10 Contributor
  • Moderator
17467 தீர்வுகள் 157849 பதில்கள்
பதிவிடப்பட்டது

If the Firefox user interface (toolbars) is in the wrong language or if you want to change the current language then download Firefox in the language of your choice.

If the Firefox user interface (toolbars) is in the wrong language or if you want to change the current language then download Firefox in the language of your choice. *https://www.mozilla.org/en-US/firefox/all/
பதிவிடப்பட்டது

கேள்வியின் உரிமையாளர்

cor-el said

If the Firefox user interface (toolbars) is in the wrong language or if you want to change the current language then download Firefox in the language of your choice.

As you will see if you review the screenshots I linked to, all of the menus are in English except for the "Firefox" menu - which is in Japanese.

''cor-el [[#answer-1214404|said]]'' <blockquote> If the Firefox user interface (toolbars) is in the wrong language or if you want to change the current language then download Firefox in the language of your choice. *https://www.mozilla.org/en-US/firefox/all/ </blockquote> As you will see if you review the screenshots I linked to, all of the menus are in English except for the "Firefox" menu - which is in Japanese.
cor-el
  • Top 10 Contributor
  • Moderator
17467 தீர்வுகள் 157849 பதில்கள்
பதிவிடப்பட்டது

What does the "Help -> Troubleshooting Information" (about:support) page show for the language settings (Internationalization & Localization) at the bottom of this page?

What does the "Help -> Troubleshooting Information" (about:support) page show for the language settings (Internationalization & Localization) at the bottom of this page?
பதிவிடப்பட்டது

கேள்வியின் உரிமையாளர்

Here is a screenshot:

Here is a screenshot:
cor-el
  • Top 10 Contributor
  • Moderator
17467 தீர்வுகள் 157849 பதில்கள்
பதிவிடப்பட்டது

So, it looks that the OS system locale setting is used for the Firefox menu. I don't know whether Firefox handles (creates) this menu or that this menu is created/filled by the Mac OS because on Mac the main menu bar is handled by the OS and not under control of Firefox.

You could try to ask advice at the Mac support forum.

So, it looks that the OS system locale setting is used for the Firefox menu. I don't know whether Firefox handles (creates) this menu or that this menu is created/filled by the Mac OS because on Mac the main menu bar is handled by the OS and not under control of Firefox. You could try to ask advice at the Mac support forum.
பதிவிடப்பட்டது

கேள்வியின் உரிமையாளர்

Mac forums are spectacularly unhelpful so it seems I may be stuck.

Thanks for your help, cor-el.

Mac forums are spectacularly unhelpful so it seems I may be stuck. Thanks for your help, cor-el.
cor-el
  • Top 10 Contributor
  • Moderator
17467 தீர்வுகள் 157849 பதில்கள்
பதிவிடப்பட்டது

Maybe try Reddit and mozillaZine to see whether Mac users there have suggestions.

Maybe try Reddit and mozillaZine to see whether Mac users there have suggestions. *https://www.reddit.com/r/firefox/
Chris Ilias
  • Moderator
354 தீர்வுகள் 1943 பதில்கள்
பதிவிடப்பட்டது

தீர்வு தேர்ந்தெடுக்கப்பட்டது

I'm on macOS and I managed to reproduce this.

To fix this, you'll need to uninstall the Japanese language.

  1. To go Tools > Addons > Languages.
  2. Beside Japanese, click Remove.
  3. Restart Firefox.
I'm on macOS and I managed to reproduce this. To fix this, you'll need to uninstall the Japanese language. # To go '''Tools > Addons > Languages'''. # Beside ''Japanese'', click '''Remove'''. # Restart Firefox.
பதிவிடப்பட்டது

கேள்வியின் உரிமையாளர்

Not sure why I didn't think to try that myself! Thanks Chris.

Not sure why I didn't think to try that myself! Thanks Chris.
xander.dorn 0 தீர்வுகள் 2 பதில்கள்
பதிவிடப்பட்டது

Hi!

I got a similar problem. With every Firefox update in the last few years the menu language was set to German even though I haven't even installed the German language pack. So I couldn't even deactivate anything and in the options the language was always set to English - I also tried both British and US with no success. So far the only thing that ever worked was to reinstall Firefox completely but today not even this works anymore. Is there a solution to this old bug?

yours Xander

Hi! I got a similar problem. With every Firefox update in the last few years the menu language was set to German even though I haven't even installed the German language pack. So I couldn't even deactivate anything and in the options the language was always set to English - I also tried both British and US with no success. So far the only thing that ever worked was to reinstall Firefox completely but today not even this works anymore. Is there a solution to this old bug? yours Xander
McCoy
  • Top 10 Contributor
533 தீர்வுகள் 5035 பதில்கள்
பதிவிடப்பட்டது

xander.dorn said

Is there a solution to this old bug?

Hi Xander !

Would you please take a look at the last post in this bug report :

https://bugzilla.mozilla.org/show_bug.cgi?id=1564998

See this thread : https://support.mozilla.org/en-US/questions/1268054

''xander.dorn [[#answer-1249662|said]]'' <blockquote> Is there a solution to this old bug? </blockquote> Hi Xander ! Would you please take a look at the last post in this bug report : https://bugzilla.mozilla.org/show_bug.cgi?id=1564998 See this thread : https://support.mozilla.org/en-US/questions/1268054
xander.dorn 0 தீர்வுகள் 2 பதில்கள்
பதிவிடப்பட்டது

the purgecache doesn't work either

the purgecache doesn't work either
McCoy
  • Top 10 Contributor
533 தீர்வுகள் 5035 பதில்கள்
பதிவிடப்பட்டது

xander.dorn said

the purgecache doesn't work either

It's the first part of the last post in the bug report that did the trick (maunally updating the language pack) ......

(I added a link to that thread, because the OPs initial reaction was the same as yours is now)

''xander.dorn [[#answer-1249664|said]]'' <blockquote> the purgecache doesn't work either </blockquote> It's the first part of the last post in the bug report that did the trick (maunally updating the language pack) ...... (I added a link to that thread, because the OPs initial reaction was the same as yours is now)
Chris Ilias
  • Moderator
354 தீர்வுகள் 1943 பதில்கள்
பதிவிடப்பட்டது

Hi Xander, A post in this thread was marked as the solution by the person who asked the original question (mgibson323). Your issue may have similar symptoms, but it is likely a different cause/solution. You should use https://support.mozilla.org/en-US/questions/new where volunteers can get more details about your setup.

Because this thread is solved and more people might start using it for their own questions, I'm going to lock it.

Hi Xander, A post in this thread was marked as the solution by the person who asked the original question (mgibson323). Your issue may have similar symptoms, but it is likely a different cause/solution. You should use https://support.mozilla.org/en-US/questions/new where volunteers can get more details about your setup. Because this thread is solved and more people might start using it for their own questions, I'm going to lock it.