X
Tap here to go to the mobile version of the site.

ஆதரவு மன்றம்

List of Addons not visible after Firefox update

  • 14 replies
  • 1 இந்த பிரச்சனை உள்ளது
  • Last reply by FredMcD
பதிவிடப்பட்டது

My Addons are working okay, however when I look at the about:addons page the list only shows blank spaces where addons should be, only a blue highlight shows if I click on each addon.

This is the same for my Plugins and Themes.

I have tried deleting some files in my profile as suggested by others on here with similar problems but none work.

My Addons are working okay, however when I look at the about:addons page the list only shows blank spaces where addons should be, only a blue highlight shows if I click on each addon. This is the same for my Plugins and Themes. I have tried deleting some files in my profile as suggested by others on here with similar problems but none work.
Attached screenshots

தீர்வு தேர்ந்தெடுக்கப்பட்டது

FredMcD said

It only shows your system and Firefox information. Look it over if you want.

Okay found solution from another poster on here by JayShankar as below..

Helpful Reply This thread seems to be active, so just in case it helps, here's my experience: After upgrading to Quantum (v. 65/66) I had exactly the same result with blank entries in the Add-ons Manager, although the add-ons themselves were working. Likewise, starting in safe mode revealed them successfully.

The culprit in my case was in my profile's chrome folder where I had installed a github custom css tweak, specifically the userContent.css file in that folder. The solution was very simple and painfully obvious: edit that file manually using textedit and comment out (/*) any lines containing "aboutaddons/addonlists". ... Voila! problem solved, the Add-ons Manager is back to normal.

I hope this helps anyone who might have the same problem originating in the chrome folder.

Read this answer in context 0
மேற்கோள்

Additional System Details

நிறுவப்பட்ட நிரல்கள்

  • Shockwave Flash 32.0 r0

பயன்பாடு

  • User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:66.0) Gecko/20100101 Firefox/66.0

கூடுதல் தகவல்

FredMcD
  • Top 10 Contributor
4224 தீர்வுகள் 58976 பதில்கள்
பதிவிடப்பட்டது

Type chrome://mozapps/content/extensions/extensions.xul? <enter> in the address bar. Now disable everything. Restart Firefox.


It could be the work of one of your add-ons, or it could be Hardware Acceleration. How to disable Hardware Acceleration {web link}

Type about:addons<enter> in the address bar to open your Add-ons Manager. Hot key; <Control> (Mac=<Command>) <Shift> A)

In the Add-ons Manager, on the left, select Extensions. Disable a few add-ons, then Restart Firefox.

Some added toolbar and anti-virus add-ons are known to cause Firefox issues. Disable All Of them.

If the problem continues, disable some more (restarting FF). Continue until the problem is gone. After, you know what group is causing the issue. Re-enable the last group ONE AT A TIME (restarting FF) until the problem returns.

Once you think you found the problem, disable that and re-enable all the others, then restart again. Let us know who the suspect is, detective.

Type '''chrome://mozapps/content/extensions/extensions.xul? '''<enter> in the address bar. Now disable everything. Restart Firefox. --------------- It could be the work of one of your add-ons, or it could be '''Hardware Acceleration. ''' ''[https://support.mozilla.org/en-US/kb/forum-response-disable-hardware-acceleration How to disable Hardware Acceleration]'' {web link} Type '''about:addons'''<enter> in the address bar to open your Add-ons Manager. Hot key; '''<Control> ''(Mac=<Command>)'' <Shift> A) ''' In the Add-ons Manager, on the left, select '''Extensions. ''' Disable a few add-ons, then '''Restart Firefox. ''' Some added toolbar and anti-virus add-ons are known to cause Firefox issues. '''Disable All Of them. ''' If the problem continues, disable some more (restarting FF). Continue until the problem is gone. After, you know what group is causing the issue. Re-enable the last group '''ONE AT A TIME''' (restarting FF) until the problem returns. Once you think you found the problem, disable that and re-enable all the others, then restart again. Let us know who the suspect is, detective.
இது உங்களுக்கு பயனுள்ளதாக இருந்ததா?
மேற்கோள்
பதிவிடப்பட்டது

கேள்வியின் உரிமையாளர்

Thanks for your reply.

You seem to miss the point that I cannot see any of my addons to be able to disable them.

However I found I can view my addons in Safe Mode I have already tried disabling all my addons, plugins and themes, restarting Firefox but nothing changes so it isn't being caused by any addon.

You can see by the image attachment all that shows are the container places for my addons unless I run Firefox in safe mode.

Thanks for your reply. You seem to miss the point that I cannot see any of my addons to be able to disable them. However I found I can view my addons in Safe Mode I have already tried disabling all my addons, plugins and themes, restarting Firefox but nothing changes so it isn't being caused by any addon. You can see by the image attachment all that shows are the container places for my addons unless I run Firefox in safe mode.
இது உங்களுக்கு பயனுள்ளதாக இருந்ததா?
மேற்கோள்
WestEnd
  • Top 25 Contributor
60 தீர்வுகள் 5373 பதில்கள்
பதிவிடப்பட்டது

That sounds like a security issue or something is ticking off the security measure to cause it to block the addons.

That sounds like a security issue or something is ticking off the security measure to cause it to block the addons.
இது உங்களுக்கு பயனுள்ளதாக இருந்ததா?
மேற்கோள்
FredMcD
  • Top 10 Contributor
4224 தீர்வுகள் 58976 பதில்கள்
பதிவிடப்பட்டது

Did you try to

FredMcD said

Type chrome://mozapps/content/extensions/extensions.xul? <enter> in the address bar.

Start your Computer in safe mode with network support. Then start Firefox. Is the problem still there?

http://encyclopedia2.thefreedictionary.com/Linux+Safe+Mode Starting Any Computer In Safe Mode; Free Online Encyclopedia

Did you try to ''FredMcD [[#answer-1208733|said]]'' <blockquote> Type '''chrome://mozapps/content/extensions/extensions.xul? '''<enter> in the address bar. </blockquote> ----------- Start your '''Computer''' in safe mode with network support. Then start Firefox. Is the problem still there? http://encyclopedia2.thefreedictionary.com/Linux+Safe+Mode Starting Any Computer In Safe Mode; Free Online Encyclopedia
இது உங்களுக்கு பயனுள்ளதாக இருந்ததா?
மேற்கோள்
பதிவிடப்பட்டது

கேள்வியின் உரிமையாளர்

Thanks for reply Fred. Tried that but was the same in Safe Mode.

Thanks for reply Fred. Tried that but was the same in Safe Mode.
இது உங்களுக்கு பயனுள்ளதாக இருந்ததா?
மேற்கோள்
FredMcD
  • Top 10 Contributor
4224 தீர்வுகள் 58976 பதில்கள்
பதிவிடப்பட்டது

Let’s do a full clean re-install;

Download Firefox For All languages And Systems {web link}

Save the file. Then Close Firefox.

Using your file browser, open the Programs Folder on your computer.

Windows: C:\Program Files C:\Program Files (x86) Note: Check Both Folders

Mac: Open the "Applications" folder. https://support.mozilla.org/en-US/kb/how-download-and-install-firefox-mac

Linux: Check your user manual. If you installed Firefox with the distro-based package manager, you should use the same way to uninstall it. See Install Firefox on Linux; https://support.mozilla.org/en-US/kb/install-firefox-linux

If you downloaded and installed the binary package from the Firefox download page, simply remove the folder Firefox in your home directory. http://www.mozilla.org/firefox#desktop ++++++++++++++++++++++++++++ Look for, and remove any Mozilla or Firefox program folders. Do not remove the Mozilla Thunderbird folder if there is one.

Do Not remove any profile folders.

After rebooting the computer, run a registry scanner if you have one. Then run the installer. +++++++++++++++++++++++++++ If there is a problem, start your Computer in safe mode and try again.

http://encyclopedia2.thefreedictionary.com/Linux+Safe+Mode This shows how to Start all Computers in Safe Mode; Free Online Encyclopedia

Let’s do a full clean re-install; [http://www.mozilla.org/en-US/firefox/all/ Download Firefox For All languages And Systems] {web link} Save the file. Then '''Close Firefox. ''' Using your file browser, open the '''Programs Folder''' on your computer. '''Windows: ''' C:\Program Files C:\Program Files (x86) '''Note:''' Check Both Folders '''Mac: ''' Open the ''' "Applications" ''' folder. https://support.mozilla.org/en-US/kb/how-download-and-install-firefox-mac '''Linux: ''' Check your user manual. If you installed Firefox with the distro-based package manager, you should use the same way to uninstall it. See Install Firefox on Linux; https://support.mozilla.org/en-US/kb/install-firefox-linux If you downloaded and installed the binary package from the Firefox download page, simply remove the folder Firefox in your home directory. http://www.mozilla.org/firefox#desktop ++++++++++++++++++++++++++++ Look for, and remove any '''Mozilla''' or '''Firefox''' program folders. Do not remove the '''Mozilla Thunderbird''' folder if there is one. '''Do Not''' remove any profile folders. After rebooting the computer, run a registry scanner if you have one. Then run the installer. +++++++++++++++++++++++++++ If there is a problem, start your '''Computer''' in safe mode and try again. http://encyclopedia2.thefreedictionary.com/Linux+Safe+Mode This shows how to Start all Computers in Safe Mode; Free Online Encyclopedia
இது உங்களுக்கு பயனுள்ளதாக இருந்ததா?
மேற்கோள்
பதிவிடப்பட்டது

கேள்வியின் உரிமையாளர்

Okay, deleted all Mozilla Firefox files in both Program files, rebooted and ran CCleaner a couple of times to clear registry.

Reinstalled Firefox but problem still shows with addons not visible.

Okay, deleted all Mozilla Firefox files in both Program files, rebooted and ran CCleaner a couple of times to clear registry. Reinstalled Firefox but problem still shows with addons not visible.
இது உங்களுக்கு பயனுள்ளதாக இருந்ததா?
மேற்கோள்
FredMcD
  • Top 10 Contributor
4224 தீர்வுகள் 58976 பதில்கள்
பதிவிடப்பட்டது

I called for more help.

It’s possible that there is a problem with the file(s) that store the extensions registry.

Type about:support in the address bar and press enter.

Under the page logo on the left side, you will see Application Basics. Under this find Profile Folder. To its right press the button Show Folder. This will open your file browser to the current Firefox profile. Now Close Firefox.

Windows: Show Folder; Linux: Open Directory; Mac: Show in Finder

Linux: Under the page logo on the left side, you will see Application Basics. Under this find Profile Directory. To its right press the button Open Directory.

Delete all extensions* files and compatibility.ini in the Firefox profile folder to reset the extensions registry.

New files will be created when required.

After, restart Firefox.

See "Corrupt extension files":

+++++++++++++++++++++++++++ You will have to approve the updating one last time.

I called for more help. It’s possible that there is a problem with the file(s) that store the extensions registry. Type '''about:support''' in the address bar and press enter. Under the page logo on the left side, you will see '''Application Basics. ''' Under this find '''Profile Folder. ''' To its right press the button '''Show Folder. ''' This will open your file browser to the current Firefox profile. Now '''Close Firefox. ''' Windows: Show Folder; Linux: Open Directory; Mac: Show in Finder '''Linux: ''' Under the page logo on the left side, you will see '''Application Basics.''' Under this find '''Profile Directory. ''' To its right press the button '''Open Directory. ''' Delete all '''extensions*''' files and '''compatibility.ini''' in the Firefox profile folder to reset the extensions registry. *https://support.mozilla.org/kb/Profiles New files will be created when required. After, restart Firefox. See "Corrupt extension files": *http://kb.mozillazine.org/Unable_to_install_themes_or_extensions *https://support.mozilla.org/kb/Unable+to+install+add-ons +++++++++++++++++++++++++++ You will have to approve the updating one last time.
இது உங்களுக்கு பயனுள்ளதாக இருந்ததா?
மேற்கோள்
பதிவிடப்பட்டது

கேள்வியின் உரிமையாளர்

Thanks again, I tried this before posting as had seen it on other posts.

Anyway just tried it again and still no difference.

It is as if something is stopping the addons, plugins and themes from showing, they are there and working but not visible unless I run Firefox in safe mode.

Thanks again, I tried this before posting as had seen it on other posts. Anyway just tried it again and still no difference. It is as if something is stopping the addons, plugins and themes from showing, they are there and working but not visible unless I run Firefox in safe mode.
இது உங்களுக்கு பயனுள்ளதாக இருந்ததா?
மேற்கோள்
FredMcD
  • Top 10 Contributor
4224 தீர்வுகள் 58976 பதில்கள்
பதிவிடப்பட்டது

Type about:support in the address bar and press Enter. Under the main banner, press the button; Copy Text To Clipboard.. Now in the Reply Box on the forum page, do a right-click in the box and select Paste.

This will show us your system details. No Personal Information Is Collected.

Type '''about:support''' in the address bar and press '''Enter.''' Under the main banner, press the button; '''Copy Text To Clipboard.'''. Now in the Reply Box on the forum page, do a right-click in the box and select '''Paste.''' This will show us your system details. '''No Personal Information Is Collected.'''
இது உங்களுக்கு பயனுள்ளதாக இருந்ததா?
மேற்கோள்
பதிவிடப்பட்டது

கேள்வியின் உரிமையாளர்

Not sure I want every program etc on my PC shown on a public forum.

Not sure I want every program etc on my PC shown on a public forum.
இது உங்களுக்கு பயனுள்ளதாக இருந்ததா?
மேற்கோள்
FredMcD
  • Top 10 Contributor
4224 தீர்வுகள் 58976 பதில்கள்
பதிவிடப்பட்டது

It only shows your system and Firefox information. Look it over if you want.

It only shows your system and Firefox information. Look it over if you want.
இது உங்களுக்கு பயனுள்ளதாக இருந்ததா?
மேற்கோள்
பதிவிடப்பட்டது

தீர்வு தேர்ந்தெடுக்கப்பட்டது

FredMcD said

It only shows your system and Firefox information. Look it over if you want.

Okay found solution from another poster on here by JayShankar as below..

Helpful Reply This thread seems to be active, so just in case it helps, here's my experience: After upgrading to Quantum (v. 65/66) I had exactly the same result with blank entries in the Add-ons Manager, although the add-ons themselves were working. Likewise, starting in safe mode revealed them successfully.

The culprit in my case was in my profile's chrome folder where I had installed a github custom css tweak, specifically the userContent.css file in that folder. The solution was very simple and painfully obvious: edit that file manually using textedit and comment out (/*) any lines containing "aboutaddons/addonlists". ... Voila! problem solved, the Add-ons Manager is back to normal.

I hope this helps anyone who might have the same problem originating in the chrome folder.

''FredMcD [[#answer-1209515|said]]'' <blockquote> It only shows your system and Firefox information. Look it over if you want. </blockquote> Okay found solution from another poster on here by JayShankar as below.. '''Helpful Reply This thread seems to be active, so just in case it helps, here's my experience: After upgrading to Quantum (v. 65/66) I had exactly the same result with blank entries in the Add-ons Manager, although the add-ons themselves were working. Likewise, starting in safe mode revealed them successfully. The culprit in my case was in my profile's chrome folder where I had installed a github custom css tweak, specifically the userContent.css file in that folder. The solution was very simple and painfully obvious: edit that file manually using textedit and comment out (/*) any lines containing "aboutaddons/addonlists". ... Voila! problem solved, the Add-ons Manager is back to normal. I hope this helps anyone who might have the same problem originating in the chrome folder.'''

Richchad மூலமாக திருத்தப்பட்டது

இது உங்களுக்கு பயனுள்ளதாக இருந்ததா?
மேற்கோள்
FredMcD
  • Top 10 Contributor
4224 தீர்வுகள் 58976 பதில்கள்
பதிவிடப்பட்டது

That was very good work. Well done. Please flag your last post as Solved Problem so others will know.

That was very good work. Well done. Please flag your last post as '''Solved Problem''' so others will know.
இது உங்களுக்கு பயனுள்ளதாக இருந்ததா?
மேற்கோள்
கேள்வி எழுப்பு

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.