X
Tap here to go to the mobile version of the site.

ஆதரவு மன்றம்

autoplay cannot be blocked

  • 6 replies
  • 5 இந்த பிரச்னைகள் உள்ளது
  • Last reply by koooper
பதிவிடப்பட்டது

I have the about:config autoplay set to "1" as you are supposed to, but when Firefox updated the other day autoplay has been enabled again. I have downloaded an add-on to try and block them, but I want to know why we can't block them ourselves, or why setting the about:config autoplay to "1" no longer works.

I have the about:config autoplay set to "1" as you are supposed to, but when Firefox updated the other day autoplay has been enabled again. I have downloaded an add-on to try and block them, but I want to know why we can't block them ourselves, or why setting the about:config autoplay to "1" no longer works.

Additional System Details

நிறுவப்பட்ட நிரல்கள்

  • Shockwave Flash 32.0 r0

பயன்பாடு

  • User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:66.0) Gecko/20100101 Firefox/66.0

கூடுதல் தகவல்

jscher2000
  • Top 10 Contributor
8794 தீர்வுகள் 71937 பதில்கள்
பதிவிடப்பட்டது

You can set Firefox 66 to block autoplay on sites using either of these methods (they are linked):

  • On the Options/Preferences page, Privacy & Security panel, check the box for "Block websites from automatically playing sound"
  • In about:config, set media.autoplay.default to 1

However, it doesn't work in every case: some sites start videos in a way that bypasses Firefox's definition of autoplay. However, the current emphasis is to avoid audio distractions, so Firefox still aims to silence videos that start playing automatically.

Add-ons may have a different method of monitoring videos starting so they might block videos on sites that Firefox misses.

You can set Firefox 66 to block autoplay on sites using either of these methods (they are linked): * On the Options/Preferences page, Privacy & Security panel, check the box for "Block websites from automatically playing sound" * In about:config, set '''media.autoplay.default''' to 1 However, it doesn't work in every case: some sites start videos in a way that bypasses Firefox's definition of autoplay. However, the current emphasis is to avoid audio distractions, so Firefox still aims to silence videos that start playing automatically. Add-ons may have a different method of monitoring videos starting so they might block videos on sites that Firefox misses.

jscher2000 மூலமாக திருத்தப்பட்டது

jscher2000
  • Top 10 Contributor
8794 தீர்வுகள் 71937 பதில்கள்
பதிவிடப்பட்டது

This Reddit post has suggested settings changes you could try, since you are already familiar with about:config. If you find a combination of settings that works well for your needs, please let us know.

https://www.reddit.com/r/firefox/comments/b35aed/is_mediaautoplaydefault_no_longer_supported_after/eixic0m/

This Reddit post has suggested settings changes you could try, since you are already familiar with about:config. If you find a combination of settings that works well for your needs, please let us know. https://www.reddit.com/r/firefox/comments/b35aed/is_mediaautoplaydefault_no_longer_supported_after/eixic0m/
பதிவிடப்பட்டது

கேள்வியின் உரிமையாளர்

Ok, first lets address that there is NO BOX on the privacy/security panel labeled "Block websites from automatically playing sound" in this newest version of firefox. So I can't do that. This part: "In about:config, set media.autoplay.default to 1" was already done but did not affect it. In fact, that was the whole purpose of this question, which is "why doesn't that work anymore?" In the reddit thread, there was one setting that I had not used, but it seems to have mixed results. The icon with the crossbar through the "play" button has re-appeared in my address bar (on some sites) but does not seem to always work. The question therefore remains: "why have they removed our ability to block autoplay videos?"

Ok, first lets address that there is NO BOX on the privacy/security panel labeled "Block websites from automatically playing sound" in this newest version of firefox. So I can't do that. This part: "In about:config, set media.autoplay.default to 1" was already done but did not affect it. In fact, that was the whole purpose of this question, which is "why doesn't that work anymore?" In the reddit thread, there was one setting that I had not used, but it seems to have mixed results. The icon with the crossbar through the "play" button has re-appeared in my address bar (on some sites) but does not seem to always work. The question therefore remains: "why have they removed our ability to block autoplay videos?"
jscher2000
  • Top 10 Contributor
8794 தீர்வுகள் 71937 பதில்கள்
பதிவிடப்பட்டது

CDukes said

Ok, first lets address that there is NO BOX on the privacy/security panel labeled "Block websites from automatically playing sound" in this newest version of firefox. So I can't do that.

What does yours look like in the area pictured in my screenshot?

Did you disable this setting as suggested in the Reddit discussion:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful or accepting the risk.

(2) In the search box above the list, type or paste autop and pause while the list is filtered

(3) Double-click the media.autoplay.allow-muted preference to switch the value from true to false

Did that make any difference?

As for the more general question: this feature has been in tweaking and testing for several versions now and this is the final reality of how this feature works, until they change it. Please also refer to my previous comments.

''CDukes [[#answer-1206704|said]]'' <blockquote> Ok, first lets address that there is NO BOX on the privacy/security panel labeled "Block websites from automatically playing sound" in this newest version of firefox. So I can't do that. </blockquote> What does yours look like in the area pictured in my screenshot? Did you disable this setting as suggested in the Reddit discussion: (1) In a new tab, type or paste '''about:config''' in the address bar and press Enter/Return. Click the button promising to be careful or accepting the risk. (2) In the search box above the list, type or paste '''autop''' and pause while the list is filtered (3) Double-click the '''media.autoplay.allow-muted''' preference to switch the value from true to false Did that make any difference? As for the more general question: this feature has been in tweaking and testing for several versions now and this is the final reality of how this feature works, until they change it. Please also refer to my previous comments.
cor-el
  • Top 10 Contributor
  • Moderator
17579 தீர்வுகள் 159041 பதில்கள்
பதிவிடப்பட்டது

You can also look at this extension.

You can also look at this extension. *Disable HTML5 Autoplay https://addons.mozilla.org/firefox/addon/disable-autoplay/
koooper 4 தீர்வுகள் 8 பதில்கள்
பதிவிடப்பட்டது

உதவிகரமான பதில்

To make the "stop autoplay" work again use these settings:

media.autoplay.default: 1 media.autoplay.enabled.user-gestures-needed: false media.autoplay.allow-muted: false

Although the "media.autoplay.enabled.user-gestures-needed" seems to be wrong it brings back the "stop autoplay" feature.

To make the "stop autoplay" work again use these settings: media.autoplay.default: '''1''' media.autoplay.enabled.user-gestures-needed: '''false''' media.autoplay.allow-muted: '''false''' Although the "media.autoplay.enabled.user-gestures-needed" seems to be wrong it brings back the "stop autoplay" feature.