X
Tap here to go to the mobile version of the site.

ஆதரவு மன்றம்

language switching does not work

  • 8 replies
  • 1 இந்த பிரச்சனை உள்ளது
  • Last reply by cor-el
பதிவிடப்பட்டது

Firefox (65.0.1) on my Mac (Mojave 10.12.2) started displaying everything in Dutch. No matter what I do, I can't get it to switch back to English.

I'm currently in the US (San Francisco), but even if I visit salesforce.com here, even the website defaults to Dutch.

So both the interface (menus etc) of Firefox itself, as well as the content displayed default to Dutch.

See attachment: preferences page is in Dutch, as are the menus at the top, and the tab with SalesForce. Despite that the settings are to show US english.

Firefox (65.0.1) on my Mac (Mojave 10.12.2) started displaying everything in Dutch. No matter what I do, I can't get it to switch back to English. I'm currently in the US (San Francisco), but even if I visit salesforce.com here, even the website defaults to Dutch. So both the interface (menus etc) of Firefox itself, as well as the content displayed default to Dutch. See attachment: preferences page is in Dutch, as are the menus at the top, and the tab with SalesForce. Despite that the settings are to show US english.
Attached screenshots

தீர்வு தேர்ந்தெடுக்கப்பட்டது

I had Dutch and US English installed (cannot remove Dutch). I now also added UK English, and that worked.

Read this answer in context 0
மேற்கோள்

Additional System Details

பயன்பாடு

  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.14; rv:65.0) Gecko/20100101 Firefox/65.0

கூடுதல் தகவல்

FredMcD
  • Top 10 Contributor
4193 தீர்வுகள் 58537 பதில்கள்
பதிவிடப்பட்டது

Are you saying the browser is not showing English, or the webpage? What about other webpages? Any problems?

If the webpage, try finding the language settings.

Are you saying the browser is not showing English, or the webpage? What about other webpages? Any problems? If the webpage, try finding the language settings.
இது உங்களுக்கு பயனுள்ளதாக இருந்ததா? 0
மேற்கோள்
பதிவிடப்பட்டது

கேள்வியின் உரிமையாளர்

Please see the screenshot I attached to the original post. I set it to English, yet everything keeps being in Dutch. (tried restarting, changing to another language and back, etc. to no avail)

Note: it used to work so it seems a recent update broke it.

Please see the screenshot I attached to the original post. I set it to English, yet everything keeps being in Dutch. (tried restarting, changing to another language and back, etc. to no avail) Note: it used to work so it seems a recent update broke it.
இது உங்களுக்கு பயனுள்ளதாக இருந்ததா?
மேற்கோள்
cor-el
  • Top 10 Contributor
  • Moderator
17346 தீர்வுகள் 156811 பதில்கள்
பதிவிடப்பட்டது

உதவிகரமான பதில்

Maybe (re)install the English Firefox version as you currently may have a Dutch Firefox version. You can find the full version of the current Firefox release (65.0.2) in all languages and all operating systems here:

Maybe (re)install the English Firefox version as you currently may have a Dutch Firefox version. You can find the full version of the current Firefox release (65.0.2) in all languages and all operating systems here: *https://www.mozilla.org/en-US/firefox/all/ *https://www.mozilla.org/en-US/firefox/65.0.2/releasenotes/
இது உங்களுக்கு பயனுள்ளதாக இருந்ததா? 1
மேற்கோள்
பதிவிடப்பட்டது

கேள்வியின் உரிமையாளர்

The about box is in English, so I guess I already have the English version. And as mentuioned above: it used to work, only recently stopped and switched to Dutch by itself

The about box is in English, so I guess I already have the English version. And as mentuioned above: it used to work, only recently stopped and switched to Dutch by itself
இது உங்களுக்கு பயனுள்ளதாக இருந்ததா?
மேற்கோள்
cor-el
  • Top 10 Contributor
  • Moderator
17346 தீர்வுகள் 156811 பதில்கள்
பதிவிடப்பட்டது

Firefox can only show the user interface in a different language when you have this specific locale installed or if you have a language pack for this language installed. Language packs are shown on "Options/Preferences -> Languages".

See also the "Internationalization & Localization" section on the "Help -> Troubleshooting Information" (about:support) page.

Firefox can only show the user interface in a different language when you have this specific locale installed or if you have a language pack for this language installed. Language packs are shown on "Options/Preferences -> Languages". See also the "Internationalization & Localization" section on the "Help -> Troubleshooting Information" (about:support) page.
இது உங்களுக்கு பயனுள்ளதாக இருந்ததா? 0
மேற்கோள்
பதிவிடப்பட்டது

தீர்வு தேர்ந்தெடுக்கப்பட்டது

I had Dutch and US English installed (cannot remove Dutch). I now also added UK English, and that worked.

I had Dutch and US English installed (cannot remove Dutch). I now also added UK English, and that worked.
இது உங்களுக்கு பயனுள்ளதாக இருந்ததா?
மேற்கோள்
pa_sharp 0 தீர்வுகள் 1 பதில்கள்
பதிவிடப்பட்டது

I had a similar problem just today (Mac OSX 10.14.5, Firefox 68.0). I have US and Norwegian keyboard installed on my MAc. At home, using external keyboard, no issue Firefox changing languages. I only have English language configured on Firefox.

Today, I worked from a coffee shop. FIrefox would change keyboard on my Mac. I'd go from one entry field to another and suddenly the keyboard would change. I'd set it back to US, do the same thing and it would change to Norwegian again. No keystrokes just clicking into the next field.

I thought I'd delete the Norwegian keyboard. But in Mac SysPref for Keyboard, I could not click the minus to get rid of Norwegian. I went to Safari and the same website I using when it switched keyboard and it did not switch keyboard.

So, something a bit odd it seems to be happening with the keyboard settings and Firefox.

I did notice when I got back home, the minus was now available on the Mac Keyboard SysPref.

I had a similar problem just today (Mac OSX 10.14.5, Firefox 68.0). I have US and Norwegian keyboard installed on my MAc. At home, using external keyboard, no issue Firefox changing languages. I only have English language configured on Firefox. Today, I worked from a coffee shop. FIrefox would change keyboard on my Mac. I'd go from one entry field to another and suddenly the keyboard would change. I'd set it back to US, do the same thing and it would change to Norwegian again. No keystrokes just clicking into the next field. I thought I'd delete the Norwegian keyboard. But in Mac SysPref for Keyboard, I could not click the minus to get rid of Norwegian. I went to Safari and the same website I using when it switched keyboard and it did not switch keyboard. So, something a bit odd it seems to be happening with the keyboard settings and Firefox. I did notice when I got back home, the minus was now available on the Mac Keyboard SysPref.

pa_sharp மூலமாக திருத்தப்பட்டது

இது உங்களுக்கு பயனுள்ளதாக இருந்ததா?
மேற்கோள்
cor-el
  • Top 10 Contributor
  • Moderator
17346 தீர்வுகள் 156811 பதில்கள்
பதிவிடப்பட்டது

Firefox stores some settings as part of the Site Preferences, so if you keep having problems then try to clear the Site Preferences via "Clear Recent History".

Firefox stores some settings as part of the Site Preferences, so if you keep having problems then try to clear the Site Preferences via "Clear Recent History".
இது உங்களுக்கு பயனுள்ளதாக இருந்ததா?
மேற்கோள்
கேள்வி எழுப்பு

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.