X
Tap here to go to the mobile version of the site.

ஆதரவு மன்றம்

Cookie permission button not working

  • 7 replies
  • 1 இந்த பிரச்சனை உள்ளது
  • Last reply by af32vxl
பதிவிடப்பட்டது

I'm experiencing a long-lived bug, or more possibly file corruption, that became important very recently. Due to another bug in Firefox 65 (https://support.mozilla.org/en-US/questions/1249037), I need to change cookie permissions. In the preference panel under "Cookies and Site Data", the "Manage Permissions" button doesn't work, although being not gray. After clicking this button, the expected window is not shown visibly. However invisible window still blocks keyboard and mouse input to the original firefox window. Clicking away from the center of the screen or Esc would disengage and possibly close the invisible window. The consequence is that I can't see or change permissions from this window. I have been having this problem for several firefox updates so it's more like a corrupted file. Despite that, cookie permissions still function properly and can be updated through the icon on the address bar.

Although there are workarounds such as through the icon on the address bar, this is really inconvenient and makes it hardly possible to edit cross site or cross subdomain cookie permissions. How do I figure out what is wrong and correct it please? I'm using Ubuntu 18.04.

I'm experiencing a long-lived bug, or more possibly file corruption, that became important very recently. Due to another bug in Firefox 65 (https://support.mozilla.org/en-US/questions/1249037), I need to change cookie permissions. In the preference panel under "Cookies and Site Data", the "Manage Permissions" button doesn't work, although being not gray. After clicking this button, the expected window is not shown visibly. However invisible window still blocks keyboard and mouse input to the original firefox window. Clicking away from the center of the screen or Esc would disengage and possibly close the invisible window. The consequence is that I can't see or change permissions from this window. I have been having this problem for several firefox updates so it's more like a corrupted file. Despite that, cookie permissions still function properly and can be updated through the icon on the address bar. Although there are workarounds such as through the icon on the address bar, this is really inconvenient and makes it hardly possible to edit cross site or cross subdomain cookie permissions. How do I figure out what is wrong and correct it please? I'm using Ubuntu 18.04.

தீர்வு தேர்ந்தெடுக்கப்பட்டது

Problem found to be in permissions.sqlite where permission='-1' is probably obsolete but neither taken care of properly nor overwritten in recent firefox versions. The following command solves the problem.

sqlite3 /path/to/profile/permissions.sqlite delete from moz_perms where type='cookie' and permission='-1'; .exit

Read this answer in context 0

Additional System Details

பயன்பாடு

  • User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:65.0) Gecko/20100101 Firefox/65.0

கூடுதல் தகவல்

பதிவிடப்பட்டது

கேள்வியின் உரிமையாளர்

And this problem doesn't occur on a new profile. I also migrated (/copied) the whole profile folder from a Mac to Ubuntu a few months ago, before which it was fine.

And this problem doesn't occur on a new profile. I also migrated (/copied) the whole profile folder from a Mac to Ubuntu a few months ago, before which it was fine.

af32vxl மூலமாக திருத்தப்பட்டது

philipp
  • Top 25 Contributor
  • Moderator
5304 தீர்வுகள் 23419 பதில்கள்
பதிவிடப்பட்டது

does the dialog shop up properly when you launch firefox in safemode once?

Troubleshoot Firefox issues using Safe Mode

does the dialog shop up properly when you launch firefox in safemode once? [[Troubleshoot Firefox issues using Safe Mode]]
பதிவிடப்பட்டது

கேள்வியின் உரிமையாளர்

I'm afriad no.

I'm afriad no.
cor-el
  • Top 10 Contributor
  • Moderator
17468 தீர்வுகள் 157853 பதில்கள்
பதிவிடப்பட்டது

You shouldn't copy a full profile folder from Mac to Linux because some files may contain absolute paths that are not compatible.. Best is to only copy (database) files you really need.

Maybe create a new profile and and check regularly if it keeps working.

You shouldn't copy a full profile folder from Mac to Linux because some files may contain absolute paths that are not compatible.. Best is to only copy (database) files you really need. *https://support.mozilla.org/en-US/kb/recovering-important-data-from-an-old-profile Maybe create a new profile and and check regularly if it keeps working.
பதிவிடப்பட்டது

கேள்வியின் உரிமையாளர்

Hi cor-el.

Thanks for the suggestion.

Nobody wants to copy the profile folder if there's a reliable & private way to achieve the same. Based on the close relation between the configuration file and the problem, how likely do you think that copying files selectively can maintain the cookie config and meanwhile solve the problem?

To me, a likely solution is to repair some (possibly one) file. Is that viable?

Hi cor-el. Thanks for the suggestion. Nobody wants to copy the profile folder if there's a reliable & private way to achieve the same. Based on the close relation between the configuration file and the problem, how likely do you think that copying files selectively can maintain the cookie config and meanwhile solve the problem? To me, a likely solution is to repair some (possibly one) file. Is that viable?
cor-el
  • Top 10 Contributor
  • Moderator
17468 தீர்வுகள் 157853 பதில்கள்
பதிவிடப்பட்டது

உதவிகரமான பதில்

For the cookies you would need cookies.sqlite. For the permissions you need permissions.sqlite. You may have to modify some setting manually in Options/Preferences, but prefs.js is a file that best is not to copy.

For the cookies you would need cookies.sqlite. For the permissions you need permissions.sqlite. You may have to modify some setting manually in Options/Preferences, but prefs.js is a file that best is not to copy.
பதிவிடப்பட்டது

தீர்வு தேர்ந்தெடுக்கப்பட்டது

Problem found to be in permissions.sqlite where permission='-1' is probably obsolete but neither taken care of properly nor overwritten in recent firefox versions. The following command solves the problem.

sqlite3 /path/to/profile/permissions.sqlite delete from moz_perms where type='cookie' and permission='-1'; .exit

Problem found to be in permissions.sqlite where permission='-1' is probably obsolete but neither taken care of properly nor overwritten in recent firefox versions. The following command solves the problem. sqlite3 /path/to/profile/permissions.sqlite delete from moz_perms where type='cookie' and permission='-1'; .exit