Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox freezes when i open a particular youtube video !

  • 12 பதிலளிப்புகள்
  • 1 இந்த பிரச்சனை உள்ளது
  • 92 views
  • Last reply by jscher2000

Hi My firefox freezes when i open this youtube video https://www.youtube.com/watch?v=QAU_8GEgSwI

I cant do anything in the interface which goes glitchy after a while, forcing me to shut it from task bar and restart. It took me a while to understand the problem was with the youtube video. If i dont open that link, everything works normal. Also, Earlier (till yesterday) i was watching that video without any such problem.

I tried updating and reinstalling firefox completely but still facing the same issue with this particular video. I cant figure out whats the problem !

Please help.

All Replies (12)

Separate Security Issue: Update your Flash Player or remove it using these links; Uninstall Flash Player | Windows {web link} Uninstall Flash Player | Mac {web link}

Note: Windows users should download the ActiveX for Internet Explorer. and the plugin for Plugin-based browsers (like Firefox).

Note: Windows 8 and Windows 10 have built-in flash players and Adobe will cause a conflict. Install the plugin only. Not the ActiveX.

Flash Player Version: Version 32.0.0.114

https://get.adobe.com/flashplayer/ Direct link scans current system and browser Note: Other software is offered in the download. <Windows Only>

https://get.adobe.com/flashplayer/otherversions/ Step 1: Select Operating System Step 2: Select A Version (Firefox, Win IE . . . .) Note: Other software is offered in the download. <Windows Only> +++++++++++++++++++ See if there are updates for your graphics drivers https://support.mozilla.org/en-US/kb/upgrade-graphics-drivers-use-hardware-acceleration

I am watching the clip now. So far no problems.

Start Firefox in Safe Mode {web link}

A small dialog should appear. Click Start In Safe Mode (not Refresh). Is the problem still there?

I watched 90% of the clip. No problems.

Hi Still having the problem. I completely uninstalled flash player our of windows.

I also tried watching the video in safe mode which delayed the freeze to a few seconds but still have the same problem.

I also installed 'youtube flash player' plugin to firefox but still have the problem.  :/ the UI freezes within 2 seconds when i click the link and the video/page is loading.

Nope. I dont know what else to do though.. I did cross checked my gpu drivers. They seem to be updated too.

For now i uninstalled the youtube flash player plugin from firefox.

When I check "Stats for nerds" on the right-click context menu, it indicates two potential issues (full size screenshot attached):

(1) I'm getting VP9-encoded video. This can be a real CPU hog, but it's common on YouTube these days, so if you don't have CPU issues on lots of videos, this might not be the thing to focus on.

If you think it's still worth ruling out, you could try this extension that pushes YouTube to use H.264 instead:

https://addons.mozilla.org/firefox/addon/h264ify/

(2) YouTube is sending me 60fps video, which I believe is double the data to decode compared with more typical 30fps video. So that may be more than you want.

I am aware of a userscript to hide 60fps capability from YouTube but I haven't tested it since July 2017 so I don't know how well it is working these days: https://greasyfork.org/en/scripts/23329-disable-youtube-60-fps-force-30-fps

This is also a feature listed for Iridium for YouTube, which has a comprehensive feature set that might be more complicated than you need, but could have some goodies you've always wanted: https://addons.mozilla.org/firefox/addon/particle-iridium/

This one lets you select lower resolution for 60fps videos, but I'm not sure that will improve your overall experience?? https://addons.mozilla.org/firefox/addon/youtube-auto-hd-fps/

Hey Thanks for digging in but it seems to be working fine after a complete system reboot; must be a windows glitch, i dont know though.

Also, since the video was working day before yesterday so i cant have any fps/codec problems from youtube.

Thank you for the help Jscher and fred ^^

Update : Its back again. I checked with playing the video in chrome. Same issue. UI completely freezes. Could this be a windows issue? Im running windows 10 x64

You could try one or both of the suggestions I gave before and see whether they make any difference.