X
Tap here to go to the mobile version of the site.

ஆதரவு மன்றம்

Firefox freezes when i open a particular youtube video !

  • 12 replies
  • 1 இந்த பிரச்சனை உள்ளது
  • Last reply by jscher2000
பதிவிடப்பட்டது

Hi My firefox freezes when i open this youtube video https://www.youtube.com/watch?v=QAU_8GEgSwI

I cant do anything in the interface which goes glitchy after a while, forcing me to shut it from task bar and restart. It took me a while to understand the problem was with the youtube video. If i dont open that link, everything works normal. Also, Earlier (till yesterday) i was watching that video without any such problem.

I tried updating and reinstalling firefox completely but still facing the same issue with this particular video. I cant figure out whats the problem !

Please help.

Hi My firefox freezes when i open this youtube video https://www.youtube.com/watch?v=QAU_8GEgSwI I cant do anything in the interface which goes glitchy after a while, forcing me to shut it from task bar and restart. It took me a while to understand the problem was with the youtube video. If i dont open that link, everything works normal. Also, Earlier (till yesterday) i was watching that video without any such problem. I tried updating and reinstalling firefox completely but still facing the same issue with this particular video. I cant figure out whats the problem ! Please help.

Additional System Details

நிறுவப்பட்ட நிரல்கள்

  • Shockwave Flash 28.0 r0

பயன்பாடு

  • User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:64.0) Gecko/20100101 Firefox/64.0

கூடுதல் தகவல்

FredMcD
  • Top 10 Contributor
4256 தீர்வுகள் 59602 பதில்கள்
பதிவிடப்பட்டது

Separate Security Issue: Update your Flash Player or remove it using these links; Uninstall Flash Player | Windows {web link} Uninstall Flash Player | Mac {web link}

Note: Windows users should download the ActiveX for Internet Explorer. and the plugin for Plugin-based browsers (like Firefox).

Note: Windows 8 and Windows 10 have built-in flash players and Adobe will cause a conflict. Install the plugin only. Not the ActiveX.

Flash Player Version: Version 32.0.0.114

https://get.adobe.com/flashplayer/ Direct link scans current system and browser Note: Other software is offered in the download. <Windows Only>

https://get.adobe.com/flashplayer/otherversions/ Step 1: Select Operating System Step 2: Select A Version (Firefox, Win IE . . . .) Note: Other software is offered in the download. <Windows Only> +++++++++++++++++++ See if there are updates for your graphics drivers https://support.mozilla.org/en-US/kb/upgrade-graphics-drivers-use-hardware-acceleration

'''Separate Security Issue:''' Update your Flash Player or remove it using these links; [http://helpx.adobe.com/flash-player/kb/uninstall-flash-player-windows.html Uninstall Flash Player | Windows] {web link} [http://helpx.adobe.com/flash-player/kb/uninstall-flash-player-mac-os.html Uninstall Flash Player | Mac] {web link} '''Note: Windows users''' should download the '''ActiveX''' for ''Internet Explorer.'' '''and''' the '''plugin''' for ''Plugin-based browsers'' (like Firefox). '''Note: Windows 8 and Windows 10''' have built-in flash players and Adobe will cause a conflict. Install the plugin only. Not the ActiveX. Flash Player Version: '''Version 32.0.0.114 ''' https://get.adobe.com/flashplayer/ Direct link scans current system and browser '''Note: Other software''' is offered in the download. <Windows Only> https://get.adobe.com/flashplayer/otherversions/ Step 1: Select Operating System Step 2: Select A Version (Firefox, Win IE . . . .) '''Note: Other software''' is offered in the download. <Windows Only> +++++++++++++++++++ See if there are updates for your graphics drivers https://support.mozilla.org/en-US/kb/upgrade-graphics-drivers-use-hardware-acceleration
FredMcD
  • Top 10 Contributor
4256 தீர்வுகள் 59602 பதில்கள்
பதிவிடப்பட்டது

I am watching the clip now. So far no problems.

Start Firefox in Safe Mode {web link}

A small dialog should appear. Click Start In Safe Mode (not Refresh). Is the problem still there?

I am watching the clip now. So far no problems. [https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode Start Firefox in Safe Mode] {web link} A small dialog should appear. Click '''Start In Safe Mode''' (not Refresh). Is the problem still there?
FredMcD
  • Top 10 Contributor
4256 தீர்வுகள் 59602 பதில்கள்
பதிவிடப்பட்டது

I watched 90% of the clip. No problems.

I watched 90% of the clip. No problems.
பதிவிடப்பட்டது

கேள்வியின் உரிமையாளர்

Hi Still having the problem. I completely uninstalled flash player our of windows.

I also tried watching the video in safe mode which delayed the freeze to a few seconds but still have the same problem.

I also installed 'youtube flash player' plugin to firefox but still have the problem.  :/ the UI freezes within 2 seconds when i click the link and the video/page is loading.

Hi Still having the problem. I completely uninstalled flash player our of windows. I also tried watching the video in safe mode which delayed the freeze to a few seconds but still have the same problem. I also installed 'youtube flash player' plugin to firefox but still have the problem. :/ the UI freezes within 2 seconds when i click the link and the video/page is loading.
FredMcD
  • Top 10 Contributor
4256 தீர்வுகள் 59602 பதில்கள்
பதிவிடப்பட்டது
Youtube currently uses the HTML5 player. https://support.mozilla.org/en-US/kb/fix-common-audio-and-video-issues
பதிவிடப்பட்டது

கேள்வியின் உரிமையாளர்

Okay, thanks for the help.

Okay, thanks for the help.
FredMcD
  • Top 10 Contributor
4256 தீர்வுகள் 59602 பதில்கள்
பதிவிடப்பட்டது

Is the problem fixed?

Is the problem fixed?
பதிவிடப்பட்டது

கேள்வியின் உரிமையாளர்

Nope. I dont know what else to do though.. I did cross checked my gpu drivers. They seem to be updated too.

For now i uninstalled the youtube flash player plugin from firefox.

Nope. I dont know what else to do though.. I did cross checked my gpu drivers. They seem to be updated too. For now i uninstalled the youtube flash player plugin from firefox.
jscher2000
  • Top 10 Contributor
8763 தீர்வுகள் 71700 பதில்கள்
பதிவிடப்பட்டது

When I check "Stats for nerds" on the right-click context menu, it indicates two potential issues (full size screenshot attached):

(1) I'm getting VP9-encoded video. This can be a real CPU hog, but it's common on YouTube these days, so if you don't have CPU issues on lots of videos, this might not be the thing to focus on.

If you think it's still worth ruling out, you could try this extension that pushes YouTube to use H.264 instead:

https://addons.mozilla.org/firefox/addon/h264ify/

(2) YouTube is sending me 60fps video, which I believe is double the data to decode compared with more typical 30fps video. So that may be more than you want.

I am aware of a userscript to hide 60fps capability from YouTube but I haven't tested it since July 2017 so I don't know how well it is working these days: https://greasyfork.org/en/scripts/23329-disable-youtube-60-fps-force-30-fps

This is also a feature listed for Iridium for YouTube, which has a comprehensive feature set that might be more complicated than you need, but could have some goodies you've always wanted: https://addons.mozilla.org/firefox/addon/particle-iridium/

This one lets you select lower resolution for 60fps videos, but I'm not sure that will improve your overall experience?? https://addons.mozilla.org/firefox/addon/youtube-auto-hd-fps/

When I check "Stats for nerds" on the right-click context menu, it indicates two potential issues (full size screenshot attached): <center><img src="https://prod-cdn.sumo.mozilla.net/uploads/images/2019-01-13-12-56-05-f9cad5.png" width="480"></center> (1) I'm getting VP9-encoded video. This can be a real CPU hog, but it's common on YouTube these days, so if you don't have CPU issues on lots of videos, this might not be the thing to focus on. If you think it's still worth ruling out, you could try this extension that pushes YouTube to use H.264 instead: https://addons.mozilla.org/firefox/addon/h264ify/ (2) YouTube is sending me 60fps video, which I believe is double the data to decode compared with more typical 30fps video. So that may be more than you want. I am aware of a userscript to hide 60fps capability from YouTube but I haven't tested it since July 2017 so I don't know how well it is working these days: https://greasyfork.org/en/scripts/23329-disable-youtube-60-fps-force-30-fps This is also a feature listed for Iridium for YouTube, which has a comprehensive feature set that might be more complicated than you need, but could have some goodies you've always wanted: https://addons.mozilla.org/firefox/addon/particle-iridium/ This one lets you select lower resolution for 60fps videos, but I'm not sure that will improve your overall experience?? https://addons.mozilla.org/firefox/addon/youtube-auto-hd-fps/
பதிவிடப்பட்டது

கேள்வியின் உரிமையாளர்

Hey Thanks for digging in but it seems to be working fine after a complete system reboot; must be a windows glitch, i dont know though.

Also, since the video was working day before yesterday so i cant have any fps/codec problems from youtube.

Thank you for the help Jscher and fred ^^

Hey Thanks for digging in but it seems to be working fine after a complete system reboot; must be a windows glitch, i dont know though. Also, since the video was working day before yesterday so i cant have any fps/codec problems from youtube. Thank you for the help Jscher and fred ^^
பதிவிடப்பட்டது

கேள்வியின் உரிமையாளர்

Update : Its back again. I checked with playing the video in chrome. Same issue. UI completely freezes. Could this be a windows issue? Im running windows 10 x64

Update : Its back again. I checked with playing the video in chrome. Same issue. UI completely freezes. Could this be a windows issue? Im running windows 10 x64
jscher2000
  • Top 10 Contributor
8763 தீர்வுகள் 71700 பதில்கள்
பதிவிடப்பட்டது

You could try one or both of the suggestions I gave before and see whether they make any difference.

You could try one or both of the suggestions I gave before and see whether they make any difference.